# 403 Forbidden Form error

**URL:** <https://forum.mautic.org/t/403-forbidden-form-error/6188>\
**Category:** Product Support\
**Created:** [October 11, 2016, 12:38pm UTC](https://forum.mautic.org/t/403-forbidden-form-error/6188 "2016-10-11T12:38:02Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![pautena](https://avatars.discourse-cdn.com/v4/letter/p/c57346/32.png) [@pautena](https://forum.mautic.org/u/pautena)\
**Post date:** [October 11, 2016, 12:38pm UTC](https://forum.mautic.org/t/403-forbidden-form-error/6188/1 "2016-10-11T12:38:02Z")

</div>

Each time I submit a form that is inside a landing page I get a 403 Forbidden.  
  
  
  
_Failed to load resource: the server responded with a status of 403 (Forbidden)_  
  
  
  
Our mautic is installed in a digital ocean VPS (apache).  
  
I’ve used the following line in htcaccess in an attempt to provide origin permissions:  
  
  
  
_Header set Access-Control-Allow-Origin “\*”_  
  
  
  
The error remains there anyway. Can anyone provide any advice? Thank you.

---

<div class="post-metadata">

**Author:** ![pautena](https://avatars.discourse-cdn.com/v4/letter/p/c57346/32.png) [@pautena](https://forum.mautic.org/u/pautena)\
**Post date:** [October 11, 2016, 12:38pm UTC](https://forum.mautic.org/t/403-forbidden-form-error/6188/2 "2016-10-11T12:38:02Z")

</div>

Each time I submit a form that is inside a landing page I get a 403 Forbidden.

Failed to load resource: the server responded with a status of 403 (Forbidden)

Our mautic is installed in a digital ocean VPS (apache).  
I’ve used the following line in htcaccess in an attempt to provide origin permissions:

Header set Access-Control-Allow-Origin “\*”

The error remains there anyway. Can anyone provide any advice? Thank you.

---

<div class="post-metadata">

**Author:** ![Elenchus](https://avatars.discourse-cdn.com/v4/letter/e/ccd318/32.png) [@Elenchus](https://forum.mautic.org/u/Elenchus)\
**Post date:** [October 15, 2016, 9:36pm UTC](https://forum.mautic.org/t/403-forbidden-form-error/6188/3 "2016-10-15T21:36:51Z")

</div>

I have a possibly related issue: I’m getting a 403 error on the Mautic tracking pixel in Chrome’s console. I checked the folder permissions, and it seems fine.

---

<div class="post-metadata">

**Author:** ![Elenchus](https://avatars.discourse-cdn.com/v4/letter/e/ccd318/32.png) [@Elenchus](https://forum.mautic.org/u/Elenchus)\
**Post date:** [October 16, 2016, 1:40am UTC](https://forum.mautic.org/t/403-forbidden-form-error/6188/4 "2016-10-16T01:40:03Z")

</div>

Update:  
Have a look here for more information on this - [http://stackoverflow.com/questions/10636611/how-does-access-control-allow-origin-header-work](http://stackoverflow.com/questions/10636611/how-does-access-control-allow-origin-header-work)

I ended up adding this to .htaccess in my mautic folder:

 Header set Access-Control-Allow-Origin http:// mysite .com Header set Access-Control-Allow-Credentials true Header set Access-Control-Allow-Methods: GET, POST, PATCH, PUT, OPTIONS Header set Access-Control-Allow-Headers: Origin, Content-Type, X-Auth-Token

N.B. replace mysite .com with your site name, or use the line you used in your initial post.

EDIT: Ok, this method has caused normal mautic use to return a 500 error. I’ll keep working on it.

---

<div class="post-metadata">

**Author:** ![ricardomartins](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ricardomartins/32/198_2.png) [@ricardomartins](https://forum.mautic.org/u/ricardomartins)\
**Post date:** [August 22, 2017, 5:11am UTC](https://forum.mautic.org/t/403-forbidden-form-error/6188/5 "2017-08-22T05:11:27Z")

</div>

In my case the problem was that depending on the type of form you use, Mautic sets the action="//yourmautic…" instead of placing the mautic url with the full protocol.  
As my Mautic has HTTPS and the site I was trying to install the form modal doesn’t has https, Mautic tried to make a 302 redirect with the POST data, but it becames a GET request which doesn’t work.

The easiest solution in my case was install a let’s encrypt certificate on the site I was trying to install the form. 😮
