# 500 error when installing after admin user   - PHP Fatal error:  require(): Failed opening required

**URL:** <https://forum.mautic.org/t/500-error-when-installing-after-admin-user-php-fatal-error-require-failed-opening-required/6652>\
**Category:** Product Support\
**Created:** [November 24, 2016, 10:54am UTC](https://forum.mautic.org/t/500-error-when-installing-after-admin-user-php-fatal-error-require-failed-opening-required/6652 "2016-11-24T10:54:33Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![phillip](https://avatars.discourse-cdn.com/v4/letter/p/3e96dc/32.png) [@phillip](https://forum.mautic.org/u/phillip)\
**Post date:** [November 24, 2016, 10:54am UTC](https://forum.mautic.org/t/500-error-when-installing-after-admin-user-php-fatal-error-require-failed-opening-required/6652/1 "2016-11-24T10:54:33Z")

</div>

Hello,  
  
  
  
I’m trying to instal Mautic on a fresh Amazon Linux EC2 server running php 7.0, mysql and apache 2.2. I have not yet made any major changes to php.ini, httpd.conf, etc but will do later.  
  
  
  
During the instal process I get to the ‘Mautic Installation - Administrative User’ fine but when I click next, I get a 500 server error page.  
  
  
  
Here is the error from errors\_log:  
  
  
  
[Thu Nov 24 10:37:14.566634 2016] [:error] [pid 32109] [client 151.226.161.42:59168] PHP Fatal error: require(): Failed opening required ‘/var/www/html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=’.:/usr/share/pear7:/usr/share/php7’) in /var/www/html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209, referer: [http://www.millsmeyer.com/mautic/index.php/installer/step/2](http://www.millsmeyer.com/mautic/index.php/installer/step/2)  
  
  
  
I have mautic installed in a sub-directory /var/www/html/mautic but I’m not sure if that is causing the problem. I get the vague impression from searching online that this might be caused by a .htaccess file but I’m not sure.  
  
  
  
Can anyone help please?

---

<div class="post-metadata">

**Author:** ![phillip](https://avatars.discourse-cdn.com/v4/letter/p/3e96dc/32.png) [@phillip](https://forum.mautic.org/u/phillip)\
**Post date:** [November 24, 2016, 10:54am UTC](https://forum.mautic.org/t/500-error-when-installing-after-admin-user-php-fatal-error-require-failed-opening-required/6652/2 "2016-11-24T10:54:33Z")

</div>

Hello,

I’m trying to instal Mautic on a fresh Amazon Linux EC2 server running php 7.0, mysql and apache 2.2. I have not yet made any major changes to php.ini, httpd.conf, etc but will do later.

During the instal process I get to the ‘Mautic Installation - Administrative User’ fine but when I click next, I get a 500 server error page.

Here is the error from errors\_log:

[Thu Nov 24 10:37:14.566634 2016] [:error] [pid 32109] [client 151.226.161.42:59168] PHP Fatal error: require(): Failed opening required ‘/var/www/html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=’.:/usr/share/pear7:/usr/share/php7’) in /var/www/html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209, referer: [http://www.millsmeyer.com/mautic/index.php/installer/step/2](http://www.millsmeyer.com/mautic/index.php/installer/step/2)

I have mautic installed in a sub-directory /var/www/html/mautic but I’m not sure if that is causing the problem. I get the vague impression from searching online that this might be caused by a .htaccess file but I’m not sure.

Can anyone help please?

---

<div class="post-metadata">

**Author:** ![phillip](https://avatars.discourse-cdn.com/v4/letter/p/3e96dc/32.png) [@phillip](https://forum.mautic.org/u/phillip)\
**Post date:** [November 24, 2016, 10:59am UTC](https://forum.mautic.org/t/500-error-when-installing-after-admin-user-php-fatal-error-require-failed-opening-required/6652/3 "2016-11-24T10:59:33Z")

</div>

Answering my own question, this appears to be cache issue! No idea how there can be a cache issue with a new install, surely a problem with the code uploaded by Mautic?

just delete everything in app/cache/prod

cd app/cache/prod  
sudo rm -R \*

---

<div class="post-metadata">

**Author:** ![CraigM](https://avatars.discourse-cdn.com/v4/letter/c/f14d63/32.png) [@CraigM](https://forum.mautic.org/u/CraigM)\
**Post date:** [February 7, 2017, 8:06pm UTC](https://forum.mautic.org/t/500-error-when-installing-after-admin-user-php-fatal-error-require-failed-opening-required/6652/4 "2017-02-07T20:06:00Z")

</div>

This fixed my issue too. Installation of an upgrade to Mautic hung during the final step.

The error was: ERROR Fatal error: require\_once():

I waited a couple of days thinking that it would clear itself, but no.

I deleted the Mautic/app/cache/prod from within an FTP client.

The Mautic issue was resolved and I was able to log in correctly.

---

<div class="post-metadata">

**Author:** ![inkovic](https://avatars.discourse-cdn.com/v4/letter/i/9fc29f/32.png) [@inkovic](https://forum.mautic.org/u/inkovic)\
**Post date:** [October 26, 2017, 10:00pm UTC](https://forum.mautic.org/t/500-error-when-installing-after-admin-user-php-fatal-error-require-failed-opening-required/6652/5 "2017-10-26T22:00:53Z")

</div>

I got this issue as well. Mautic kind of ‘hung’ at the last step of installation when attempting to clear application cache and manually doing it resolved this for me too.
