# After 3.2.1 to 3.2.5 upgrade, php bin/console throws error

**URL:** <https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145>\
**Category:** Product Support\
**Created:** [February 13, 2021, 2:58pm UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145 "2021-02-13T14:58:25Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![ralf\_muhlberger](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ralf_muhlberger/32/826_2.png) [@ralf\_muhlberger](https://forum.mautic.org/u/ralf_muhlberger)\
**Post date:** [February 13, 2021, 2:58pm UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145/1 "2021-02-13T14:58:25Z")

</div>

**Your software**  
_My PHP version is_ : 7.3.20 as per Mautic system info, although on command line I can only seem to get to a PHP version 7.2.24  
_My MySQL version is_ 5.0.12

**Updating/Installing Errors**  
_I am_ : Updating from 3.2.1 to 3.2.5  
_Upgrading via_ Web

_These errors are showing in the installer_ : none

_These errors are showing in the Mautic log_ : Only some mail issues because I was hitting the send limit of my smtp relay. I’ve now switched to AWS SES, but the system keeps trying to send emails through the old servers. That’s in part why I was updating, as I saw that some mail related bugs had been fixed.

_These errors are showing in the upgrade\_log.txt file (located in the root of your Mautic instance when an upgrade has been attempted - ensure you remove or redact any sensitive data such as domain names in the file path)_ : There is no upgrade\_log.txt file

**Your problem**  
_My problem is_ :  
After running the upgrade from 3.2.1 to 3.2.5, Mautic says that I am running 3.2.5, but my command line tasks, including cron jobs, that use bin/console now throw the following error:

* * *

Type error: Too few arguments to function Mautic\LeadBundle\Model\ListModel  
::\_\_construct(), 3 passed in /var/www/html/var/cache/prod/Container1ptoicy/  
appProdProjectContainer.php on line 9560 and exactly 4 expected

* * *

_Steps I have tried to fix the problem_ :

- clearing the cache

- lots and lots of web searching, to no avail

- looked at line 9560 in the file mentioned above, but can’t work out where the issue here might be

---

<div class="post-metadata">

**Author:** ![ralf\_muhlberger](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ralf_muhlberger/32/826_2.png) [@ralf\_muhlberger](https://forum.mautic.org/u/ralf_muhlberger)\
**Post date:** [February 14, 2021, 12:07am UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145/2 "2021-02-14T00:07:19Z")

</div>

I deleted the files in that cache directory, and it appears to be working again.

---

<div class="post-metadata">

**Author:** ![ralf\_muhlberger](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ralf_muhlberger/32/826_2.png) [@ralf\_muhlberger](https://forum.mautic.org/u/ralf_muhlberger)\
**Post date:** [February 14, 2021, 12:10am UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145/3 "2021-02-14T00:10:15Z")

</div>

I’ve now also run

$ php bin/console doctrine:migration:status  
$ php bin/console doctrine:migration:migrate

and cleared the cache again. Running these a second time tells me that there are no more migrations to run.

Is there anything else that I might have to do?

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 14, 2021, 4:34pm UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145/4 "2021-02-14T16:34:05Z")

</div>

Hi there, you should only need to do those steps if your upgrade failed for some reason. Did you try to upgrade in the UI and have it get stuck or something?

You should always follow these steps if you get stuck with an update:

> **[Update Failed](https://docs.mautic.org/en/troubleshooting/update-failed)**
>
> . Sometimes when updating Mautic, the process might stall or fail part way through. This can cause a problem, because it can cause Mautic to be inbetween two versions and often this can make the system unusable.The following processes can be followed...

---

<div class="post-metadata">

**Author:** ![ralf\_muhlberger](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ralf_muhlberger/32/826_2.png) [@ralf\_muhlberger](https://forum.mautic.org/u/ralf_muhlberger)\
**Post date:** [February 15, 2021, 12:09am UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145/5 "2021-02-15T00:09:57Z")

</div>

I didn’t think it had, but I’m wondering now whether it did get stuck in the cache clean and I didn’t notice. My problem was actually that the cache at `/var/www/html/var/cache` wasn’t cleaned out, and still causing a problem. I’m not sure what is using this second cache, rather than the one in the mautic directory tree, but deleting those files fixed the issue. Might be something to add to that advice document.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 15, 2021, 11:59am UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145/6 "2021-02-15T11:59:27Z")

</div>

/var/cache is your Mautic cache.

Maybe you have an error in the file path in your Mautic config if the cache is some place other than the Mautic root?

 ![screenshot-mautic32.ddev.site-2021.02.15-11_58_34](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/b/b04d114bda33618d64afee70f2134b7a0dc5b350.png)

---

<div class="post-metadata">

**Author:** ![ralf\_muhlberger](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ralf_muhlberger/32/826_2.png) [@ralf\_muhlberger](https://forum.mautic.org/u/ralf_muhlberger)\
**Post date:** [February 22, 2021, 5:06am UTC](https://forum.mautic.org/t/after-3-2-1-to-3-2-5-upgrade-php-bin-console-throws-error/18145/7 "2021-02-22T05:06:51Z")

</div>

There seemed to be a cache of something else in /var/www/html/var/cache/prod/ that caused the problem, separate from the mautic/var/cache directory.

All working fine now. Maybe just one of those tech gremlins that happen once every gazillion ticks 😉
