# After installation: Uh oh! I think I broke it - 500 Internal Server Error

**URL:** <https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563>\
**Category:** Product Support\
**Created:** [March 22, 2020, 11:41pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563 "2020-03-22T23:41:07Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![alpha2020](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/alpha2020/32/2038_2.png) [@alpha2020](https://forum.mautic.org/u/alpha2020)\
**Post date:** [March 22, 2020, 11:41pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/1 "2020-03-22T23:41:08Z")

</div>

**Your software**  
My Mautic version is: 2.16.0  
My PHP version is: 7.0.33

**Your problem**  
**My problem is:**  
After Mautic installation using Softaculous I started to work with Mautic. I configured Email settings (using Amazon SES) and I began to create segments. Then I made a break and when I tried to login as admin a couples of minutes later I received the login error page

"Quote

### The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

#### System administrators, check server logs for errors.

# Uh oh! I think I broke it. If I do it again, please report me to the system administrator!

> #### **500** Internal Server Error

Unquote"

**These errors are showing in the log:**

[2020-03-22 14:30:05] mautic.WARNING: PHP Warning - require(/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php): failed to open stream: No such file or directory - in file /home/bestback/public\_html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 {“className”:“Mautic\CategoryBundle\Entity\Category”,“classMetadata”:“[object] (Doctrine\ORM\Mapping\ClassMetadata: Doctrine\ORM\Mapping\ClassMetadataInfo@000000002f452922000000005b9391a3)”,“proxyClassName”:“Proxies\ **CG** \Mautic\CategoryBundle\Entity\Category”,“fileName”:“/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php”}

[2020-03-22 14:30:05] mautic.WARNING: PHP Warning - require(/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php): failed to open stream: No such file or directory - in file /home/bestback/public\_html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 {“className”:“Mautic\CategoryBundle\Entity\Category”,“classMetadata”:“[object] (Doctrine\ORM\Mapping\ClassMetadata: Doctrine\ORM\Mapping\ClassMetadataInfo@000000002f452922000000005b9391a3)”,“proxyClassName”:“Proxies\ **CG** \Mautic\CategoryBundle\Entity\Category”,“fileName”:“/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php”}

[2020-03-22 14:30:05] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php’ (include\_path=‘.:/opt/cpanel/ea-php70/root/usr/share/pear’) - in file /home/bestback/public\_html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209

[[2020-03-22 14:30:05] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php’ (include\_path=‘.:/opt/cpanel/ea-php70/root/usr/share/pear’) - in file /home/bestback/public\_html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209

[2020-03-22 14:30:05] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalErrorException: “Compile Error: require(): Failed opening required ‘/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php’ (include\_path=‘.:/opt/cpanel/ea-php70/root/usr/share/pear’)” at /home/bestback/public\_html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php line 209 {“exception”:“[object] (Symfony\Component\Debug\Exception\FatalErrorException(code: 0): Compile Error: require(): Failed opening required ‘/home/bestback/public\_html/mautic/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticCategoryBundleEntityCategory.php’ (include\_path=‘.:/opt/cpanel/ea-php70/root/usr/share/pear’) at /home/bestback/public\_html/mautic/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php:209)”}

**Steps I have tried to fix the problem:**

I read several of the support post in this forum about that error. I cleared the app/cache as recommended without any positive result.

The installation is on a shared web hosting account. Unfortunately (regarding this problem), I am not very familiar with PHP commands of how to run these on a shared hosting account.

Do I have to create a new repair.php file and save it in the Mautic directory and run it in order for the included PHP commands to execute???

I believe that Mautic is a really great application and I want to use it. I hope that I can get the help that I need to fix that problem

Thank you so much!

---

<div class="post-metadata">

**Author:** ![iamisearojob](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/iamisearojob/32/2197_2.png) [@iamisearojob](https://forum.mautic.org/u/iamisearojob)\
**Post date:** [March 23, 2020, 7:06am UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/2 "2020-03-23T07:06:59Z")

</div>

Yeah me too thats why am sticking around  
Try create a sub domain and re do installation again use softaculous so you dont have to worry about any details being correct or not.  
If it works remove previous installation where you want it and re install using softaculous

---

<div class="post-metadata">

**Author:** ![alpha2020](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/alpha2020/32/2038_2.png) [@alpha2020](https://forum.mautic.org/u/alpha2020)\
**Post date:** [March 23, 2020, 2:11pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/3 "2020-03-23T14:11:45Z")

</div>

Thanks for your tip

I tried it and it did fail too! Login was not even possible - error page showed right away.

---

<div class="post-metadata">

**Author:** ![iamisearojob](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/iamisearojob/32/2197_2.png) [@iamisearojob](https://forum.mautic.org/u/iamisearojob)\
**Post date:** [March 24, 2020, 9:38am UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/4 "2020-03-24T09:38:41Z")

</div>

That could be a problem with your hosting provider and database issues  
I have been carrying out test with mautic since 2 weeks ago  
with over 15 installation and none has failed if used softaculous.

I only changed hosting when page hit wasnt working then later knew its mautic issue not hosting.

Get a cheap hosting for test like $5 or so am sure it will work then you can get your hosting to fix their issues

---

<div class="post-metadata">

**Author:** ![alpha2020](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/alpha2020/32/2038_2.png) [@alpha2020](https://forum.mautic.org/u/alpha2020)\
**Post date:** [March 24, 2020, 5:41pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/5 "2020-03-24T17:41:54Z")

</div>

Thanks for your reply.

Could you please tell me which issues my web hosting service has to fix? I am a novice in these matters?

---

<div class="post-metadata">

**Author:** ![sourdoughbread](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/sourdoughbread/32/2060_2.png) [@sourdoughbread](https://forum.mautic.org/u/sourdoughbread)\
**Post date:** [March 24, 2020, 8:26pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/6 "2020-03-24T20:26:56Z")

</div>

I have also installed Mautic using Softaculous on my shared hosting without any issues.

Did you install it on a subdomain? Which hosting are you using?

Feel free to PM me.

---

<div class="post-metadata">

**Author:** ![alpha2020](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/alpha2020/32/2038_2.png) [@alpha2020](https://forum.mautic.org/u/alpha2020)\
**Post date:** [March 24, 2020, 9:27pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/7 "2020-03-24T21:27:16Z")

</div>

Thanks for your reply!

I did both install it on a sub-domain and in a directory. The current installation is in a directory

I have an account with an UK firm named Brixly

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [March 25, 2020, 10:20am UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/8 "2020-03-25T10:20:33Z")

</div>

Hi there,

This is almost always a file/folder ownership/permissions issue.

As this is coming up with increasing frequency in the forums I’ve written up an article for the docs which you can find here:

> **[File ownership and permissions](https://docs.mautic.org/en/troubleshooting/file-ownership-and-permissions)**
>
> . If you experience errors like the following:. mautic.WARNING: PHP Warning require(/mautic/app/cache/prod/doctrine/orm/Proxies/CGMauticCategoryBundleEntityCategory.php): failed to open stream: No such file or directory - in file...

Hope this helps!

---

<div class="post-metadata">

**Author:** ![alpha2020](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/alpha2020/32/2038_2.png) [@alpha2020](https://forum.mautic.org/u/alpha2020)\
**Post date:** [March 28, 2020, 7:57pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/9 "2020-03-28T19:57:10Z")

</div>

Hi,

After I tried to execute/run all recommended CLI commands Mautic still showed the same error page and the same error messages in the error logs

Nevertheless, Mautic is such a great app that I really want to work with it - I think it is one of the best apps for customer relations and email automation.

I am a very satisfied customer of Brixly, a UK web hosting company. I thought that it would be a good idea to ask their customer support for help. I told them what I did and what error messages I got and I informed them about [rcheesley](https://forum.mautic.org/u/rcheesley)’s recommendations.

After some minutes MAUTIC was working (and since then) and I asked what Brixly support did to get Mautic running.

This is their answer and I hope that this will help a lot of shared hosting customers around the world who want to run Mautic and face the same problems as I did:

> Quote
> 
> Hey Tony,
> 
> We run a bash script from here, which sets permissions to ‘default’ or recommended values. We tend to use the following…
> 
> [GitHub - PeachFlame/cPanel-fixperms: A script to fix permissions & ownership, on files & directories, for cPanel accounts.](https://github.com/PeachFlame/cPanel-fixperms)
> 
> This would need to be run from our end, but only corrects any permissions back to what they would be / should be when the account is created.
> 
> Pleasure, glad it’s working fine which is the main thing 🙂 keep safe!
> 
> Kind Regards,
> 
> Dennis Nind  
> Snr. Technical Analyst / CEO  
> cPanel Professional Certified (CPP, CWA)  
> Brixly Web Solutions ([https://brixly.uk](https://brixly.uk/))
> 
> Unquote

I hope this helps you as it did me

Best,  
Tony

---

<div class="post-metadata">

**Author:** ![dirk\_s](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dirk_s/32/748_2.png) [@dirk\_s](https://forum.mautic.org/u/dirk_s)\
**Post date:** [March 28, 2020, 8:02pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/10 "2020-03-28T20:02:03Z")

</div>

I still looks to me like an incomplete cache. This happens when the PHP Timeout is set too low. I need to increase them to 300 seconds when upgrading installations to refresh cache completely. Can you increase PHP Timeout, clear cache and try again?

---

<div class="post-metadata">

**Author:** ![alpha2020](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/alpha2020/32/2038_2.png) [@alpha2020](https://forum.mautic.org/u/alpha2020)\
**Post date:** [March 28, 2020, 9:20pm UTC](https://forum.mautic.org/t/after-installation-uh-oh-i-think-i-broke-it-500-internal-server-error/13563/11 "2020-03-28T21:20:26Z")

</div>

Hi Dirk,

I did increase the time out to 360 and faced the same problems still and Mautic did not run. Then I asked my webhosting support and they fixed the problem in resetting the permissions with a cPanel bash script which is described here

> **[PeachFlame/cPanel-fixperms](https://github.com/PeachFlame/cPanel-fixperms)**
>
> A script to fix permissions & ownership, on files & directories, for cPanel accounts. - PeachFlame/cPanel-fixperms

Now Mautic is running like a charm.

Perhaps, that solution could help a lot of Mautic users who face the same problems as I did.

Again, thanks for your message!

Best,  
Tony
