# Campaigns still trying to send with AWS after switching from Amazon SES to SendGrid

**URL:** https://forum.mautic.org/t/campaigns-still-trying-to-send-with-aws-after-switching-from-amazon-ses-to-sendgrid/32454
**Category:** Product Support
**Created:** [June 20, 2024, 4:32pm UTC](https://forum.mautic.org/t/campaigns-still-trying-to-send-with-aws-after-switching-from-amazon-ses-to-sendgrid/32454 "2024-06-20T16:32:09Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![c-speed](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/c-speed/32/12621_2.png) [@c-speed](https://forum.mautic.org/u/c-speed)
#### Post date: [June 20, 2024, 4:32pm UTC](https://forum.mautic.org/t/campaigns-still-trying-to-send-with-aws-after-switching-from-amazon-ses-to-sendgrid/32454/1 "2024-06-20T16:32:09Z")

</div>

**Your software**  
My Mautic version is: 3.2.5  
My PHP version is: 8.3  
My Database type and version is: mysql

**Your problem**  
My problem is: Hello, everything has been working fine until I switched from Amazon SES to Sendgrid. Transactional emails send normally but campaigns are no longer sending.

These errors are showing in the log:

I get this following error when I click on the contact details:

Last execution error: Expected response code 250 but got code “554”, with message "554 Message rejected: Sending paused for this account. For more information, please check the inbox of the email address associated with your AWS account.

Steps I have tried to fix the problem:  
I can’t figure out why it’s still trying to use the old AWS account. I’ve changed the email settings to SendGrid correctly, it successfully connects and test emails work. And like I said above, transactional emails are sending properly. I can see the transactional emails going through on my SendGrid dashboard.

I’ve cleared the cache but that didn’t help.

---

<div class="post-metadata">

### Author: ![dirk\_s](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dirk_s/32/748_2.png) [@dirk\_s](https://forum.mautic.org/u/dirk_s)
#### Post date: [June 20, 2024, 8:12pm UTC](https://forum.mautic.org/t/campaigns-still-trying-to-send-with-aws-after-switching-from-amazon-ses-to-sendgrid/32454/2 "2024-06-20T20:12:15Z")

</div>

> [@c-speed](#):
>
> My Mautic version is: 3.2.5

Hi there, I think this is a major issue. Version 3 is way out of date, many security fixes are not available for that old release. I doubt many people still know how to handle v3 anymore.

But you may check local.php, if there are maybe leftovers from AWS SES?

But really - v3 is your biggest issue right now.

---

<div class="post-metadata">

### Author: ![c-speed](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/c-speed/32/12621_2.png) [@c-speed](https://forum.mautic.org/u/c-speed)
#### Post date: [June 21, 2024, 8:28pm UTC](https://forum.mautic.org/t/campaigns-still-trying-to-send-with-aws-after-switching-from-amazon-ses-to-sendgrid/32454/3 "2024-06-21T20:28:25Z")

</div>

Thanks for the reply. I took your advice and ended up upgrading to 5.1 this morning. Everything went smoothly except SendGrid doesn’t work at all after installing it through composer.

I made a separate post on it if you have any ideas.

Thanks.

---

<div class="post-metadata">

### Author: ![c-speed](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/c-speed/32/12621_2.png) [@c-speed](https://forum.mautic.org/u/c-speed)
#### Post date: [June 23, 2024, 6:30pm UTC](https://forum.mautic.org/t/campaigns-still-trying-to-send-with-aws-after-switching-from-amazon-ses-to-sendgrid/32454/4 "2024-06-23T18:30:52Z")

</div>

I finally got SendGrid configured with Email DSN. Test emails and all form emails are working.

However, campaigns are still not sending.

When I view a contact in the Channels \> emails \> contacts, it shows this error:

Last execution error:  
Expected response code 250 but got code “554”, with message "554 Message rejected: Sending paused for this account. For more information, please check the inbox of the email address associated with your AWS account. "

I tried creating a new Campaign and New Email with no luck.  
I removed anything to do with Amazon local.php with no luck.  
I’ve cleared the cache but that didn’t help either.

---

<div class="post-metadata">

### Author: ![c-speed](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/c-speed/32/12621_2.png) [@c-speed](https://forum.mautic.org/u/c-speed)
#### Post date: [June 23, 2024, 6:51pm UTC](https://forum.mautic.org/t/campaigns-still-trying-to-send-with-aws-after-switching-from-amazon-ses-to-sendgrid/32454/5 "2024-06-23T18:51:15Z")

</div>

Solved the problem.

Totally my own fault. The cronjobs were pointing to my backup 3.2.5 Mautic installation. 🤦‍♂️
