# Cannot Authorize Mautic Joomla Plugin

**URL:** <https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331>\
**Category:** Product Support\
**Created:** [September 14, 2015, 1:18pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331 "2015-09-14T13:18:46Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 14, 2015, 1:18pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/1 "2015-09-14T13:18:46Z")

</div>

When trying to authorize the Joomla Mautic Plugin, I receive the following error message:  
  
  
  
Error  
  
Incorrect access token parameters returned: Array  
  
  
  
The Public Key, and Secret Key have been created in Mautic and entered in the plugin and re-checked; the OAuth version has been set to the same setting as Mautic.  
  
  
  
Please, advice at your earliest convenience. Thank you in advance.

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 14, 2015, 1:18pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/2 "2015-09-14T13:18:46Z")

</div>

When trying to authorize the Joomla Mautic Plugin, I receive the following error message:

Error  
Incorrect access token parameters returned: Array

The Public Key, and Secret Key have been created in Mautic and entered in the plugin and re-checked; the OAuth version has been set to the same setting as Mautic.

Please, advice at your earliest convenience. Thank you in advance.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [September 15, 2015, 5:20am UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/3 "2015-09-15T05:20:55Z")

</div>

Could you try my version of the plugin?

[https://github.com/escopecz/mautic-joomla](https://github.com/escopecz/mautic-joomla)

There is Download button in the right hand column. Let me know if that work. I’ll send pull request to official plugin then.

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 16, 2015, 2:00pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/4 "2015-09-16T14:00:16Z")

</div>

Escopecz,

I downloaded the plugin from the link you suggested and installed it (today 2015-09-17). After clicking ‘Authorise’ it does not throw an error however it does not give an indication whether it authorised successfully either. The following is the log entries at the moment:

2015-09-16T14:39:47+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: ???  
2015-09-16T14:39:45+00:00 INFO #.#.#.# plg\_mautic Authorize method called.  
2015-09-16T14:37:16+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: ???  
2015-09-16T14:37:15+00:00 INFO #.#.#.# plg\_mautic Authorize method called.  
2015-09-16T14:36:06+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: ???  
2015-09-16T14:36:02+00:00 INFO #.#.#.# plg\_mautic Authorize method called.  
2015-09-14T15:24:49+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: Array  
2015-09-14T15:24:47+00:00 INFO #.#.#.# plg\_mautic Authorize method called.  
2015-09-14T15:23:37+00:00 INFO #.#.#.# plg\_mautic Authorize method called.  
2015-09-14T14:15:09+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: Array

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 16, 2015, 2:02pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/5 "2015-09-16T14:02:12Z")

</div>

I suspect it may have to do with CloudFlare caching?

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [September 16, 2015, 2:48pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/6 "2015-09-16T14:48:09Z")

</div>

If you could turn it off for a test, we could know more.

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 16, 2015, 3:02pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/7 "2015-09-16T15:02:38Z")

</div>

(1) I have excluded the [myjoomla.com/administrator](http://myjoomla.com/administrator) from CloudFlare it still does not work properly after uploading your plugin.

(2) Now paused the CloudFlare service and click on ‘Authorise’ log show the following:  
2015-09-16T16:00:27+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: ???  
2015-09-16T16:00:21+00:00 INFO #.#.#.# plg\_mautic Authorize method called.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [September 16, 2015, 3:04pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/8 "2015-09-16T15:04:11Z")

</div>

The response from Mautic goes to [myjoomla.com](http://myjoomla.com) (using your example). Not to administrator section.

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 16, 2015, 3:11pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/9 "2015-09-16T15:11:26Z")

</div>

Ok I made a modification as follows to the configuration:  
array (  
‘baseUrl’ =\> ‘[http://www.myjoomla.com/mautic](http://www.myjoomla.com/mautic)’,  
‘version’ =\> ‘OAuth1a’,  
‘clientKey’ =\> ‘fakdfae334j3sa0043swogoo84sks0okwkcgc8gws’,  
‘clientSecret’ =\> ‘1njtf1fdorao3939100falalfakcc0ko040k8wwgk’,  
‘callback’ =\> ‘[http://www.myjoomla.com/](http://www.myjoomla.com/)’,  
)

It goes to this Mautic page :  
[http://www.myjoomla.com/mautic/oauth/v1/authorize?oauth\_token=945q5qrqr9qalda0a9afdhjaf09a4qahaweswra4526gbsa](http://www.myjoomla.com/mautic/oauth/v1/authorize?oauth_token=945q5qrqr9qalda0a9afdhjaf09a4qahaweswra4526gbsa)

After login in to that page, it delivers a mostly blank page with the following text at the top left corner:  
Callback is not valid.

from the log:  
2015-09-16T16:16:50+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: Array  
2015-09-16T16:16:38+00:00 INFO #.#.#.# plg\_mautic Authorize method called.  
2015-09-16T16:03:39+00:00 INFO #.#.#.# plg\_mautic Authorize method called.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [September 16, 2015, 3:27pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/10 "2015-09-16T15:27:22Z")

</div>

That’s great. We are moving forward 🙂

That message means that the callback URL from the oAuth credentials stored in Mautic is different than the one Plugin provides during the request. It should be base URL of your Joomla. Here is more about it [https://github.com/escopecz/mautic-joomla#plugin-authorization](https://github.com/escopecz/mautic-joomla#plugin-authorization)

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 16, 2015, 5:11pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/11 "2015-09-16T17:11:30Z")

</div>

Should it be [http://myjoomla.com](http://myjoomla.com) can it also be [http://www.myjoomla.com](http://www.myjoomla.com)?

I have recreated the Mautic API Credentials based on the [http://www.myjoomla.com](http://www.myjoomla.com). Reset the Keys in the plugin with the newly created keys.

Results:  
2015-09-16T18:02:37+00:00 ERROR #.#.#.# plg\_mautic Incorrect access token parameters returned: Array  
2015-09-16T18:02:36+00:00 INFO #.#.#.# plg\_mautic Authorize method called.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [September 16, 2015, 5:25pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/12 "2015-09-16T17:25:21Z")

</div>

it should be what you have as a default URL address. The redirect could be problem I think. You didn’t have to create the new credentials. Callback can be updated.

Now the error says that the access token is incorrect (obviously).

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 18, 2015, 3:20pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/13 "2015-09-18T15:20:09Z")

</div>

Still experiencing the same issue with the Mautic-Joomla Plugin. I made sure that all information is provided correctly, e.g. callback, keys, etc. Any suggestions?

---

<div class="post-metadata">

**Author:** ![aluidens](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aluidens/32/32_2.png) [@aluidens](https://forum.mautic.org/u/aluidens)\
**Post date:** [September 19, 2015, 12:33pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/14 "2015-09-19T12:33:47Z")

</div>

Clinking Authorise, I am send to the Mautic login page.  
I get the following after loggin in:  
Link in the browser address: [http://www.myjoomla.com/mautic/oauth/v1/authorize?oauth\_token=3lf7g3d307ggog84w8o8c8go08sg8kgw4gwkocg84s04888s80](http://www.myjoomla.com/mautic/oauth/v1/authorize?oauth_token=3lf7g3d307ggog84w8o8c8go08sg8kgw4gwkocg84s04888s80)  
Displayed on the page: Callback is not valid.  
In the Log: 2015-09-19T02:37:28+00:00 ERROR #.#.#.# plg\_mautic PLG\_MAUTIC\_ACCESS\_TOKEN\_NOT\_VALID  
2015-09-19T02:37:28+00:00 INFO #.#.#.# plg\_mautic Authorize method called.

---

<div class="post-metadata">

**Author:** ![VEV](https://avatars.discourse-cdn.com/v4/letter/v/c6cbf5/32.png) [@VEV](https://forum.mautic.org/u/VEV)\
**Post date:** [November 6, 2015, 9:49am UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/15 "2015-11-06T09:49:51Z")

</div>

I have same problem at the last version Joomla 3 throu OAuth1.  
«Callback is not valid.»

If I use OAuth2 - all OK.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 10:57pm UTC](https://forum.mautic.org/t/cannot-authorize-mautic-joomla-plugin/2331/16 "2020-02-02T22:57:12Z")

</div>


