# Cannot Install - Out of Memory

**URL:** <https://forum.mautic.org/t/cannot-install-out-of-memory/2535>\
**Category:** Product Support\
**Created:** [October 19, 2015, 4:59pm UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535 "2015-10-19T16:59:29Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![dzawacki](https://avatars.discourse-cdn.com/v4/letter/d/9d8465/32.png) [@dzawacki](https://forum.mautic.org/u/dzawacki)\
**Post date:** [October 19, 2015, 4:59pm UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535/1 "2015-10-19T16:59:29Z")

</div>

I downloaded the production version of Mautic 1.2 ([https://www.mautic.org/download/](https://www.mautic.org/download/)) and uploaded it into a folder on my domain. When I navigated to this folder through the browser to complete the install, I get the following message:

Code:

Fatal error: Out of memory (allocated 35389440) (tried to allocate 36 bytes) in /path/to/mautic/app/bootstrap.php.cache on line 2701

  
In my PHP Info I see I have 120M allocated.  
  
I had Mautic running a few months ago but ran into issues with the upgrade to 1.2 so I removed it. Trying again today, it appears I'm still having issues.  
  
Any ideas what I'm doing wrong here? I'm struggling to find a installation guide because I'm at a loss right now.

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [October 21, 2015, 5:59am UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535/2 "2015-10-21T05:59:13Z")

</div>

That doesn’t make sense to me. The limit is 120MB, but it gets out of memory trying to allocate 35MB. Could you discuss this issue with your server provider?

---

<div class="post-metadata">

**Author:** ![dzawacki](https://avatars.discourse-cdn.com/v4/letter/d/9d8465/32.png) [@dzawacki](https://forum.mautic.org/u/dzawacki)\
**Post date:** [October 19, 2015, 4:59pm UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535/3 "2015-10-19T16:59:29Z")

</div>

I downloaded the production version of Mautic 1.2 ([https://www.mautic.org/download/](https://www.mautic.org/download/)) and uploaded it into a folder on my domain. When I navigated to this folder through the browser to complete the install, I get the following message:

```auto
Fatal error: Out of memory (allocated 35389440) (tried to allocate 36 bytes) in /path/to/mautic/app/bootstrap.php.cache on line 2701
```

In my PHP Info I see I have 120M allocated.

I had Mautic running a few months ago but ran into issues with the upgrade to 1.2 so I removed it. Trying again today, it appears I’m still having issues.

Any ideas what I’m doing wrong here? I’m struggling to find a installation guide because I’m at a loss right now.

---

<div class="post-metadata">

**Author:** ![msimko](https://avatars.discourse-cdn.com/v4/letter/m/a183cd/32.png) [@msimko](https://forum.mautic.org/u/msimko)\
**Post date:** [February 29, 2016, 9:12pm UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535/4 "2016-02-29T21:12:11Z")

</div>

Trying to install  
I am getting similar when trying to install. First tried 1.2.2, and now trying 1.2.4  
this error:  
Fatal error: Out of memory (allocated 35127296) (tried to allocate 40 bytes) in /homepages/xxxxxxxxxxxxxxxxxxx/mauto/app/bootstrap.php.cache on line 2701

and php settings (using 5.6)

Configuration option PHP 5.6   
Zend Framework v2.6.0-dev  
allow\_call\_time\_pass\_reference Not supported   
allow\_url\_fopen Activated  
display\_errors Activated  
error\_reporting 22517  
html\_errors Activated  
include\_path .:/usr/lib/php5.6   
log\_errors Deactivated  
magic\_quotes\_runtime Not supported  
magic\_quotes\_sybase Not supported  
max\_execution\_time 50000  
memory\_limit 120M  
post\_max\_size 8M  
precision 14  
safe\_mode Deactivated  
short\_open\_tag Activated  
upload\_max\_filesize 40M

I have Mautic running version 1.2.2 in a different account on this hosting company

Don’t see minimum server requirements for Mautic in the Wiki  
Any clues on what needs fixing will be appreciated  
Do you need data from phpinfo()?

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 29, 2016, 9:54pm UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535/5 "2016-02-29T21:54:13Z")

</div>

As I wrote earlier, contact your server provider to increase your memory limit. Mautic tries to allocate 35MB and the memory limit is hit. So `memory_limit	120M` might not be true. I’d recommend even higher limit. Something like 512MB. It depends what you’ll do with Mautic though.

---

<div class="post-metadata">

**Author:** ![msimko](https://avatars.discourse-cdn.com/v4/letter/m/a183cd/32.png) [@msimko](https://forum.mautic.org/u/msimko)\
**Post date:** [March 1, 2016, 7:59pm UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535/6 "2016-03-01T19:59:46Z")

</div>

Resolved - I increased the memory limit to 256M by uploading directives in a php.ini file

Now I am happily bappily proceeding with install.

Thanks.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 10:57pm UTC](https://forum.mautic.org/t/cannot-install-out-of-memory/2535/7 "2020-02-02T22:57:48Z")

</div>


