# Cannot login after a broken update

**URL:** <https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480>\
**Category:** Product Support\
**Created:** [October 24, 2019, 4:04pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480 "2019-10-24T16:04:00Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 24, 2019, 4:04pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/1 "2019-10-24T16:04:00Z")

</div>

**Your software**  
My Mautic version is: 2.15.3  
My PHP version is: PHP 5.6

**Your problem**  
My problem is: After a broken update (didn’t finish) mautic had a lot of issues.

These errors are showing in the log:

[2019-10-24 13:59:07] mautic.NOTICE: Symfony\Component\Console\Exception\RuntimeException: Too many arguments, expected arguments “command”. (uncaught exception) at /home/mymauticsite/public\_html/mautic/vendor/symfony/console/Input/ArgvInput.php line 182 while running console command `mautic:broadcasts:send`

Steps I have tried to fix the problem:

I’ve read and tried a lot of things as change server configurations to finish the update with **doctrine:schema:update --force** and a the error message saying its offline and a lot of error\_log messages are ok now. But now, I cannot login to Mautic, it reads and came back to login page. There are only one error message left (pasted above)

Sites I’ve used to repair some of the first errors.

> **[How to Update Mautic Properly and Easily](https://araixrand.wordpress.com/2019/01/28/update-mautic-properly/)**
>
> If you have installed Mautic on shared web hosting server then you might encounter update issue. That is because of limitation with Shared web hosting account and Mautic required CLI commands to up…

  

> <https://gist.github.com/ChgoChad/fe9950c628ad8169cd27a58ee64106e8>

  
[https://www.mautic.org/docs/en/tips/troubleshooting.html](https://www.mautic.org/docs/en/tips/troubleshooting.html)

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [October 25, 2019, 12:57pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/2 "2019-10-25T12:57:16Z")

</div>

Hi there,

Sorry to hear you’re having problems after updating. Have you followed, step by step, the stages in [this page](https://www.mautic.org/docs/en/tips/update-failed.html) on the docs?

Please share the results from each step.

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 25, 2019, 2:55pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/3 "2019-10-25T14:55:57Z")

</div>

Hi rcheesley ! Thanks for help.

I’ve tried this steps before posting here. I’ve installed command.php to execute the routines as I’m not able to connect throught ssh. The system finished 3 update routines, the error message disappeared but I cannot login and when I try it logs the message above.

Hope someone knows this error and could point me to the right direction !

Thanks !

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [October 25, 2019, 6:01pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/4 "2019-10-25T18:01:56Z")

</div>

> [@bugbusters](#):
>
> `mautic:broadcasts:send`

It looks like maybe a problem with your cron job, but that should not prevent you logging in.

What happens if you try to log in? Have you tried doing so in an incognito window or another browser, for example?

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 25, 2019, 8:11pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/5 "2019-10-25T20:11:56Z")

</div>

> [@silavapi](#):
>
> s like maybe a problem with your cron job, but that should not prevent you logging in.

Yep. I’ve tested with all the browsers, incognito, throught VPN, on mobile, cleaned cache, everything.

It happened after a broken update that I think already is ok.

I tried to delete the mautic folder, download a new install, extract, copy my old local.php back to new installation folder and nothing changed. I open mautic’s login page, insert my login credentials, mautic try to login and nothing happens, it’s like a refresh on the page so I’m back to login page to insert my credentials again. Everytime I try to login it logs the error message I’ve posted.

What I just did:

. I’ve installed Mautic in a new server  
. Then I’ve pointed the local.php to access the database on the old (with problem) installation, just to see if the problem is with something in database and… everything worked like a charm.

So, I do not have problem with database. I do not have problem with mautic files. Something in my local.php is causing the problem. Maybe an old setup that is causing this.

my local.php:

[https://pastebin.com/9upPRefY](https://pastebin.com/9upPRefY)

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [October 27, 2019, 9:38pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/6 "2019-10-27T21:38:48Z")

</div>

Can you share the output of your error logs since you tried this? Is it still just the one about too many arguments?

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [October 28, 2019, 12:53am UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/7 "2019-10-28T00:53:07Z")

</div>

Manually delete the `app/cache/prod/` directory and try a refresh of Mautic in your browser.

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 28, 2019, 2:35pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/8 "2019-10-28T14:35:23Z")

</div>

Same error message on the logs:

mautic.NOTICE: Symfony\Component\Console\Exception\RuntimeException: Too many arguments, expected arguments “command”. (uncaught exception) at /home/mymauticsite/public\_html/mautic/vendor/symfony/console/Input/ArgvInput.php line 182 while running console command `mautic:broadcasts:send`

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 28, 2019, 2:36pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/9 "2019-10-28T14:36:26Z")

</div>

I’ve tried that a lot of time. All the troubleshooting steps Mautic’s documentation indicates I did.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [October 28, 2019, 3:08pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/10 "2019-10-28T15:08:22Z")

</div>

So you used your panel’s file manager to delete that folder? I’m not talking about using the script.

=====

When you used a fresh install with your old local.php, everything worked correctly, right?

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 28, 2019, 3:24pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/11 "2019-10-28T15:24:23Z")

</div>

Hi MxyzptlkFishStix, Thanks for helping.

I’ve tried with script, and in the last test I’ve deleted it by SSH as I asked for the access to my ISP. Same problem.

When I fresh install and put my old local.php back, the error is the same, its why I think something on my local.php is the responsable for this issue.

Regards.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [October 28, 2019, 5:08pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/12 "2019-10-28T17:08:33Z")

</div>

I did a diff of your local.php with mine. Outside of differences between logins/pass/domains/mail/etc., I don’t see any problems.

What version of Mautic did you upgrade from?

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 28, 2019, 7:28pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/13 "2019-10-28T19:28:11Z")

</div>

from 2.15.1

I do not understand what is the problem. I’ve tried do upgrade, it didn’t work and Mautic stop working. So I followed all the troubleshooting document steps, change php version, change max\_limit php values, etc and all the new error\_logs was clean except for this one with this error message. I tried everything and nothing work so I did a fresh install in a new server, changed the local.php variables manually to point it to the old database and it works. Just to test, I copied local.php from old installation and put it on the new server and got the same error. So I export the old database, import on a database server on the new installation and now its working.

I kept this issue opened because it could help someone with the same problem. I kept the old installation with problem to try to figure out how to fix it and learn more about mautic.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [October 28, 2019, 7:41pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/14 "2019-10-28T19:41:48Z")

</div>

You could always try a diff of the two different directories (broken upgrade and fresh 2.15.3) and see what’s different between the two as far as files go.

`diff -qr /directory/of/broken/mautic /directory/of/fresh/mautic`

Based on what you’ve posted, it doesn’t seem like that upgrade processed the zip file extraction properly.

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 28, 2019, 7:49pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/15 "2019-10-28T19:49:00Z")

</div>

yes, but following the troubleshooting steps, I’ve download a fresh install on the old server, put local.php back and the problem still the same. So the files on the old server already is a fresh copy. Thats why I said the problem might be on the local.php. Because it’s the only different file that causing problems.

The different thing I have on the old Mautic and new one is that on the old server I was using Sparkpost API to send mails and on the new one I’m using ElasticMail

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [October 28, 2019, 11:24pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/16 "2019-10-28T23:24:56Z")

</div>

Are you deleting the entire old installation first or are you overwriting the old installation with new files?

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 30, 2019, 1:03pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/17 "2019-10-30T13:03:25Z")

</div>

I’ve deleted entire installation and extract the new files from the zip downloaded.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [October 30, 2019, 5:13pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/18 "2019-10-30T17:13:27Z")

</div>

You said that you tried a fresh install on another host, using your old local.php, and everything worked, correct?

---

<div class="post-metadata">

**Author:** ![bugbusters](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bugbusters/32/965_2.png) [@bugbusters](https://forum.mautic.org/u/bugbusters)\
**Post date:** [October 30, 2019, 6:07pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/19 "2019-10-30T18:07:32Z")

</div>

No. I tried a fresh install on another host, using old database but with the old local.php the error is the same. If I use the new local.php and just point it to the old database server, it works fine.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [October 30, 2019, 7:34pm UTC](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480/20 "2019-10-30T19:34:56Z")

</div>

Move your new local.php to the old install and see if that solves your problem. The local.php might have DOS carriage returns. Do the former or convert the “bad” local.php to Unix format.

[DOS2Unix](https://waterlan.home.xs4all.nl/dos2unix.html)

[Next page](https://forum.mautic.org/t/cannot-login-after-a-broken-update/11480.md?page=2)
