# Connecting to Postal via API

**URL:** <https://forum.mautic.org/t/connecting-to-postal-via-api/30808>\
**Category:** Mautic 5 Install/Upgrade Support\
**Created:** [February 6, 2024, 6:55pm UTC](https://forum.mautic.org/t/connecting-to-postal-via-api/30808 "2024-02-06T18:55:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![bob-emblibrary](https://avatars.discourse-cdn.com/v4/letter/b/c6cbf5/32.png) [@bob-emblibrary](https://forum.mautic.org/u/bob-emblibrary)\
**Post date:** [February 6, 2024, 6:55pm UTC](https://forum.mautic.org/t/connecting-to-postal-via-api/30808/1 "2024-02-06T18:55:14Z")

</div>

**Your software**  
My Mautic version is:5.0.3  
My PHP version is:8.1  
My Database type and version is:mariadb 15.1

**Your problem**  
My problem is: Trying to install a plugin ‘postal\_server\_api\_transport\_for\_mautic’ and following the steps causes Mautic to stop responding. I was wondering if anyone has their install connected to Postal and if so, have you got API credentials working or relagated to the SMTP creds.  
Addon can be found here - [GitHub - LucasCCS/postal\_server\_api\_transport\_for\_mautic](https://github.com/LucasCCS/postal_server_api_transport_for_mautic)

These errors are showing in the log:

Steps I have tried to fix the problem: Followed plugins instructions- Caused mautic to post errors.  
Git pulled the repo to the plugin folder. Reload apache, webserver fails to respond.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [February 6, 2024, 9:59pm UTC](https://forum.mautic.org/t/connecting-to-postal-via-api/30808/2 "2024-02-06T21:59:43Z")

</div>

This is a M4 plugin. Plz wait for or take care of the upgrade.

---

<div class="post-metadata">

**Author:** ![bob-emblibrary](https://avatars.discourse-cdn.com/v4/letter/b/c6cbf5/32.png) [@bob-emblibrary](https://forum.mautic.org/u/bob-emblibrary)\
**Post date:** [February 6, 2024, 10:16pm UTC](https://forum.mautic.org/t/connecting-to-postal-via-api/30808/3 "2024-02-06T22:16:24Z")

</div>

But Mautic’s own methods don’t show it as being deprecated. The issue is with TransportType.php no longer existing in Mautic\Email\Bundle\Model\ and all of their documentation refers to using that. But after 4.4 it is gone. So should I roll back to 4.4 to get it to work?
