# Could not extract the contents of the ZIP archive \[SOLVED\]

**URL:** <https://forum.mautic.org/t/could-not-extract-the-contents-of-the-zip-archive-solved/27405>\
**Category:** Mautic 4 Install/Upgrade Support\
**Created:** [March 18, 2023, 5:04pm UTC](https://forum.mautic.org/t/could-not-extract-the-contents-of-the-zip-archive-solved/27405 "2023-03-18T17:04:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![crozilla](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/crozilla/32/2054_2.png) [@crozilla](https://forum.mautic.org/u/crozilla)\
**Post date:** [March 18, 2023, 5:04pm UTC](https://forum.mautic.org/t/could-not-extract-the-contents-of-the-zip-archive-solved/27405/1 "2023-03-18T17:04:31Z")

</div>

**Your software**  
_My PHP version is_ : 8.0.22  
_My MySQL/MariaDB version is_: 8.0.28-0ubuntu0.20.04.3

**Updating/Installing Errors**  
_I am_ : Updating  
_Upgrading/installing via_ : Command Line

_These errors are showing in the installer_ :

The Mautic update could not complete successfully because of the following error: Could not extract the contents of the ZIP archive to the filesystem. PHP Warning: ZipArchive::extractTo(/home/username/domain.com/mauticmail/.htaccess): failed to open stream: Permission denied in /home/username/domain.com/mauticmail/app/bundles/CoreBundle/Update/Step/InstallNewFilesStep.php on line 82

_These errors are showing in the Mautic log_ :

mautic.WARNING: Command `mautic:update:apply` exited with status code 1 {“hostname”:“servername”,“pid”:381758}

**Your problem**  
_My problem is_ : Can’t update, stuck on v4.4.6. I have successfully updated the past several updates using CLI, but this one isn’t working. I am using a separate directory for Mautic, \<[domain.com/mauticmail/](http://domain.com/mauticmail/)\> and thought I had tweaked the .htaccess file to accommodate that, but has something changed?

_Steps I have tried to fix the problem_ : Contacted my webhost to see if there were permission errors. They found one, but removing it had no effect. Still cannot update.

UPDATE: While I was writing this post, I cleared the cache and that did it (along with removing the bad permission). Just posting this in case someone else has the problem.

---

<div class="post-metadata">

**Author:** ![giorgi\_gadrani](https://avatars.discourse-cdn.com/v4/letter/g/b5ac83/32.png) [@giorgi\_gadrani](https://forum.mautic.org/u/giorgi_gadrani)\
**Post date:** [June 6, 2024, 12:31pm UTC](https://forum.mautic.org/t/could-not-extract-the-contents-of-the-zip-archive-solved/27405/2 "2024-06-06T12:31:45Z")

</div>

![update](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/6/65c1d7f6ead181ddb20f1aad012c5c26278e9dc2.png)
