# cron error

**URL:** <https://forum.mautic.org/t/cron-error/7503>\
**Category:** General Discussion\
**Created:** [February 13, 2017, 6:24pm UTC](https://forum.mautic.org/t/cron-error/7503 "2017-02-13T18:24:16Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![ayayron](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ayayron/32/10341_2.png) [@ayayron](https://forum.mautic.org/u/ayayron)\
**Post date:** [February 13, 2017, 6:24pm UTC](https://forum.mautic.org/t/cron-error/7503/1 "2017-02-13T18:24:16Z")

</div>

Hi,  
  
  
  
I just looked at your path. [getastra.com/go/app/bundles/CoreBundle/Templating/Helper/ThemeHelper.php](http://getastra.com/go/app/bundles/CoreBundle/Templating/Helper/ThemeHelper.php)  
  
  
  
nothing shows up when something should at least i should have a 404 or 500 error pop up for the web address and nothing. Then i back tracked on your path to primary domain of [getastra.com](http://getastra.com) you have a website already on the domain. using mautic you don’t want to have it in a sub folder section of a website that is already setup. Mautic either is on a dedicated domain all by itself and or subdomain to your domain. for example: [management.getastra.com](http://management.getastra.com) and you install mautic directly to that path. I would if you are new to this and don’t have a lot inside of mautic to create a sub domain and install it from their. create a new database first and so when you do an install you pick that database that is new and install it.

---

<div class="post-metadata">

**Author:** ![ayayron](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ayayron/32/10341_2.png) [@ayayron](https://forum.mautic.org/u/ayayron)\
**Post date:** [February 13, 2017, 6:24pm UTC](https://forum.mautic.org/t/cron-error/7503/2 "2017-02-13T18:24:16Z")

</div>

Hi,

I just looked at your path. [getastra.com/go/app/bundles/CoreBundle/Templating/Helper/ThemeHelper.php](http://getastra.com/go/app/bundles/CoreBundle/Templating/Helper/ThemeHelper.php)

nothing shows up when something should at least i should have a 404 or 500 error pop up for the web address and nothing. Then i back tracked on your path to primary domain of [getastra.com](http://getastra.com) you have a website already on the domain. using mautic you don’t want to have it in a sub folder section of a website that is already setup. Mautic either is on a dedicated domain all by itself and or subdomain to your domain. for example: [management.getastra.com](http://management.getastra.com) and you install mautic directly to that path. I would if you are new to this and don’t have a lot inside of mautic to create a sub domain and install it from their. create a new database first and so when you do an install you pick that database that is new and install it.

---

<div class="post-metadata">

**Author:** ![ananda](https://avatars.discourse-cdn.com/v4/letter/a/e99b99/32.png) [@ananda](https://forum.mautic.org/u/ananda)\
**Post date:** [February 13, 2017, 6:31pm UTC](https://forum.mautic.org/t/cron-error/7503/3 "2017-02-13T18:31:57Z")

</div>

Thanks for your message. I have Mautic installed at [http://Go.getastra.com](http://Go.getastra.com).

Could you please check this URL?

---

<div class="post-metadata">

**Author:** ![ayayron](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ayayron/32/10341_2.png) [@ayayron](https://forum.mautic.org/u/ayayron)\
**Post date:** [February 13, 2017, 6:36pm UTC](https://forum.mautic.org/t/cron-error/7503/4 "2017-02-13T18:36:06Z")

</div>

this link shows up fine it gives the login to mautic. [http://go.getastra.com/s/login](http://go.getastra.com/s/login)

---

<div class="post-metadata">

**Author:** ![ayayron](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ayayron/32/10341_2.png) [@ayayron](https://forum.mautic.org/u/ayayron)\
**Post date:** [February 13, 2017, 6:46pm UTC](https://forum.mautic.org/t/cron-error/7503/5 "2017-02-13T18:46:28Z")

</div>

this link you have listed on your cron job isn’t attached to that location.

crons should be using this part.

/usr/local/cpanel/3rdparty/bin/php /home/go.getastra.com/app/console mautic:segments:update  
/usr/local/cpanel/3rdparty/bin/php /home/go.getastra.com/app/console mautic:campaigns:rebuild  
/usr/local/cpanel/3rdparty/bin/php /home/go.getastra.com/app/console mautic:campaigns:trigger

---

<div class="post-metadata">

**Author:** ![ananda](https://avatars.discourse-cdn.com/v4/letter/a/e99b99/32.png) [@ananda](https://forum.mautic.org/u/ananda)\
**Post date:** [February 14, 2017, 11:08am UTC](https://forum.mautic.org/t/cron-error/7503/6 "2017-02-14T11:08:44Z")

</div>

The server paths are a little different in my configuration. I have double checked that all crons are running fine. Meanwhile I have been able to resolve the issue. The necessary PHP extensions weren’t being loaded from the custom php.ini file.  
Due to the server configuration I was earlier unable to pass the command line parameters to the script. Mautic forum suggested that I pass the ‘php -n’ flag so that the default php.ini is ignored and the command line parameters are passed to the script.

Turns out that critical extensions like dom, libxml, json weren’t being loaded by php by default. So when I added these to the custom php.ini file, it started working seamlessly!

Thanks a lot for your help!
