# CSV imports fail - stalling In Progress, Runtime Less than 1 second

**URL:** <https://forum.mautic.org/t/csv-imports-fail-stalling-in-progress-runtime-less-than-1-second/25199>\
**Category:** Product Support\
**Tags:** mautic-4\
**Created:** [August 27, 2022, 4:11pm UTC](https://forum.mautic.org/t/csv-imports-fail-stalling-in-progress-runtime-less-than-1-second/25199 "2022-08-27T16:11:53Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![modifiedcontent](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/modifiedcontent/32/511_2.png) [@modifiedcontent](https://forum.mautic.org/u/modifiedcontent)\
**Post date:** [September 2, 2022, 5:49pm UTC](https://forum.mautic.org/t/csv-imports-fail-stalling-in-progress-runtime-less-than-1-second/25199/6 "2022-09-02T17:49:20Z")

</div>

[In this case](https://forum.mautic.org/t/4-2-cant-send-email-error-500-foreign-key-constraint-fails/22933/9) a failing foreign key constraint was apparently caused by an encoding mismatch. Almost all of the tables in my database had collation utf8\_unicode\_ci. A few had utf8mb4\_unicode\_ci; I have converted those to utf8\_unicode\_ci and will test later if that made any difference…

What else could I check? Is there a way to safely “reset” the tables that cause these problems? Or does the ‘integrity constraint violation’ point to another problem - what problem does it point to?

**Edit:**

I am now converting all tables to utf8mb4\_unicode\_ci, [following this recipe to fix the general foreign key mess](https://github.com/mautic/mautic/issues/9129).

Using `alter table lead_event_log CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;`, I get the following unusual error:

> #1025 - Error on rename of ‘./mydatabase/#sql-a26\_721a’ to ‘./mydatabase/lead\_event\_log’ (errno: 150 “Foreign key constraint is incorrectly formed”)

Same error on tables oauth2\_accesstokens, oauth2\_clients, oauth2\_refreshtokens, users, …

Several other tables, like plugin\_citrix\_events, have this error:

> Specified key was too long; max key length is 3072 bytes

Does anyone know what this means?

---

_[View the full topic](https://forum.mautic.org/t/csv-imports-fail-stalling-in-progress-runtime-less-than-1-second/25199)._
