Mautic Community Forums

cURL error 56

Hi everyone :slight_smile:

Your software
My Mautic version is: 2.15.3
My PHP version is: 7.0, 7.2

Your problem
My problem is:

I use WordPress and with WPFusion i am able to send data from my WordPress install to my Mautic install, creating user profile seems ok, but when updating i got thoses errors im my WPFusion log :

Error while performing method combined_update: cURL error 56: OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 104
[0] => 1968
[1] => Array
[update_contact] => Array
[firstname] => Valerie
[lastname] => Collard
[email] =>

        [apply_tags] => Array
                [0] => woocommerce



(My WordPress host and Mautic Host are not the same, and i dont know witch one is really failing me here)

These errors are showing in the log: no error in Mautic log

Steps I have tried to fix the problem: tried to change some various settings on my mautic host but got nothing out of it…

Thanks for reading my issue :slight_smile:
Hopefully someone could give me some insight :smiley:

1 Like

Upgrade to latest version of curl.

1 Like

Hi, thanks for the response, since it’s shared hosting, premium but still shared, i cant really do that. And it’s probably up to date anyway.
One thing that my host also told me is that they only autorize those request : “GET|HEAD|OPTIONS|POST|PUT|DELETE”
They have notice that there is the use of the request “PATCH”, which is not allowed.

I guess that a start of an answer right ?

My experience with most hosters, especially shared hosting, is they don’t have anywhere close to the latest version of software. Which isn’t necessarily a bad thing (if it’s not broke . . .), it’s just they’ll run a much older version that might contain a/some backported security patch(es) at the most dependant on the release schedule of the distro maintainer.

You don’t have anything like WordFence or any of the number of security plugins installed, do you?

i dont have a security plugin on my install, since most of the security is handled by good server practices.
But after inspection i found out that i have no issue on the sending side (witch is my WordPress on Vultr server, using a custom stack and fully up to date stack)

After contacting my target hos (witch is the shared premium one) i found out that they are indeed blocking any “PATCH” request and we have no way of whitelisting an IP to allow them trough.
To update tag, WPFusion use PATCH requests, so i guess i found out the culprit, my host is extra zealous reagarding security, so i cant really run Mautic on them.
WPFusion support will try to replace the PATCH request by PUT request, i think it will do the trick. But not sure i will stay on that host…

Also something really weird, is the fact that my segments are not updating, i have the cron setup correctly i think and the segment as well :

Maybe my host weird config expect a different path ?

Finally my host was blocking the external incoming requests, i fixed that by migrating the installation to a new host.