# Deleted Cache related issue. mautic.CRITICAL: Uncaught PHP Exception

**URL:** <https://forum.mautic.org/t/deleted-cache-related-issue-mautic-critical-uncaught-php-exception/23959>\
**Category:** Product Support\
**Tags:** mautic-3\
**Created:** [May 2, 2022, 10:46pm UTC](https://forum.mautic.org/t/deleted-cache-related-issue-mautic-critical-uncaught-php-exception/23959 "2022-05-02T22:46:06Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![shaysashcov](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/shaysashcov/32/669_2.png) [@shaysashcov](https://forum.mautic.org/u/shaysashcov)\
**Post date:** [May 2, 2022, 10:46pm UTC](https://forum.mautic.org/t/deleted-cache-related-issue-mautic-critical-uncaught-php-exception/23959/1 "2022-05-02T22:46:06Z")

</div>

**Your software**  
My Mautic version is: v3.1.2  
My PHP version is: 7.3.24  
My Database type and version is: MySQL

**Your problem**  
My problem is: My mautic site crashed after i cleared the cache. I am using filezilla to navigate. I am a marketer, so i am not very familiar with servers, databases and coding. i do know how to read codes though. if someone has encountered that error please let me know how you fixed it.

These errors are showing in the log: [2022-05-02 22:29:31] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalErrorException: “Compile Error: require(): Failed opening required ‘/var/www/html/marketing/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticPluginBundleEntityPlugin.php’ (include\_path=’.:/usr/share/php’)” at /var/www/html/marketing/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php line 206 {“exception”:"[object] (Symfony\Component\Debug\Exception\FatalErrorException(code: 0): Compile Error: require(): Failed opening required ‘/var/www/html/marketing/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticPluginBundleEntityPlugin.php’ (include\_path=’.:/usr/share/php’) at /var/www/html/marketing/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php:206)"}

Steps I have tried to fix the problem:  
Already followed the steps here [Troubleshooting | Mautic](https://docs.mautic.org/en/troubleshooting)  
but nothing seems to work out.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [May 3, 2022, 6:47am UTC](https://forum.mautic.org/t/deleted-cache-related-issue-mautic-critical-uncaught-php-exception/23959/2 "2022-05-03T06:47:52Z")

</div>

Hi,  
You are mentioning SSL. Do you have issues with your SSL certificate?  
How did you clear the cache? Deleted the respective folder’s content?  
Here is a short guide on cache:

> **[Full guide to permissions and cache in Mautic – Joey Keller](https://joeykeller.com/full-guide-to-permissions-and-cache-in-mautic/)**

---

<div class="post-metadata">

**Author:** ![aerendir](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aerendir/32/1050_2.png) [@aerendir](https://forum.mautic.org/u/aerendir)\
**Post date:** [May 3, 2022, 9:52am UTC](https://forum.mautic.org/t/deleted-cache-related-issue-mautic-critical-uncaught-php-exception/23959/3 "2022-05-03T09:52:43Z")

</div>

This is not a proble m related to digital dcertificates.

Probably you deleted the entire folder and Mautic is not able to recreate it.

With your FTP program, check if the folder `var/cache` exists.

Try to access the login page of Mautic and check if there any errors. Then check again if the folder exists and if in it there is the `prod` subfolder.

If it doesn’t exists, then check the files and folders permissions

> **[File ownership and permissions](https://docs.mautic.org/en/troubleshooting/file-ownership-and-permissions)**
>
> . If you experience errors like the following:. mautic.WARNING: PHP Warning require(/mautic/var/cache/prod/doctrine/orm/Proxies/CGMauticCategoryBundleEntityCategory.php): failed to open stream: No such file or directory - in file...

Fix them if required.

Then try again to access the login page.

If the errors continues to happen, then you need an SSH access to launch some commands: can you access the shell?

PS  
Please: change the title of this thread as there is no relation with SSL.

---

<div class="post-metadata">

**Author:** ![shaysashcov](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/shaysashcov/32/669_2.png) [@shaysashcov](https://forum.mautic.org/u/shaysashcov)\
**Post date:** [May 3, 2022, 2:46pm UTC](https://forum.mautic.org/t/deleted-cache-related-issue-mautic-critical-uncaught-php-exception/23959/4 "2022-05-03T14:46:33Z")

</div>

Hello, thanks for the reply,  
the prod folder exists as well as the rest of it. the issue still persists (500 internal server error).  
Is this still related to file permission?  
i can access shell

Thanks

---

<div class="post-metadata">

**Author:** ![shaysashcov](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/shaysashcov/32/669_2.png) [@shaysashcov](https://forum.mautic.org/u/shaysashcov)\
**Post date:** [May 3, 2022, 7:28pm UTC](https://forum.mautic.org/t/deleted-cache-related-issue-mautic-critical-uncaught-php-exception/23959/5 "2022-05-03T19:28:48Z")

</div>

Solved the problem. it was more complicated than i thought because i had several issues at the same time. long story short **i cleared my cache again.**
