# Email integration says no

**URL:** <https://forum.mautic.org/t/email-integration-says-no/8007>\
**Category:** Product Support\
**Created:** [March 23, 2017, 5:23pm UTC](https://forum.mautic.org/t/email-integration-says-no/8007 "2017-03-23T17:23:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![headcountguru](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/headcountguru/32/173_2.png) [@headcountguru](https://forum.mautic.org/u/headcountguru)\
**Post date:** [March 23, 2017, 5:23pm UTC](https://forum.mautic.org/t/email-integration-says-no/8007/1 "2017-03-23T17:23:09Z")

</div>

I’m trying to use sendgrid, i tried other and my own smtp. Please decipher this?  
  
  
  
Unable to connect with TLS encryption Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport \<\< [220-a2ls6.a2hosting.com](http://220-a2ls6.a2hosting.com) ESMTP Exim 4.88 #1 Thu, 23 Mar 2017 12:40:18 -0400 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. \>\> EHLO [atm.rising-arc.com](http://atm.rising-arc.com) \<\< [250-a2ls6.a2hosting.com](http://250-a2ls6.a2hosting.com) Hello [a2ls6.a2hosting.com](http://a2ls6.a2hosting.com) [_server ip was here_] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-AUTH PLAIN LOGIN 250-STARTTLS 250 HELP \>\> STARTTLS \<\< 220 TLS go ahead !! Unable to connect with TLS encryption (code: 0)

---

<div class="post-metadata">

**Author:** ![headcountguru](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/headcountguru/32/173_2.png) [@headcountguru](https://forum.mautic.org/u/headcountguru)\
**Post date:** [March 23, 2017, 5:23pm UTC](https://forum.mautic.org/t/email-integration-says-no/8007/2 "2017-03-23T17:23:09Z")

</div>

I’m trying to use sendgrid, i tried other and my own smtp. Please decipher this?

Unable to connect with TLS encryption Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport \<\< [220-a2ls6.a2hosting.com](http://220-a2ls6.a2hosting.com) ESMTP Exim 4.88 #1 Thu, 23 Mar 2017 12:40:18 -0400 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. \>\> EHLO [atm.rising-arc.com](http://atm.rising-arc.com) \<\< [250-a2ls6.a2hosting.com](http://250-a2ls6.a2hosting.com) Hello [a2ls6.a2hosting.com](http://a2ls6.a2hosting.com) [_server ip was here_] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-AUTH PLAIN LOGIN 250-STARTTLS 250 HELP \>\> STARTTLS \<\< 220 TLS go ahead !! Unable to connect with TLS encryption (code: 0)

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [March 23, 2017, 5:24pm UTC](https://forum.mautic.org/t/email-integration-says-no/8007/3 "2017-03-23T17:24:32Z")

</div>

another one with [a2hosting.com](http://a2hosting.com) call support to unblock ports.

---

<div class="post-metadata">

**Author:** ![headcountguru](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/headcountguru/32/173_2.png) [@headcountguru](https://forum.mautic.org/u/headcountguru)\
**Post date:** [March 24, 2017, 5:43pm UTC](https://forum.mautic.org/t/email-integration-says-no/8007/4 "2017-03-24T17:43:59Z")

</div>

Hello thanks for your help. I got the test connection to work, and it says sending test email was successful. I never get the email. So i looked in logs and found what is below… INSANELY frustrating. .What do I do?

application/x-httpd-php mautic\_prod-2017-03-24.php ( ASCII text, with very long lines )

[2017-03-24 08:50:32] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 08:50:32] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 08:50:55] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 08:50:55] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 09:23:39] mautic.WARNING: PHP Warning - stream\_socket\_enable\_crypto(): Peer certificate CN=`*.a2hosting.com' did not match expected CN=`[smtp.sparkpostmail.com](http://smtp.sparkpostmail.com)’ - in file /home/risingar/atm.rising-arc.com/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php - at line 95 [] []  
[2017-03-24 09:25:44] mautic.WARNING: PHP Warning - stream\_socket\_enable\_crypto(): Peer certificate CN=`*.a2hosting.com' did not match expected CN=`[smtp.sparkpostmail.com](http://smtp.sparkpostmail.com)’ - in file /home/risingar/atm.rising-arc.com/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php - at line 95 [] []  
[2017-03-24 12:25:08] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 12:25:08] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 12:25:24] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 12:25:24] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 13:37:20] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []  
[2017-03-24 13:37:20] mautic.NOTICE: PHP Notice - Unknown: Certificate failure for [mail.rising-arc.com](http://mail.rising-arc.com): Server name does not match certificate: /C=US/ST=Michigan/L=Ann Arbor/O=A2 Hosting, Inc./CN=_.a2hosting.com (errflg=2) - in file Unknown - at line 0 [] []
