# Email sending problem

**URL:** <https://forum.mautic.org/t/email-sending-problem/2813>\
**Category:** Product Support\
**Created:** [November 20, 2015, 3:40am UTC](https://forum.mautic.org/t/email-sending-problem/2813 "2015-11-20T03:40:11Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Blancher](https://avatars.discourse-cdn.com/v4/letter/b/f14d63/32.png) [@Blancher](https://forum.mautic.org/u/Blancher)\
**Post date:** [November 20, 2015, 3:40am UTC](https://forum.mautic.org/t/email-sending-problem/2813/1 "2015-11-20T03:40:11Z")

</div>

Hi all,  
  
  
  
I set up Mautic on my server, do the CRON jobs and all but, when I want to send an email, it doesnt work. I use Sendgrid services to send it and when I want to connect it’s show me this error (pass and Id are well registred):  
  
  
  
Unable to connect with TLS encryption Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport \<\< [220-server.graditest.com](http://220-server.graditest.com) ESMTP Exim 4.86 #2 Fri, 20 Nov 2015 03:31:58 +0000 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. \>\> EHLO [marketing.graditest.com](http://marketing.graditest.com) \<\< [250-server.graditest.com](http://250-server.graditest.com) Hello [server.graditest.com](http://server.graditest.com) [162.144.202.98] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-AUTH PLAIN LOGIN 250-STARTTLS 250 HELP \>\> STARTTLS \<\< 220 TLS go ahead !! Unable to connect with TLS encryption  
  
++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport \<\< [220-server.graditest.com](http://220-server.graditest.com) ESMTP Exim 4.86 #2 Fri, 20 Nov 2015 03:31:58 +0000 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. \>\> EHLO [marketing.graditest.com](http://marketing.graditest.com) \<\< [250-server.graditest.com](http://250-server.graditest.com) Hello [server.graditest.com](http://server.graditest.com) [162.144.202.98] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-AUTH PLAIN LOGIN 250-STARTTLS 250 HELP \>\> STARTTLS \<\< 220 TLS go ahead !! Unable to connect with TLS encryption  
  
  
  
  
  
Anyone have an idea? is it from my server? something I missed?  
  
  
  
Thx

---

<div class="post-metadata">

**Author:** ![Blancher](https://avatars.discourse-cdn.com/v4/letter/b/f14d63/32.png) [@Blancher](https://forum.mautic.org/u/Blancher)\
**Post date:** [November 20, 2015, 3:40am UTC](https://forum.mautic.org/t/email-sending-problem/2813/2 "2015-11-20T03:40:11Z")

</div>

Hi all,

I set up Mautic on my server, do the CRON jobs and all but, when I want to send an email, it doesnt work. I use Sendgrid services to send it and when I want to connect it’s show me this error (pass and Id are well registred):

Unable to connect with TLS encryption Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport \<\< [220-server.graditest.com](http://220-server.graditest.com) ESMTP Exim 4.86 #2 Fri, 20 Nov 2015 03:31:58 +0000 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. \>\> EHLO [marketing.graditest.com](http://marketing.graditest.com) \<\< [250-server.graditest.com](http://250-server.graditest.com) Hello [server.graditest.com](http://server.graditest.com) [162.144.202.98] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-AUTH PLAIN LOGIN 250-STARTTLS 250 HELP \>\> STARTTLS \<\< 220 TLS go ahead !! Unable to connect with TLS encryption  
++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport \<\< [220-server.graditest.com](http://220-server.graditest.com) ESMTP Exim 4.86 #2 Fri, 20 Nov 2015 03:31:58 +0000 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. \>\> EHLO [marketing.graditest.com](http://marketing.graditest.com) \<\< [250-server.graditest.com](http://250-server.graditest.com) Hello [server.graditest.com](http://server.graditest.com) [162.144.202.98] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-AUTH PLAIN LOGIN 250-STARTTLS 250 HELP \>\> STARTTLS \<\< 220 TLS go ahead !! Unable to connect with TLS encryption

Anyone have an idea? is it from my server? something I missed?

Thx

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [November 20, 2015, 11:30am UTC](https://forum.mautic.org/t/email-sending-problem/2813/3 "2015-11-20T11:30:46Z")

</div>

The error message says:

> [@](#):
>
> Unable to connect with TLS encryption

Try a different encryption or a port number.

---

<div class="post-metadata">

**Author:** ![Blancher](https://avatars.discourse-cdn.com/v4/letter/b/f14d63/32.png) [@Blancher](https://forum.mautic.org/u/Blancher)\
**Post date:** [November 20, 2015, 3:26pm UTC](https://forum.mautic.org/t/email-sending-problem/2813/4 "2015-11-20T15:26:59Z")

</div>

Hi escopecz,

Thanks to always reply 🙂  
can you be a bit more specific, I’m learning and sometimes can be a bit difficult to me. Ok, I need to change TLS, should it be:

1. from Mautic?
2. from my server?
3. from sendgrid?

On Mautic, I just have option to change “Service to send mail through”. As I saw in another post where someone have a problem with sendgrid, i try to use “Other SMTP Server” with this config:  
SMTP host : [smtp.sendgrid.net](http://smtp.sendgrid.net)  
SMTP port : 465  
SMTP encryption type : SSL / TLS / None (I tried all)  
SMTP authentication mode : Login  
and set my Sendgrid password and username.

But it’s not working too. Something from Sendgrid I dind’t configurate well? Can it be from my server side?

Thx  
Loic

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [November 20, 2015, 3:50pm UTC](https://forum.mautic.org/t/email-sending-problem/2813/5 "2015-11-20T15:50:26Z")

</div>

I’m no expert for email configuration. All I have is [google search](https://www.google.cz/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8&client=ubuntu#q=sendgrid%20smtp). From the [Sendgrid docs](https://sendgrid.com/docs/Integrate/index.html?ls=Advertisement&cid=70180000000cl5Z&lsd=adwords&kw=Sendgrid%20smtp&mt=e&gaid=Integration_Sitelink&mc=Paid%20Search&mcd=AdWords&keyword=sendgrid%20smtp&network=g&matchtype=e&mobile=&content=&search=1&cvosrc=PPC.Google.sendgrid%20smtp&cvo_cid=Integration_Sitelink&gclid=Cj0KEQiApruyBRCFqoDu1pbk9rkBEiQAF8EFdZPQBt3fGxrQgkYdLB7bxGmBDs-McRyP26_5xdYATVsaAn0_8P8HAQ):

[quote]Change your SMTP username and password to your SendGrid credentials  
Set the server host name to [smtp.sendgrid.net](http://smtp.sendgrid.net)  
Use ports 25 or 587 for plain/TLS connections and port 465 for SSL connections[/quote]

So I’d say that you should change port from 465 to 587 to use TLS.

---

<div class="post-metadata">

**Author:** ![Blancher](https://avatars.discourse-cdn.com/v4/letter/b/f14d63/32.png) [@Blancher](https://forum.mautic.org/u/Blancher)\
**Post date:** [November 20, 2015, 6:05pm UTC](https://forum.mautic.org/t/email-sending-problem/2813/6 "2015-11-20T18:05:52Z")

</div>

hi Escopecz,

I check this doc and change the port from 465 to 587 but still don’t work. The strange things is when I install Mautic, the Sendgrid conection was working. But now, not possible to use it. Can it be something wrong configurated on my server? Usualy Mautic should use HTTPS?

Thx

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [November 23, 2015, 10:26am UTC](https://forum.mautic.org/t/email-sending-problem/2813/7 "2015-11-23T10:26:25Z")

</div>

Check the Mautic logs (app/logs dir) and server logs for a PHP error.

---

<div class="post-metadata">

**Author:** ![vln104](https://avatars.discourse-cdn.com/v4/letter/v/5f9b8f/32.png) [@vln104](https://forum.mautic.org/u/vln104)\
**Post date:** [November 23, 2015, 10:53am UTC](https://forum.mautic.org/t/email-sending-problem/2813/8 "2015-11-23T10:53:56Z")

</div>

I am using a shared host (1and1) so found that in order to connect to Sendgrid, I have to select “Other SMTP Server” in Mautic then configured as follow:

SMTP host: [smtp.sendgrid.net](http://smtp.sendgrid.net)  
TSL encryption  
SMTP port: 2525  
username and password as usual.

Hope this helps.

Kind regards,

Linh

---

<div class="post-metadata">

**Author:** ![Blancher](https://avatars.discourse-cdn.com/v4/letter/b/f14d63/32.png) [@Blancher](https://forum.mautic.org/u/Blancher)\
**Post date:** [November 23, 2015, 4:16pm UTC](https://forum.mautic.org/t/email-sending-problem/2813/9 "2015-11-23T16:16:56Z")

</div>

Hi Linh,

Nice!!! It’s works perfectly!!!

Tnaks a lot  
Loic

---

<div class="post-metadata">

**Author:** ![vln104](https://avatars.discourse-cdn.com/v4/letter/v/5f9b8f/32.png) [@vln104](https://forum.mautic.org/u/vln104)\
**Post date:** [November 23, 2015, 4:57pm UTC](https://forum.mautic.org/t/email-sending-problem/2813/10 "2015-11-23T16:57:32Z")

</div>

Glad to have helped 🙂

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 10:56pm UTC](https://forum.mautic.org/t/email-sending-problem/2813/11 "2020-02-02T22:56:50Z")

</div>


