# Error 500 when installe Mautic

**URL:** <https://forum.mautic.org/t/error-500-when-installe-mautic/21852>\
**Category:** Product Support\
**Created:** [December 1, 2021, 4:35pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852 "2021-12-01T16:35:39Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![lamine](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lamine/32/6341_2.png) [@lamine](https://forum.mautic.org/u/lamine)\
**Post date:** [December 1, 2021, 4:35pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/1 "2021-12-01T16:35:39Z")

</div>

**Your software**  
My Mautic version is: 4.1  
My PHP version is: 7.4  
My Database type and version is:

**Your problem**  
My problem is:

**I get error 500 when i would installed it**

 ![Capture d’écran (13)](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/1/165af32bb1ef65da70f01ec09dea04b8f33be3c4.png)

These errors are showing in the log: no

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [December 1, 2021, 6:01pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/2 "2021-12-01T18:01:19Z")

</div>

To me it seems like a file ownership issue / or webserver settings.

---

<div class="post-metadata">

**Author:** ![lamine](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lamine/32/6341_2.png) [@lamine](https://forum.mautic.org/u/lamine)\
**Post date:** [December 9, 2021, 1:51pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/3 "2021-12-09T13:51:13Z")

</div>

I finally solved it i have changed a server.

---

<div class="post-metadata">

**Author:** ![Hilary](https://avatars.discourse-cdn.com/v4/letter/h/d2c977/32.png) [@Hilary](https://forum.mautic.org/u/Hilary)\
**Post date:** [January 15, 2024, 1:45pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/4 "2024-01-15T13:45:03Z")

</div>

I have installing mautic but i haven’t been successful at it. The picture below is the feedback i get

 ![Screenshot (268)](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/2/28085bcbb088f5422cdc78131b0ee55e44806418.png)

---

<div class="post-metadata">

**Author:** ![richardnl](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/richardnl/32/11430_2.png) [@richardnl](https://forum.mautic.org/u/richardnl)\
**Post date:** [January 15, 2024, 4:06pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/5 "2024-01-15T16:06:33Z")

</div>

Start by checking the server logs as the message indicates. The server logs refer to the web server logs. This could be the Apache error log. Where exactly you can find this depends on the hosting you use.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [January 15, 2024, 5:48pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/6 "2024-01-15T17:48:51Z")

</div>

I think is a permission error. Make sure all files are owned by the web user

---

<div class="post-metadata">

**Author:** ![Hilary](https://avatars.discourse-cdn.com/v4/letter/h/d2c977/32.png) [@Hilary](https://forum.mautic.org/u/Hilary)\
**Post date:** [January 17, 2024, 9:29am UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/7 "2024-01-17T09:29:06Z")

</div>

![permisssion](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/f/fd53ffb86b6ca5d8f737b982f438ebaea80852ca.png)  
hi Joey, in the attached pic on the first two lines, it shows me permission is denied and shows me the path, how do i grant permission to it to solve the problem at hand?

please help a mautic newbie.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [January 17, 2024, 11:53am UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/8 "2024-01-17T11:53:01Z")

</div>

Sure, here is my full guide about permissions:

> **[Full guide to permissions and cache in Mautic – Joey Keller](https://joeykeller.com/full-guide-to-permissions-and-cache-in-mautic/)**

---

<div class="post-metadata">

**Author:** ![Hilary](https://avatars.discourse-cdn.com/v4/letter/h/d2c977/32.png) [@Hilary](https://forum.mautic.org/u/Hilary)\
**Post date:** [January 22, 2024, 11:11am UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/9 "2024-01-22T11:11:36Z")

</div>

Hello Joey,  
Thank you so much for your help, the permission and file ownership has been resolved.

Am trying to crack the hard nut of installing MariaDB so that i can proceed with my mautic installation.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [January 22, 2024, 11:17am UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/10 "2024-01-22T11:17:54Z")

</div>

Is it Ubuntu?

---

<div class="post-metadata">

**Author:** ![Hilary](https://avatars.discourse-cdn.com/v4/letter/h/d2c977/32.png) [@Hilary](https://forum.mautic.org/u/Hilary)\
**Post date:** [January 22, 2024, 11:18am UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/11 "2024-01-22T11:18:54Z")

</div>

Yes it is Ubuntu Linux 22.04.3

---

<div class="post-metadata">

**Author:** ![Hilary](https://avatars.discourse-cdn.com/v4/letter/h/d2c977/32.png) [@Hilary](https://forum.mautic.org/u/Hilary)\
**Post date:** [February 16, 2024, 4:15pm UTC](https://forum.mautic.org/t/error-500-when-installe-mautic/21852/12 "2024-02-16T16:15:23Z")

</div>

Hello Joey,  
Happy weekend from this side, i was able to install mautic successfully. I had uninstall and the reinstalled MariaDB, created a user and granted it full access and that was how i had access to database to proceed with my mautic installation.

Thank you Joey. You are amazing.
