# Error after update to 1.4 \[something new\]

**URL:** https://forum.mautic.org/t/error-after-update-to-1-4-something-new/4026
**Category:** Product Support
**Created:** [May 29, 2016, 12:17pm UTC](https://forum.mautic.org/t/error-after-update-to-1-4-something-new/4026 "2016-05-29T12:17:57Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![111](https://avatars.discourse-cdn.com/v4/letter/1/0ea827/32.png) [@111](https://forum.mautic.org/u/111)
#### Post date: [May 29, 2016, 12:17pm UTC](https://forum.mautic.org/t/error-after-update-to-1-4-something-new/4026/1 "2016-05-29T12:17:57Z")

</div>

Hi,  
  
  
  
Updated to 1.4 from 1.2 and everything worked fine. After update completed the website refreshed, since then it’s showing me Site is Offline, contact administrator.  
  
  
  
I am on a shared hosting and have checked the error logs, first error was in the SMSController api, which was solved reading another issue on the forum and using the pull request from github : [https://github.com/mautic/mautic/pull/1732/files](https://github.com/mautic/mautic/pull/1732/files)  
  
  
  
Now I am getting these errors[29-May-2016 13:02:42 UTC] PHP Parse error: syntax error, unexpected T\_OBJECT\_OPERATOR in /home/xx/xx/app/bundles/CampaignBundle/Entity/LeadEventLogRepository.php on line 121  
[29-May-2016 13:04:32 UTC] PHP Parse error: syntax error, unexpected T\_OBJECT\_OPERATOR in /home/xx/public\_html/xx/app/bundles/LeadBundle/Controller/LeadController.php on line 363  
[29-May-2016 13:06:46 UTC] PHP Parse error: syntax error, unexpected ‘[’ in /home/xx/public\_html/xx/app/bundles/LeadBundle/Controller/LeadController.php on line 363[/code]

Have seen this PR : [https://github.com/mautic/mautic/pull/1802](https://github.com/mautic/mautic/pull/1802)

Will try and use this. Meanwhile please do share if anything else has worked for others.  
Thanks.

[code][29-May-2016 13:02:42 UTC] PHP Parse error: syntax error, unexpected T\_OBJECT\_OPERATOR in /home/xx/xx/app/bundles/CampaignBundle/Entity/LeadEventLogRepository.php on line 121  
  
[29-May-2016 13:04:32 UTC] PHP Parse error: syntax error, unexpected T\_OBJECT\_OPERATOR in /home/xx/public\_html/xx/app/bundles/LeadBundle/Controller/LeadController.php on line 363  
  
[29-May-2016 13:06:46 UTC] PHP Parse error: syntax error, unexpected ’  
  
  
  
Have seen this PR : [https://github.com/mautic/mautic/pull/1802](https://github.com/mautic/mautic/pull/1802)  
  
  
  
Will try and use this. Meanwhile please do share if anything else has worked for others.  
  
Thanks.

---

<div class="post-metadata">

### Author: ![111](https://avatars.discourse-cdn.com/v4/letter/1/0ea827/32.png) [@111](https://forum.mautic.org/u/111)
#### Post date: [May 29, 2016, 12:17pm UTC](https://forum.mautic.org/t/error-after-update-to-1-4-something-new/4026/2 "2016-05-29T12:17:57Z")

</div>

Hi,

Updated to 1.4 from 1.2 and everything worked fine. After update completed the website refreshed, since then it’s showing me Site is Offline, contact administrator.

I am on a shared hosting and have checked the error logs, first error was in the SMSController api, which was solved reading another issue on the forum and using the pull request from github : [https://github.com/mautic/mautic/pull/1732/files](https://github.com/mautic/mautic/pull/1732/files)

Now I am getting these errors`[29-May-2016 13:02:42 UTC] PHP Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/xx/xx/app/bundles/CampaignBundle/Entity/LeadEventLogRepository.php on line 121
[29-May-2016 13:04:32 UTC] PHP Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/xx/public_html/xx/app/bundles/LeadBundle/Controller/LeadController.php on line 363
[29-May-2016 13:06:46 UTC] PHP Parse error: syntax error, unexpected '[' in /home/xx/public_html/xx/app/bundles/LeadBundle/Controller/LeadController.php on line 363`

Have seen this PR : [https://github.com/mautic/mautic/pull/1802](https://github.com/mautic/mautic/pull/1802)

Will try and use this. Meanwhile please do share if anything else has worked for others.  
Thanks.

---

<div class="post-metadata">

### Author: ![111](https://avatars.discourse-cdn.com/v4/letter/1/0ea827/32.png) [@111](https://forum.mautic.org/u/111)
#### Post date: [May 29, 2016, 12:41pm UTC](https://forum.mautic.org/t/error-after-update-to-1-4-something-new/4026/3 "2016-05-29T12:41:14Z")

</div>

Okay, applied all the changes of the PR and now I am getting internal server error

` Uh oh! I think I broke it. If I do it again, please report me to the system administrator!
500 Internal Server Error`

No new error log created inside the app.

EDIT: Updated schema now everything works 🙂
