# Error connecting to the aws ses with sns

**URL:** <https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961>\
**Category:** General Discussion\
**Tags:** mautic-3\
**Created:** [June 25, 2021, 10:34pm UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961 "2021-06-25T22:34:03Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![cadentic](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/cadentic/32/434_2.png) [@cadentic](https://forum.mautic.org/u/cadentic)\
**Post date:** [June 25, 2021, 10:34pm UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/1 "2021-06-25T22:34:03Z")

</div>

hi

I am connecting through programmatic access API.  
NS provider Cloudflare

endpoint i specified during the creation of SNS topic and subscription is : [https://mautic.domain.com:2087/mailer/amazon\_api/callback](https://mautic.domain.com:2087/mailer/amazon_api/callback)  
but AWS SNS subscription is showing pending.

how to fix it.

thx  
sayantan

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [June 27, 2021, 6:00am UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/2 "2021-06-27T06:00:20Z")

</div>

Interesting. That should work out of the box. Do you have Amazon ses api enabled right? Not SMTP.

---

<div class="post-metadata">

**Author:** ![cadentic](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/cadentic/32/434_2.png) [@cadentic](https://forum.mautic.org/u/cadentic)\
**Post date:** [June 27, 2021, 6:26pm UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/3 "2021-06-27T18:26:07Z")

</div>

yes . ofcourse it is api with i am user who would have full access to sns and ses. sns and ses are not within sandbox though.

---

<div class="post-metadata">

**Author:** ![robm](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/robm/32/260_2.png) [@robm](https://forum.mautic.org/u/robm)\
**Post date:** [June 29, 2021, 9:10am UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/4 "2021-06-29T09:10:44Z")

</div>

I had this issue. I tried changing regions then it magically started working.

---

<div class="post-metadata">

**Author:** ![cadentic](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/cadentic/32/434_2.png) [@cadentic](https://forum.mautic.org/u/cadentic)\
**Post date:** [June 29, 2021, 10:05pm UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/5 "2021-06-29T22:05:39Z")

</div>

so aws ses , sns, and mautic must be within the same region? or just I can use SNS for the same region?  
my instance has full access for them within a custom role assigned to that instance why can not we have cross-region?

but i tried the same with fluentcrm it worked there. i think it is a glitch.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [June 30, 2021, 6:35am UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/6 "2021-06-30T06:35:53Z")

</div>

I don’t think region has anything to do with it. I have a general listener, that captures data from any region.  
What @robm is saying: he switched the region (probably back and forth) and suddenly started to work.  
J

---

<div class="post-metadata">

**Author:** ![robm](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/robm/32/260_2.png) [@robm](https://forum.mautic.org/u/robm)\
**Post date:** [June 30, 2021, 6:52am UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/7 "2021-06-30T06:52:39Z")

</div>

exactly, like a blind monkey smashing keys until something works. In this case, the region change made all the difference, no idea why. It shouldn’t but it did.

---

<div class="post-metadata">

**Author:** ![cadentic](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/cadentic/32/434_2.png) [@cadentic](https://forum.mautic.org/u/cadentic)\
**Post date:** [July 5, 2021, 9:35am UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/8 "2021-07-05T09:35:58Z")

</div>

@robm @joeyk can we have a VPC to VPC inter-regional peering within same account to resolve it?  
for example, if VPC @ Ohio and VPC@Sydny wouldn’t share the same CIDR then we can have a peering between them. but can it be resolved that way?

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [July 5, 2021, 2:13pm UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/9 "2021-07-05T14:13:18Z")

</div>

Sorry I don’t know what a VPC is

---

<div class="post-metadata">

**Author:** ![cadentic](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/cadentic/32/434_2.png) [@cadentic](https://forum.mautic.org/u/cadentic)\
**Post date:** [July 6, 2021, 4:34am UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/10 "2021-07-06T04:34:36Z")

</div>

hi

please take look at this if you want to know about vpc peering 🌐

ref : [What is VPC peering? - Amazon Virtual Private Cloud](https://docs.aws.amazon.com/vpc/latest/peering/what-is-vpc-peering.html)

---

<div class="post-metadata">

**Author:** ![wlandgraf](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/wlandgraf/32/764_2.png) [@wlandgraf](https://forum.mautic.org/u/wlandgraf)\
**Post date:** [July 7, 2021, 6:14pm UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/11 "2021-07-07T18:14:58Z")

</div>

As far as I know, SES and SNS must be in the same AWS region to work.

---

<div class="post-metadata">

**Author:** ![cadentic](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/cadentic/32/434_2.png) [@cadentic](https://forum.mautic.org/u/cadentic)\
**Post date:** [July 8, 2021, 3:11am UTC](https://forum.mautic.org/t/error-connecting-to-the-aws-ses-with-sns/19961/12 "2021-07-08T03:11:39Z")

</div>

@wlandgraf SES detected the SNS topic perfectly which means they are in the same region already but the ec2 lies with the different region where actually mautic is deployed. if i need to change the region of ec2 for such purpose it means if some client using a self hosted node and want to use aws ses /sns as an integrated service their instance will fail to connect too ,(of-course in logical sense)
