# Error while using emai DSN on mautic

**URL:** <https://forum.mautic.org/t/error-while-using-emai-dsn-on-mautic/31870>\
**Category:** Mautic 5 Install/Upgrade Support\
**Created:** [April 26, 2024, 12:13pm UTC](https://forum.mautic.org/t/error-while-using-emai-dsn-on-mautic/31870 "2024-04-26T12:13:59Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![khelmerrah](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/khelmerrah/32/11896_2.png) [@khelmerrah](https://forum.mautic.org/u/khelmerrah)\
**Post date:** [April 26, 2024, 12:13pm UTC](https://forum.mautic.org/t/error-while-using-emai-dsn-on-mautic/31870/1 "2024-04-26T12:13:59Z")

</div>

**Your software**  
My Mautic version is: v5.0.4  
My PHP version is: 8.1  
My Database type and version is: mysql

**Your problem**  
My problem is:

I just installed Mautic through Softaculous installer, it didn’t ask for any smtp, but now i can’t find any way to connect it other than trying this new Email DSN in the email settings area.

 ![Screenshot 2024-04-26 124040](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/e/ecb1a2f2b99fb5c32f222d186d0ef1ed92fbd05c.png)

These errors are showing in the log:

Expected response code “250” but got code “554”, with message “554 5.9.2 Sender domain is not valid.”.

Steps I have tried to fix the problem:  
tried ssl/tls, checked password, chaned from:email

---

<div class="post-metadata">

**Author:** ![bunce69](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bunce69/32/143_2.png) [@bunce69](https://forum.mautic.org/u/bunce69)\
**Post date:** [June 8, 2024, 5:17pm UTC](https://forum.mautic.org/t/error-while-using-emai-dsn-on-mautic/31870/2 "2024-06-08T17:17:31Z")

</div>

+1 - I need help the same with postmark.

---

<div class="post-metadata">

**Author:** ![peter\_k](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/peter_k/32/511_2.png) [@peter\_k](https://forum.mautic.org/u/peter_k)\
**Post date:** [June 9, 2024, 7:38am UTC](https://forum.mautic.org/t/error-while-using-emai-dsn-on-mautic/31870/3 "2024-06-09T07:38:18Z")

</div>

> [@khelmerrah](#):
>
> 554

There might be a problem with your password. If it contains a special character it’ll cause problems ATM:

> **[Mautic 5: Key Gotchas and How to Navigate Them](https://audienture.com/mautic-5-key-gotchas-and-how-to-navigate-them/#special-characters-in-mailerdsn)**
>
> Long awaited Mautic 5 is finally here 🥳 Ready to install?
> 
> Mautic 5 comes with some significant changes. Because of at least one you might want to wait for a bit before you update—as you could, for example, accidentally destroy your sender...

Relevant GitHub issues:

> <https://github.com/mautic/mautic/issues/12256?ref=audienture.com>
>
> \### Mautic Version
> 
> 4.4.x series
> 
> \### PHP version
> 
> 8.0
> 
> \### What browsers are yo…u seeing the problem on?
> 
> Not relevant
> 
> \### What happened?
> 
> Pretty simple, but hard to find: if Amazon AWS SES defines a secret / password that contains a "/" it will lead to an authorization error with the plattform. The error message:
> 
> \`Error executing "GetAccount" on "https://email.eu-central-1.amazonaws.com/v2/email/account"; AWS HTTP error: Client error: \`GET https://email.eu-central-1.amazonaws.com/v2/email/account\` resulted in a \`403 Forbidden\` response: {"message":"The request signature we calculated does not match the signature you provided. Check your AWS Secret Access (truncated...) InvalidSignatureException (client): The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details. - {"message":"The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details."}\`
> 
> The problem: AWS assigns the password randomly, often it contains a "/". You can only delete the just created key and create a new one - hoping this time its without the "special" character.
> 
> \### How can we reproduce this issue?
> 
> Step 1: Connect with Amazon SES API with a password, that contains a "/"
> Step 2: Save and test the connection - it will throw this error.
> Step 3: Back to AWS and get another key assigned. It it has no "/" it will work.
> 
> \### Relevant log output
> 
> \`\`\`shell
> \`Error executing "GetAccount" on "https://email.eu-central-1.amazonaws.com/v2/email/account"; AWS HTTP error: Client error: \`GET https://email.eu-central-1.amazonaws.com/v2/email/account\` resulted in a \`403 Forbidden\` response: {"message":"The request signature we calculated does not match the signature you provided. Check your AWS Secret Access (truncated...) InvalidSignatureException (client): The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details. - {"message":"The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details."}\`
> \`\`\`
> 
> 
> \### Code of Conduct
> 
> \- \[X\] I confirm that I have read and agree to follow this project's Code of Conduct
> 
> \<bountysource-plugin\>
> 
> \---
> Want to back this issue? \*\*\[Post a bounty on it!\](https://app.bountysource.com/issues/121828581-connection-with-amazon-ses-api-won-t-work-error403-when-the-defined-password-contains-a?utm\_campaign=plugin&utm\_content=tracker%2F5355074&utm\_medium=issues&utm\_source=github)\*\* We accept bounties via \[Bountysource\](https://app.bountysource.com/?utm\_campaign=plugin&utm\_content=tracker%2F5355074&utm\_medium=issues&utm\_source=github).
> \</bountysource-plugin\>

> <https://github.com/mautic/mautic/issues/13228?ref=audienture.com>
>
> \### Mautic Version
> 
> 5.0.x series
> 
> \### PHP version
> 
> 8.1
> 
> \### What browsers are yo…u seeing the problem on?
> 
> Not relevant
> 
> \### What happened?
> 
> I believe there is a problem in setting up the queue for email using Amazon SQS. If I get a secret\_key that includes any special character i.e. / o + then at the moment the secret is retrieved a % is appended to this character (in the config/local.php), even after parsing it gets the wrong secret to the SQS and obviously it doesnt verify. 
> Workaround: try to get secret\_key without special characters. 
> 
> \### How can we reproduce this issue?
> 
> Configure sqs scheme in the queue, use any special character in the secret
> 
> Scheme: sqs
> Host: default
> Port: empty
> Path: empty
> User: empty
> Password: empty
> Options:
> access\_key: (amazon access key)
> account: (amazon account)
> auto\_setup: false
> queue\_name: (name of the queue)
> secret\_key: (amazon secret key)
> region: us-east-1
> 
> \### Relevant log output
> 
> \_No response\_
> 
> \### Code of Conduct
> 
> \- \[X\] I confirm that I have read and agree to follow this project's Code of Conduct
> 
> \<br /\>\<hr\>
> Care about this issue? Want to get it resolved sooner? If you are a \<a href='https://www.mautic.org/become-a-member-of-mautic'\>member of Mautic\</a\>, you can add some funds to the \<a href='https://opencollective.com/mautic/projects/bounties'\>Bounties Project\</a\> so that the person who completes this task can claim those funds once it is merged by a member of the core team! Read the docs \<a href='https://contribute.mautic.org/product-team/mautic-bounty-programme'\>here.\</a\>
