# {"error":"You do not have access to the requested area/action."}

**URL:** <https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103>\
**Category:** Product Support\
**Created:** [August 29, 2016, 6:21pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103 "2016-08-29T18:21:08Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![BradGriffin](https://avatars.discourse-cdn.com/v4/letter/b/fbc32d/32.png) [@BradGriffin](https://forum.mautic.org/u/BradGriffin)\
**Post date:** [August 29, 2016, 6:21pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103/1 "2016-08-29T18:21:08Z")

</div>

Let’s try to make the most exhaustive and complete ticket here, ready?  
  
  
  
When I go to make a new form like this: [http://screencast-o-matic.com/watch/cDjUFxjVwS](http://screencast-o-matic.com/watch/cDjUFxjVwS)  
  
I get an error of {“error”:“You do not have access to the requested area/action.”} Ok, no problem right? So I search the docs and find these threads :  
  
  
  
[https://www.mautic.org/community/index.php/1486-you-do-not-have-access-to-the-requested-area-action-in-forms-fi/0](https://www.mautic.org/community/index.php/1486-you-do-not-have-access-to-the-requested-area-action-in-forms-fi/0) \<— That “could” be the problem unfortunately, we’re not rockin’ the varnish. **So… that ain’t it!**  
  
  
  
[https://www.mautic.org/community/index.php/1394-you-do-not-have-access-to-the-requested-area-action/0](https://www.mautic.org/community/index.php/1394-you-do-not-have-access-to-the-requested-area-action/0) I don’t think that’s the answer since I’ve confirmed the right SSL settings are being applied correctly ![b878926b10834963a1c17b08ff771b95.png](http://image.prntscr.com/image/b878926b10834963a1c17b08ff771b95.png)  
  
  
  
After reading the next doc…[https://www.mautic.org/community/index.php/269-form-redirect-failing/0](https://www.mautic.org/community/index.php/269-form-redirect-failing/0) appears to be not related and already patched here: [https://github.com/mautic/mautic/issues/272](https://github.com/mautic/mautic/issues/272)  
  
  
  
This definitely does not apply since I’m not attempting anything within the api: [https://www.mautic.org/community/index.php/3295-error-403-at-creating-a-lead-with-api/](https://www.mautic.org/community/index.php/3295-error-403-at-creating-a-lead-with-api/) Again, thinking & wondering if it’d be more along the lines of the first forum doc with the nginx gist in it.  
  
  
  
I did set up Mautic’s log file which is here: /l/app/logs/mautic\_prod-2016-08-29.php But that log output doesn’t yield any indications that seem to be directly related to the error. **_(or does it? Pardon my #always-be-learning mentality, but I don’t think this log is actually related to the error. But, then again, I’m not afraid of being wrong!)_**

Code:

[2016-08-29 18:39:29] mautic.ERROR: Deprecation: The alias option of the form.type\_extension tag of service "fos\_rest.form.extension.csrf\_disable" is deprecated since version 2.8 and will be removed in 3.0. Use the extended\_type option instead. - in file /home/bradgrif/public\_html/l/vendor/symfony/framework-bundle/DependencyInjection/Compiler/FormPass.php - at line 67 [] [] [2016-08-29 18:41:14] mautic.ERROR: Deprecation: The alias option of the form.type\_extension tag of service "fos\_rest.form.extension.csrf\_disable" is deprecated since version 2.8 and will be removed in 3.0. Use the extended\_type option instead. - in file /home/bradgrif/public\_html/l/vendor/symfony/framework-bundle/DependencyInjection/Compiler/FormPass.php - at line 67 [] []

  
I know a ping of @alanhartless or @escopecz might get me a Texas sized kick in the rump, but I'm gonna hope that someone can help. Not really just **_help_** as in fix it, but really help me understand **_"why"_** it is that I can't quite figure this out **_myself_**![:-)]( ":-)") My time-allotted vs time-spent is getting a bit excessive ![:-)]( ":-)")  
  
copy of cron settings: http://prntscr.com/cbt297  
insanely large txt file of sysinfo: http://bradgriffin.me/mautic\_environment.txt  
  
**THANKS FOLKS!**  
  
\*\*mental note\*\* take all YouTube videos, ask for subdomain like learn.mautic.org, then use lifterlms to organize videos into "order" & "workflow", add confidence building quizzes + answers, give myself a hug for contributing something that helps better community understanding, and reduces questions as well.

---

<div class="post-metadata">

**Author:** ![BradGriffin](https://avatars.discourse-cdn.com/v4/letter/b/fbc32d/32.png) [@BradGriffin](https://forum.mautic.org/u/BradGriffin)\
**Post date:** [August 29, 2016, 6:21pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103/2 "2016-08-29T18:21:08Z")

</div>

Let’s try to make the most exhaustive and complete ticket here, ready?

When I go to make a new form like this: [http://screencast-o-matic.com/watch/cDjUFxjVwS](http://screencast-o-matic.com/watch/cDjUFxjVwS)  
I get an error of {“error”:“You do not have access to the requested area/action.”} Ok, no problem right? So I search the docs and find these threads :

[https://www.mautic.org/community/index.php/1486-you-do-not-have-access-to-the-requested-area-action-in-forms-fi/0](https://www.mautic.org/community/index.php/1486-you-do-not-have-access-to-the-requested-area-action-in-forms-fi/0) \<— That “could” be the problem unfortunately, we’re not rockin’ the varnish. So… that ain’t it!

[https://www.mautic.org/community/index.php/1394-you-do-not-have-access-to-the-requested-area-action/0](https://www.mautic.org/community/index.php/1394-you-do-not-have-access-to-the-requested-area-action/0) I don’t think that’s the answer since I’ve confirmed the right SSL settings are being applied correctly ![](http://image.prntscr.com/image/b878926b10834963a1c17b08ff771b95.png)

After reading the next doc…[https://www.mautic.org/community/index.php/269-form-redirect-failing/0](https://www.mautic.org/community/index.php/269-form-redirect-failing/0) appears to be not related and already patched here: [https://github.com/mautic/mautic/issues/272](https://github.com/mautic/mautic/issues/272)

This definitely does not apply since I’m not attempting anything within the api: [https://www.mautic.org/community/index.php/3295-error-403-at-creating-a-lead-with-api/](https://www.mautic.org/community/index.php/3295-error-403-at-creating-a-lead-with-api/) Again, thinking & wondering if it’d be more along the lines of the first forum doc with the nginx gist in it.

I did set up Mautic’s log file which is here: /l/app/logs/mautic\_prod-2016-08-29.php But that log output doesn’t yield any indications that seem to be directly related to the error. (or does it? Pardon my #always-be-learning mentality, but I don’t think this log is actually related to the error. But, then again, I’m not afraid of being wrong!)

`[2016-08-29 18:39:29] mautic.ERROR: Deprecation: The alias option of the form.type_extension tag of service "fos_rest.form.extension.csrf_disable" is deprecated since version 2.8 and will be removed in 3.0. Use the extended_type option instead. - in file /home/bradgrif/public_html/l/vendor/symfony/framework-bundle/DependencyInjection/Compiler/FormPass.php - at line 67 [] []
[2016-08-29 18:41:14] mautic.ERROR: Deprecation: The alias option of the form.type_extension tag of service "fos_rest.form.extension.csrf_disable" is deprecated since version 2.8 and will be removed in 3.0. Use the extended_type option instead. - in file /home/bradgrif/public_html/l/vendor/symfony/framework-bundle/DependencyInjection/Compiler/FormPass.php - at line 67 [] []
`

I know a ping of @alanhartless or @escopecz might get me a Texas sized kick in the rump, but I’m gonna hope that someone can help. Not really just help as in fix it, but really help me understand “why” it is that I can’t quite figure this out myself 🙂 My time-allotted vs time-spent is getting a bit excessive 🙂

copy of cron settings: [http://prntscr.com/cbt297](http://prntscr.com/cbt297)  
insanely large txt file of sysinfo: [http://bradgriffin.me/mautic\_environment.txt](http://bradgriffin.me/mautic_environment.txt)

THANKS FOLKS!

**mental note** take all YouTube videos, ask for subdomain like [learn.mautic.org](http://learn.mautic.org), then use lifterlms to organize videos into “order” & “workflow”, add confidence building quizzes + answers, give myself a hug for contributing something that helps better community understanding, and reduces questions as well.

---

<div class="post-metadata">

**Author:** ![BradGriffin](https://avatars.discourse-cdn.com/v4/letter/b/fbc32d/32.png) [@BradGriffin](https://forum.mautic.org/u/BradGriffin)\
**Post date:** [August 29, 2016, 6:35pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103/3 "2016-08-29T18:35:17Z")

</div>

OH SNAP! After jacking around a while, my error\_log finally blew up! #wahoo! Now we can see this repeating over and over again:

`[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285
[29-Aug-2016 19:20:01 UTC] PHP Notice: Undefined index: argv in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 55
[29-Aug-2016 19:20:01 UTC] PHP Warning: array_shift() expects parameter 1 to be array, null given in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 59`

Line 55 of ArgvInput.php is referring to …what _???_ the server name, right? Which was already set here: ![](http://image.prntscr.com/image/b878926b10834963a1c17b08ff771b95.png) correct?

Line 59 of ArgvInput.php is referring to …what _???_ somehow taking the last character off of the \_SERVER variable? Did I get that part right? If so, then somewhere along in the process, I’m guessing I need to take off a forward slash? No, wait. I should probably be **adding** a forward slash to something correct? thinking out loud

---

<div class="post-metadata">

**Author:** ![BradGriffin](https://avatars.discourse-cdn.com/v4/letter/b/fbc32d/32.png) [@BradGriffin](https://forum.mautic.org/u/BradGriffin)\
**Post date:** [August 29, 2016, 7:30pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103/4 "2016-08-29T19:30:58Z")

</div>

changed cron settings to this (which didn’t help) and apparently had nothing to do with the original problem, but I thought twice after re-reading this doc: [https://mautic.org/docs/en/setup/cron\_jobs.html](https://mautic.org/docs/en/setup/cron_jobs.html) as it wasn’t quite specific enough for my brain to figure out:  
 ![](http://image.prntscr.com/image/7f895c3eef5b44239b57c26eeab3cee2.png)

THEN I also rubbed all my brain cells together and started wondering what the `array_shift` does. So, after reading thishttp://php.net/manual/en/function.array-shift.php , I added a trailing forward slash to the main URL like this ![](http://image.prntscr.com/image/132c3c5b1d6146a694f04940aac33623.png)

thinking that the additional character would/ might/ could/ should/ …fix the problem.

[h]Nope.[/h]  
 ![](http://image.prntscr.com/image/e3e3cd03b9fb4b1fb05a87a277abece1.gif)

---

<div class="post-metadata">

**Author:** ![BradGriffin](https://avatars.discourse-cdn.com/v4/letter/b/fbc32d/32.png) [@BradGriffin](https://forum.mautic.org/u/BradGriffin)\
**Post date:** [August 30, 2016, 5:12pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103/5 "2016-08-30T17:12:38Z")

</div>

[h]Where is this error coming from?[/h]  
Folks, I don’t mind giving to any and every open source platform. But I really need some help here. We can all contribute in our own way ~ from a sysadmin to a marketing aspect. But I need to get this fixed TODAY! Surely someone knows, sees, and can, at minimum, point me in the right direction or give me a hint. At this point, anything would help. Thanks!

`[30-Aug-2016 18:09:01 UTC] PHP Notice: Undefined index: argv in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 55
[30-Aug-2016 18:09:01 UTC] PHP Warning: array_shift() expects parameter 1 to be array, null given in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 59
[30-Aug-2016 18:09:01 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/bradgrif/public_html/l/vendor/symfony/console/Input/ArgvInput.php on line 285`

---

<div class="post-metadata">

**Author:** ![gmillard](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/gmillard/32/5_2.png) [@gmillard](https://forum.mautic.org/u/gmillard)\
**Post date:** [August 30, 2016, 6:13pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103/6 "2016-08-30T18:13:16Z")

</div>

Hi there.

First off - I really appreciate all the back work you did to try and get this resolved! Excellent post. Sorry responses are a little late in coming.

For the argv error - see the last paragraph of [https://mautic.org/docs/en/setup/cron\_jobs.html#tips-troubleshooting](https://mautic.org/docs/en/setup/cron_jobs.html#tips-troubleshooting) - Looks like it’s related.

For the form/JS error - see [https://github.com/mautic/mautic/issues/2401#issuecomment-243546468](https://github.com/mautic/mautic/issues/2401#issuecomment-243546468) - Cloudflare and Froala don’t play nice breaking all JS for Mautic. You unfortunately have to disable Cloudflare’s js minifying feature until Froala does something about it.

---

<div class="post-metadata">

**Author:** ![BradGriffin](https://avatars.discourse-cdn.com/v4/letter/b/fbc32d/32.png) [@BradGriffin](https://forum.mautic.org/u/BradGriffin)\
**Post date:** [August 30, 2016, 9:23pm UTC](https://forum.mautic.org/t/error-you-do-not-have-access-to-the-requested-area-action/5103/7 "2016-08-30T21:23:28Z")

</div>

Thank you @alanhartless !!  
tags & breadcrumbs for others (because we all use the Search box, right? Right! Ok. Good!)  
FIX for Mautic 2.1  
Froala editor 2.3.4  
You do not have access to the requested area  
bar keeps loading

Now, if 'ya found this page, then: Rock On! Read @alanhartless 's message right above this about disabling CloudFlare’s js minification like this:  
 ![](http://image.prntscr.com/image/85b012390c5b4b2799a937f824a7b948.png)
