# Errors upgrading 2.15.3 -\> 2.16.2, re-run more successful

**URL:** <https://forum.mautic.org/t/errors-upgrading-2-15-3-2-16-2-re-run-more-successful/14210>\
**Category:** Product Support\
**Created:** [May 6, 2020, 2:41pm UTC](https://forum.mautic.org/t/errors-upgrading-2-15-3-2-16-2-re-run-more-successful/14210 "2020-05-06T14:41:50Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![aerendir](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/aerendir/32/1050_2.png) [@aerendir](https://forum.mautic.org/u/aerendir)\
**Post date:** [June 18, 2020, 8:33pm UTC](https://forum.mautic.org/t/errors-upgrading-2-15-3-2-16-2-re-run-more-successful/14210/3 "2020-06-18T20:33:03Z")

</div>

Here is my post

> [@Impossible to update from 2.16.0](https://forum.mautic.org/t/impossible-to-update-from-2-16-0/14858):
>
> Your software My Mautic version is: 2.16.0 My PHP version is: Irrelevant Your problem My problem is: I cannot update to Mautic 2.16.2 nor to 2.16.1. The error is always the same: [Symfony\Component\Debug\Exception\FatalThrowableError] Type error: Argument 1 passed to Mautic\CoreBundle\Helper\LanguageHelper::\_\_construct() must be an instance of Mautic\CoreBundle\Helper\PathsHelper, instance of Mautic\C oreBundle\Factory\MauticFactory given, called in /var/www/[redacted]/public\_html/app/c…

---

_[View the full topic](https://forum.mautic.org/t/errors-upgrading-2-15-3-2-16-2-re-run-more-successful/14210)._
