# Failed emails status does not work even after 3 retries

**URL:** https://forum.mautic.org/t/failed-emails-status-does-not-work-even-after-3-retries/35238
**Category:** Mautic 5 Install/Upgrade Support
**Tags:** community, development, email
**Created:** [March 10, 2025, 4:33pm UTC](https://forum.mautic.org/t/failed-emails-status-does-not-work-even-after-3-retries/35238 "2025-03-10T16:33:47Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![kiarttantasi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/kiarttantasi/32/13386_2.png) [@kiarttantasi](https://forum.mautic.org/u/kiarttantasi)
#### Post date: [March 10, 2025, 4:33pm UTC](https://forum.mautic.org/t/failed-emails-status-does-not-work-even-after-3-retries/35238/1 "2025-03-10T16:33:47Z")

</div>

**Your software**  
My Mautic version is: 5.0.4  
My PHP version is: 8.1  
My Database type and version is: 8.0

**Your problem**  
My problem is:  
I am on Mautic v5.0.4. After email-sending fails and already retried for 3 times and logs the error into `/var/logs`, it would still store the record down into column `email_stats.is_failed` as `0` which I think should actually be `1` . How can I fix this ?

 ![image](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/c/c198ef62496f0833806f0013f3bd7f7ca632c8a3.png)

These errors are showing in the log:

- (intended errors log below)
- failed: Connection could not be established with host “[invalidhost.com:25](http://invalidhost.com:25)”
- Recipient address rejected: Access denied

Steps I have tried to fix the problem:  
tried to but cannot locate the code to stamp is\_failed column
