# Failed opening required ‘/var/www/vhosts/mautic/app/…/vendor/autoload.php’ (include\_path=’.:/opt/plesk/php/7.2/share/pear’) in /var/www/vhosts/mautic/app/autoload.php on line 15\\n’

**URL:** <https://forum.mautic.org/t/failed-opening-required-var-www-vhosts-mautic-app-vendor-autoload-php-include-path-opt-plesk-php-7-2-share-pear-in-var-www-vhosts-mautic-app-autoload-php-on-line-15-n/13073>\
**Category:** Product Support\
**Created:** [February 25, 2020, 5:21pm UTC](https://forum.mautic.org/t/failed-opening-required-var-www-vhosts-mautic-app-vendor-autoload-php-include-path-opt-plesk-php-7-2-share-pear-in-var-www-vhosts-mautic-app-autoload-php-on-line-15-n/13073 "2020-02-25T17:21:04Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [February 25, 2020, 5:21pm UTC](https://forum.mautic.org/t/failed-opening-required-var-www-vhosts-mautic-app-vendor-autoload-php-include-path-opt-plesk-php-7-2-share-pear-in-var-www-vhosts-mautic-app-autoload-php-on-line-15-n/13073/1 "2020-02-25T17:21:04Z")

</div>

**Your software**  
My Mautic version is:2.16  
My PHP version is:7.3

**Your problem**  
My problem is: 500 error

These errors are showing in the log:  
Got error ‘PHP message: PHP Warning: require(/var/www/vhosts/techphenomenon.com/hub.techphenomenon.com/app/…/vendor/autoload.php): failed to open stream: No such file or directory in /var/www/vhosts/Mautic/app/autoload.php on line 15\nPHP message: PHP Warning: require(/var/www/vhosts/mautic/app/…/vendor/autoload.php): failed to open stream: No such file or directory in /var/www/vhosts/mautic/app/autoload.php on line 15\nPHP message: PHP Fatal error: require(): Failed opening required ‘/var/www/vhosts/mautic/app/…/vendor/autoload.php’ (include\_path=’.:/opt/plesk/php/7.2/share/pear’) in /var/www/vhosts/mautic/app/autoload.php on line 15\n’  
Steps I have tried to fix the problem: cleared cache - fresh mautic install

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 25, 2020, 6:05pm UTC](https://forum.mautic.org/t/failed-opening-required-var-www-vhosts-mautic-app-vendor-autoload-php-include-path-opt-plesk-php-7-2-share-pear-in-var-www-vhosts-mautic-app-autoload-php-on-line-15-n/13073/2 "2020-02-25T18:05:37Z")

</div>

Hi there,

It isn’t clear when this error occurs - is it when you try to open Mautic?

Did you update at command line or via the UI to 2.16, or was it a fresh installation?

Was the update/install successful or were there any problems?

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [February 25, 2020, 7:12pm UTC](https://forum.mautic.org/t/failed-opening-required-var-www-vhosts-mautic-app-vendor-autoload-php-include-path-opt-plesk-php-7-2-share-pear-in-var-www-vhosts-mautic-app-autoload-php-on-line-15-n/13073/3 "2020-02-25T19:12:50Z")

</div>

This error occurs when attempting to access the mautic dashboard.  
In an attempt to correct this error I deleted original mautic files, unzipped a fresh download of 2.16 and copied over my local.php to app/config  
Same error when I attempt to run any ssh commands:  
PHP Warning: require(/var/www/vhosts/Mautic-Install/app/…/vendor/autoload.php): failed to open stream: No such file or directory in /var/www/vhosts/Mautic-Install/app/autoload.php on line 15

and:

PHP Fatal error: require(): Failed opening required ‘/var/www/vhosts/Mautic-Install/app/…/vendor/autoload.php’ (include\_path=’.:/usr/share/pear:/usr/share/php’) in /var/www/vhosts/Mautic-Install/app/autoload.php on line 15

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [February 26, 2020, 6:46pm UTC](https://forum.mautic.org/t/failed-opening-required-var-www-vhosts-mautic-app-vendor-autoload-php-include-path-opt-plesk-php-7-2-share-pear-in-var-www-vhosts-mautic-app-autoload-php-on-line-15-n/13073/4 "2020-02-26T18:46:02Z")

</div>

Fixed this issue with following steps:  
Save copy of local.php from app/config directory  
Delete all mautic files - remember to save media folder and any custom themes  
upload and unzip version 2.16 downloaded from mautic in directory (not the mautic-staging zip on github)  
copy local.php to config directory
