# Fixing permissions not working

**URL:** <https://forum.mautic.org/t/fixing-permissions-not-working/14185>\
**Category:** Product Support\
**Created:** [May 4, 2020, 10:36pm UTC](https://forum.mautic.org/t/fixing-permissions-not-working/14185 "2020-05-04T22:36:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![julien66](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/julien66/32/1033_2.png) [@julien66](https://forum.mautic.org/u/julien66)\
**Post date:** [May 4, 2020, 10:36pm UTC](https://forum.mautic.org/t/fixing-permissions-not-working/14185/1 "2020-05-04T22:36:47Z")

</div>

**Your software**  
My Mautic version is: 2.16.0  
My PHP version is: 7.1.33

**Your problem**  
My problem is:  
My Mautic instance was working well, but it suddenly stopped working. I don’t think I did anything special other than playing inside the GUI.

So I tried to fix the permissions and ownership using the apache user, and deleting app/cache. When I try recreating the cache manually or accessing the instance I keep receiving the error mentioned below.

I’m really puzzled because even php app/console generates the error. So I can’t even warm up the cache as nothing seems to work. Also I searched extensively on the forum and it seems fixing the permissions and ownerships works for everybody. I don’t get it why it’s not working in my case.

If anyone had an idea, I would appreciate it.  
Thanks!

These errors are showing in the log:  
Warning: require(/var/www/html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticPluginBundleEntityPlugin.php): failed to open stream: No such file or directory in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209  
Fatal error: require(): Failed opening required ‘/var/www/html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticPluginBundleEntityPlugin.php’ (include\_path=’/var/www/html/vendor/phpunit/phpunit-selenium:.:/usr/local/lib/php’) in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209

Steps I have tried to fix the problem:  
I did fix all permissions and ownership as mentioned in [https://docs.mautic.org/en/troubleshooting/file-ownership-and-permissions](https://docs.mautic.org/en/troubleshooting/file-ownership-and-permissions) and deleted the cache.

---

<div class="post-metadata">

**Author:** ![julien66](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/julien66/32/1033_2.png) [@julien66](https://forum.mautic.org/u/julien66)\
**Post date:** [May 5, 2020, 8:25pm UTC](https://forum.mautic.org/t/fixing-permissions-not-working/14185/2 "2020-05-05T20:25:45Z")

</div>

Would anybody have an idea? In the documentation page related to this issue, it says the issue is very likely related to permissions. That means other cause might trigger the issue (unlikely though). Would anybody face another root cause?

I have another Mautic instance sharing the same configuration and it works well.  
Thanks!
