# Focus Item & Landing Page Bug

**URL:** <https://forum.mautic.org/t/focus-item-landing-page-bug/16436>\
**Category:** Product Support\
**Created:** [October 5, 2020, 8:52am UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436 "2020-10-05T08:52:15Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![mikew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikew/32/5156_2.png) [@mikew](https://forum.mautic.org/u/mikew)\
**Post date:** [October 5, 2020, 8:52am UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/1 "2020-10-05T08:52:15Z")

</div>

**Your software**  
My Mautic version is: 3.1 & 2.16.3  
My PHP version is: 7.2

**Your problem**  
My problem is:  
Trying to add focus items to a Mautic landing page

I can only add {focus=1} in a landing page, any other form does not show.

![image](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/8/89d076854cd10ce1a06b8795f2e4a9ba9f95456d.png)

For fucus item =1 everything works fine. Now if I go and change the 1 to a 3, first it does not show up in the dropdown, so now my code looks like {focus=3}.

I go and test the page and it does not work.

These errors are showing in the log:

This is the error that I see in the console:  
Failed to load resource: the server responded with a status of 404 (Not Found) [https://mydomain.com/focus/3.js](https://mydomain.com/focus/3.js)

In the System Logs I am seeing this:  
[2020-10-05 08:40:25] mautic.NOTICE: PHP Notice - Undefined index: safari\_web\_id - in file /var/www/mydomain/app/bundles/NotificationBundle/Helper/NotificationHelper.php - at line 117 {“integration”:"[object] (Mautic\NotificationBundle\Integration\OneSignalIntegration: {})",“settings”:"[object] (Mautic\PluginBundle\Entity\Integration: Mautic\PluginBundle\Entity\Integration with ID #1)",“keys”:,“supported”:[“mobile”,“landing\_page\_enabled”,“welcome\_notification\_enabled”,“tracking\_page\_enabled”],“featureSettings”:{“subdomain\_name”:null,“platforms”:},“appId”:null}

Steps I have tried to fix the problem:

I have tried adding the code to the bottom of the page without using the personalised focus item token.

---

<div class="post-metadata">

**Author:** ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)\
**Post date:** [October 5, 2020, 9:49am UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/2 "2020-10-05T09:49:17Z")

</div>

Focus item turned on, right?

---

<div class="post-metadata">

**Author:** ![mikew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikew/32/5156_2.png) [@mikew](https://forum.mautic.org/u/mikew)\
**Post date:** [October 5, 2020, 10:06am UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/3 "2020-10-05T10:06:28Z")

</div>

Yip 🙂 it is. Double checked everything.

---

<div class="post-metadata">

**Author:** ![mikew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikew/32/5156_2.png) [@mikew](https://forum.mautic.org/u/mikew)\
**Post date:** [October 7, 2020, 6:02pm UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/4 "2020-10-07T18:02:59Z")

</div>

Any one have a clue about this or is seeing different behaviour ?

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [October 7, 2020, 6:15pm UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/5 "2020-10-07T18:15:11Z")

</div>

Can you clone the page you are working on and then remove the [form=10} to eliminate it from the equation and save with just {focus=3} ?

Can you verify the mautic tracking script in on the published landing page? I believe its required in addition to the code for the focus item.

are you using Onesignal? Can you disable the plugin for testing purposes?

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [October 7, 2020, 6:40pm UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/6 "2020-10-07T18:40:04Z")

</div>

@mikew I made a quick landing page and focus item to recreate the issue. This is what I got.

When I was not logged in the page 500 errored me  
When I was logged in the errors occurred

 ![Screenshot (33)](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/4/47f4a0537b7473cccee7e3e4973dfc50359b4444.png)

The link explains this type of error but not much else.

> **[X-Content-Type-Options](https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/X-Content-Type-Options?utm_source=mozilla&utm_medium=firefox-console-errors&utm_campaign=default)**
>
> The X-Content-Type-Options response HTTP header is a marker used by the server to indicate that the MIME types advertised in the Content-Type headers should not be changed and be followed. This is a way to opt out of MIME type sniffing, or, in other...

  
Its not just you

---

<div class="post-metadata">

**Author:** ![mikew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikew/32/5156_2.png) [@mikew](https://forum.mautic.org/u/mikew)\
**Post date:** [October 7, 2020, 6:41pm UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/7 "2020-10-07T18:41:34Z")

</div>

@EJL. Amazing !!! Thanks for testing. Lets see if there is an explanation to why this is happening. maybe someone else will shed some light.

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [October 7, 2020, 6:51pm UTC](https://forum.mautic.org/t/focus-item-landing-page-bug/16436/8 "2020-10-07T18:51:28Z")

</div>

I added more detail to my response. The error has to do with incorrect headers and MIME types. I dunno if Mautic is generating them incorrectly in the landing page builder output, if something crazy is in the .htaccess generated by mautic when you install is doing odd re-writes or what. It will take some time to chase down.

I running Mautic 3.1.1 Btw
