# Fresh installation problem with DB setup

**URL:** <https://forum.mautic.org/t/fresh-installation-problem-with-db-setup/6237>\
**Category:** General Discussion\
**Created:** [October 15, 2016, 4:02pm UTC](https://forum.mautic.org/t/fresh-installation-problem-with-db-setup/6237 "2016-10-15T16:02:49Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![georges](https://avatars.discourse-cdn.com/v4/letter/g/bcef8e/32.png) [@georges](https://forum.mautic.org/u/georges)\
**Post date:** [October 15, 2016, 4:02pm UTC](https://forum.mautic.org/t/fresh-installation-problem-with-db-setup/6237/1 "2016-10-15T16:02:49Z")

</div>

Hi,  
  
  
  
I’ve freshly downloaded the Mautic zip, and put it into my IIS Document root on Windows. When I browse to [http://localhost/index.php](http://localhost/index.php), Mautic redirects to [http://localhost/index.php/index.php/installer](http://localhost/index.php/index.php/installer) and generates a HTTP 500 error.  
  
When I look into the logs, it happens because it’s trying to connect to a MySQL Server on localhost with no username and password even before displaying the database configuration screen during the installation process.  
  
  
  
Any idea on how to work around this? I manually hardcoded the right credentials into MauticvendordoctrinedballibDoctrineDBALConnection.php, but then the schema was missing.  
  
Running php app/console doctrine:schema:update --force from the console leads to the same problem.  
  
  
  
Thanks,  
  
Georges  
  
  
  
[2016-10-15 17:12:35] mautic.CRITICAL: Uncaught PHP Exception DoctrineDBALExceptionConnectionException: "An exception occured in driver: SQLSTATE[HY000] [2002] No connection could be made because the target machine actively refused it. "

---

<div class="post-metadata">

**Author:** ![georges](https://avatars.discourse-cdn.com/v4/letter/g/bcef8e/32.png) [@georges](https://forum.mautic.org/u/georges)\
**Post date:** [October 15, 2016, 4:02pm UTC](https://forum.mautic.org/t/fresh-installation-problem-with-db-setup/6237/2 "2016-10-15T16:02:49Z")

</div>

Hi,

I’ve freshly downloaded the Mautic zip, and put it into my IIS Document root on Windows. When I browse to [http://localhost/index.php](http://localhost/index.php), Mautic redirects to [http://localhost/index.php/index.php/installer](http://localhost/index.php/index.php/installer) and generates a HTTP 500 error.  
When I look into the logs, it happens because it’s trying to connect to a MySQL Server on localhost with no username and password even before displaying the database configuration screen during the installation process.

Any idea on how to work around this? I manually hardcoded the right credentials into MauticvendordoctrinedballibDoctrineDBALConnection.php, but then the schema was missing.  
Running php app/console doctrine:schema:update --force from the console leads to the same problem.

Thanks,  
Georges

[2016-10-15 17:12:35] mautic.CRITICAL: Uncaught PHP Exception DoctrineDBALExceptionConnectionException: "An exception occured in driver: SQLSTATE[HY000] [2002] No connection could be made because the target machine actively refused it. "

---

<div class="post-metadata">

**Author:** ![georges](https://avatars.discourse-cdn.com/v4/letter/g/bcef8e/32.png) [@georges](https://forum.mautic.org/u/georges)\
**Post date:** [October 15, 2016, 6:42pm UTC](https://forum.mautic.org/t/fresh-installation-problem-with-db-setup/6237/3 "2016-10-15T18:42:40Z")

</div>

Ok, the fix is very easy, just remove the extra index.php from the path that got added for an unknown reason.  
[http://localhost/index.php/installer](http://localhost/index.php/installer) launches the installer properly.
