# GoDaddy Email setup with Office365

**URL:** <https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414>\
**Category:** Product Support\
**Created:** [September 21, 2016, 5:06pm UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414 "2016-09-21T17:06:30Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![lewisone](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lewisone/32/91_2.png) [@lewisone](https://forum.mautic.org/u/lewisone)\
**Post date:** [September 21, 2016, 5:06pm UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/1 "2016-09-21T17:06:30Z")

</div>

**After months and months of tech support** and these forums i finally got this to work, hope it helps others that have been posting about it as well.  
  
  
  
The issue was this: I have Godaddy hosting with Office365 mail offered by GD (So i can max out my outgoing mail to 10k per day)  
  
  
  
Every time i put in the 365 settings it would give me a connection error #111 refused from server message. Most felt it was a blocked port 587 and happened with port 25 as well.  
  
  
  
Long story short, here are the settings you will need to have:  
  
  
  
Service to send mail through: Other SMTP Server  
  
SMTP host: relay-hosting.secureserver.net  
  
SMTP port: 25  
  
SMTP encryption type: None  
  
SMTP authentication mode: None  
  
  
  
••••••••••••••••••••••••••••••••  
  
The next great hurdle was cron jobs. Most of the jobs to put in were totally wrong as far as routing and structure, It seems that GD had some quirks that I finally found that stopped giving me errors. So here is what I found that finally worked:  
  
  
  
/usr/local/bin/php -q /home/{username}/public\_html/{websitefolder}/app/console mautic:segments:update  
  
  
  
the -q is for quiet mode which will not send any notifications, however I left that out for testing and will probably not put it back so i can watch if something bad happens.  
  
  
  
••••••••••••••••••••••••••••••••  
  
  
  
Finally, when I tested my emails after the first fix in the Mautic settings/mail I received it. However when i did it under contacts/dropdown send email it did not.  
  
  
  
After a numerous calls to tech support I finally found someone who changed my cpanel email to send through my main email address and Abracadabra it all of a sudden started working.  
  
  
  
••••••••••••••••••••••••••••••••  
  
  
  
Now I am finally up and going and am super happy and hope this little bit of suffering on my part is helpful to others.

---

<div class="post-metadata">

**Author:** ![lewisone](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lewisone/32/91_2.png) [@lewisone](https://forum.mautic.org/u/lewisone)\
**Post date:** [September 21, 2016, 5:06pm UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/2 "2016-09-21T17:06:30Z")

</div>

After months and months of tech support and these forums i finally got this to work, hope it helps others that have been posting about it as well.

The issue was this: I have Godaddy hosting with Office365 mail offered by GD (So i can max out my outgoing mail to 10k per day)

Every time i put in the 365 settings it would give me a connection error #111 refused from server message. Most felt it was a blocked port 587 and happened with port 25 as well.

Long story short, here are the settings you will need to have:

Service to send mail through: Other SMTP Server  
SMTP host: [relay-hosting.secureserver.net](http://relay-hosting.secureserver.net)  
SMTP port: 25  
SMTP encryption type: None  
SMTP authentication mode: None

••••••••••••••••••••••••••••••••  
The next great hurdle was cron jobs. Most of the jobs to put in were totally wrong as far as routing and structure, It seems that GD had some quirks that I finally found that stopped giving me errors. So here is what I found that finally worked:

/usr/local/bin/php -q /home/{username}/public\_html/{websitefolder}/app/console mautic:segments:update

the -q is for quiet mode which will not send any notifications, however I left that out for testing and will probably not put it back so i can watch if something bad happens.

••••••••••••••••••••••••••••••••

Finally, when I tested my emails after the first fix in the Mautic settings/mail I received it. However when i did it under contacts/dropdown send email it did not.

After a numerous calls to tech support I finally found someone who changed my cpanel email to send through my main email address and Abracadabra it all of a sudden started working.

••••••••••••••••••••••••••••••••

Now I am finally up and going and am super happy and hope this little bit of suffering on my part is helpful to others.

---

<div class="post-metadata">

**Author:** ![lewisone](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lewisone/32/91_2.png) [@lewisone](https://forum.mautic.org/u/lewisone)\
**Post date:** [September 25, 2016, 1:21am UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/3 "2016-09-25T01:21:16Z")

</div>

Updated above…

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [September 26, 2016, 1:38pm UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/4 "2016-09-26T13:38:26Z")

</div>

cool

---

<div class="post-metadata">

**Author:** ![Augentia](https://avatars.discourse-cdn.com/v4/letter/a/ea5d25/32.png) [@Augentia](https://forum.mautic.org/u/Augentia)\
**Post date:** [October 26, 2016, 2:28pm UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/5 "2016-10-26T14:28:42Z")

</div>

@lewisone i tried the settings you gave, and got this error (below)…can you help ?

Connection could not be established with host [http://relay-hosting.secureserver.net/](http://relay-hosting.secureserver.net/) [Unable to find the socket transport “http” - did you forget to enable it when you configured PHP? #70426344] Log data: ++ Starting Swift\_SmtpTransport !! Connection could not be established with host [http://relay-hosting.secureserver.net/](http://relay-hosting.secureserver.net/) [Unable to find the socket transport “http” - did you forget to enable it when you configured PHP? #70426344] (code: 0)  
++ Starting Swift\_SmtpTransport !! Connection could not be established with host [http://relay-hosting.secureserver.net/](http://relay-hosting.secureserver.net/) [Unable to find the socket transport “http” - did you forget to enable it when you configured PHP? #70426344] (code: 0)

---

<div class="post-metadata">

**Author:** ![lewisone](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lewisone/32/91_2.png) [@lewisone](https://forum.mautic.org/u/lewisone)\
**Post date:** [January 24, 2017, 5:37am UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/6 "2017-01-24T05:37:11Z")

</div>

Sorry Augentia, it’s been months and didn’t see your response. I honestly don’t know but If I were to guess I would say that you need to update your PHP version?? If I remember correct when I was setting it up that is what this meant.

Also, make sure the email be handled is Queue for this.

Also, lol… Check to make sure that your cron jobs are set up. I seem to have found a bunch that I had to dig for to get this to work, here are mine, the routing was tricky and those dohicky numbers at teh end are incredibly important to get them to run:

/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:segments:update \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:campaigns:trigger \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:emails:send \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:campaigns:rebuild \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:social:monitoring \>/dev/null 2\>&1

/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:webhooks:process \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:iplookup:download \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:maintenance:cleanup --days-old=365 --dry-run \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:broadcasts:send [–id=ID] [–channel=CHANNEL] \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:campaigns:update \>/dev/null 2\>&1

/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:emails:send \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:leadlists:update \>/dev/null 2\>&1  
/usr/local/bin/php /home/mygodaddyname/public\_html/domain/app/console mautic:email:process \>/dev/null 2\>&1

---

<div class="post-metadata">

**Author:** ![mauticuser1](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mauticuser1/32/422_2.png) [@mauticuser1](https://forum.mautic.org/u/mauticuser1)\
**Post date:** [November 20, 2019, 9:37pm UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/7 "2019-11-20T21:37:08Z")

</div>

I know this is an old post, but I’m hoping someone will read it.

So i use GD for domain name only and email with Office365 offered by GD. My website and Mautic installation are on my own computer running windows server 2012. Among other thing, i am having trouble setting up my Mail Send Settings. I donot get a good “test connection” or “send test email”.

I configured the email settings - Host - [smtp.office365.com](http://smtp.office365.com), Port - 587, Encry - TLS and Auth - Login, when I click on Test connection, it gives the following error -  
Connection could not be established with host [smtp.office365.com](http://smtp.office365.com/) [An attempt was made to access a socket in a way forbidden by its access permissions. #10013] Log data: ++ Starting Swift\_SmtpTransport !! Connection could not be established with host [smtp.office365.com](http://smtp.office365.com/) [An attempt was made to access a socket in a way forbidden by its access permissions. #10013] (code: 0)

When i use your setting i get this error -  
Connection could not be established with host [relay-hosting.secureserver.net](http://relay-hosting.secureserver.net) [A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. #10060] Log data: ++ Starting Swift\_SmtpTransport !! Connection could not be established with host [relay-hosting.secureserver.net](http://relay-hosting.secureserver.net) [A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. #10060] (code: 0)

Any Ideas??

---

<div class="post-metadata">

**Author:** ![Yosu\_Cadilla](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/yosu_cadilla/32/6206_2.png) [@Yosu\_Cadilla](https://forum.mautic.org/u/Yosu_Cadilla)\
**Post date:** [November 21, 2019, 1:57am UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/8 "2019-11-21T01:57:15Z")

</div>

@mauticuser1 Please try to post issues/support requests only once, all new posts are reviewed by someone sooner or later.  
If possible, try not to resuscitate old posts, the main reason being they are probably outdated already and it’s best to start a new post.

I am going to answer you in your new post:

> [@Mail Send Setting using office365, website hosted on local windows server](https://forum.mautic.org/t/mail-send-setting-using-office365-website-hosted-on-local-windows-server/11743):
>
> Your software My Mautic version is: Mautic 2.12.3 My PHP version is: PHP Version 7.2.7 Windows Server 2012 R2 Standard Edition My problem is: Can not get a good Test Connection, Can not Send Test Email I configured the email settings - Host - [smtp.office365.com](http://smtp.office365.com), Port - 587, Encry - TLS and Auth - Login, when I click on Test connection, it gives the following error - Connection could not be established with host [smtp.office365.com](http://smtp.office365.com) [An attempt was made to access a socket in a way forbidden …

---

<div class="post-metadata">

**Author:** ![Yosu\_Cadilla](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/yosu_cadilla/32/6206_2.png) [@Yosu\_Cadilla](https://forum.mautic.org/u/Yosu_Cadilla)\
**Post date:** [November 21, 2019, 3:15am UTC](https://forum.mautic.org/t/godaddy-email-setup-with-office365/5414/9 "2019-11-21T03:15:22Z")

</div>

> [@Mail Send Setting using office365, website hosted on local windows server](https://forum.mautic.org/t/mail-send-setting-using-office365-website-hosted-on-local-windows-server/11743/8):
>
> I understand you want to keep costs low, however hosting Mautic on your own computer is a no go, a cloud VPS will cost you as low as $10/month or even $5/month. Another no-go is to use your residential or company email service for sending emails. You need to use an email marketing service. There are a few mid-quality marketing email providers that offer you lots of free emails per month. If you are not sending that many emails, Sendgrid is top quality provider and will give you 2K emails for f…
