# Google Cloud cannot access sendgrid

**URL:** <https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623>\
**Category:** Product Support\
**Created:** [October 4, 2017, 5:37am UTC](https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623 "2017-10-04T05:37:58Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![t3rrylin](https://avatars.discourse-cdn.com/v4/letter/t/7feea3/32.png) [@t3rrylin](https://forum.mautic.org/u/t3rrylin)\
**Post date:** [October 4, 2017, 5:37am UTC](https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623/1 "2017-10-04T05:37:58Z")

</div>

I deploied Mautic on google cloud platform, and I wish to use sendgrid as email sender (which I need 12000 mail).  
  
  
  
However I tried the sendgrid option and also the SMTP option but both return me the same error:  
  
  
  
Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110]  
  
++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110]  
  
  
  
  
  
I tried other email option as well,  
  
PHP mail: fail  
  
Gmail: Success \<-- and this is the only one I success sending.  
  
  
  
I tried with another smtp server that I used for personal use, but I get the same error. I already opened tcp:587 and tcp:465 port in the google cloud instant firewall rules.  
  
  
  
Anyone can help? Many thanks!

---

<div class="post-metadata">

**Author:** ![t3rrylin](https://avatars.discourse-cdn.com/v4/letter/t/7feea3/32.png) [@t3rrylin](https://forum.mautic.org/u/t3rrylin)\
**Post date:** [October 4, 2017, 5:37am UTC](https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623/2 "2017-10-04T05:37:58Z")

</div>

I deploied Mautic on google cloud platform, and I wish to use sendgrid as email sender (which I need 12000 mail).

However I tried the sendgrid option and also the SMTP option but both return me the same error:

Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110]  
++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110]

I tried other email option as well,  
PHP mail: fail  
Gmail: Success \<-- and this is the only one I success sending.

I tried with another smtp server that I used for personal use, but I get the same error. I already opened tcp:587 and tcp:465 port in the google cloud instant firewall rules.

Anyone can help? Many thanks!

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [October 4, 2017, 12:43pm UTC](https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623/3 "2017-10-04T12:43:45Z")

</div>

Re-check if you ports are really open also try port 25 and 2525

---

<div class="post-metadata">

**Author:** ![t3rrylin](https://avatars.discourse-cdn.com/v4/letter/t/7feea3/32.png) [@t3rrylin](https://forum.mautic.org/u/t3rrylin)\
**Post date:** [October 5, 2017, 4:54am UTC](https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623/4 "2017-10-05T04:54:18Z")

</div>

IP range: 0.0.0.0/0

tcp:25;tcp:2525

is that all I should set?  
Should I set it Ingress or Egress?

Thanks!

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [October 5, 2017, 12:30pm UTC](https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623/5 "2017-10-05T12:30:45Z")

</div>

email me i have a script that can help us identify the problem `jninhilario@gmail.com`

---

<div class="post-metadata">

**Author:** ![Yosu\_Cadilla](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/yosu_cadilla/32/6206_2.png) [@Yosu\_Cadilla](https://forum.mautic.org/u/Yosu_Cadilla)\
**Post date:** [October 6, 2017, 2:02pm UTC](https://forum.mautic.org/t/google-cloud-cannot-access-sendgrid/9623/6 "2017-10-06T14:02:27Z")

</div>

As I see in sendgrid docs, you can use:  
Ports  
Use port 25, 2525, or 587 for unencrypted / TLS connections  
Use port 465 for SSL connections  
We recommend using port 587 to avoid potential rate limiting. 587 is also the least likely to be blocked by default corporate and residential ISP network settings.

[https://sendgrid.com/docs/Classroom/Basics/Email\_Infrastructure/recommended\_smtp\_settings.html](https://sendgrid.com/docs/Classroom/Basics/Email_Infrastructure/recommended_smtp_settings.html)
