# Got Error 500 only when not connected as admin

**URL:** <https://forum.mautic.org/t/got-error-500-only-when-not-connected-as-admin/10423>\
**Category:** Product Support\
**Created:** [April 12, 2018, 5:29pm UTC](https://forum.mautic.org/t/got-error-500-only-when-not-connected-as-admin/10423 "2018-04-12T17:29:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![ekomak](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ekomak/32/312_2.png) [@ekomak](https://forum.mautic.org/u/ekomak)\
**Post date:** [April 12, 2018, 5:29pm UTC](https://forum.mautic.org/t/got-error-500-only-when-not-connected-as-admin/10423/1 "2018-04-12T17:29:45Z")

</div>

Hello Mauticians

I have a issue with my Mautic installation. When i am connected as admin everything work well. I cant see Landing page and webform even focus object.  
But, when am not connected, all the landing page send an error 500.  
link in focus object send error 500 too. Even if link embed are external link.

Did somebody had the same issue ?  
Did you found a solution to that ?

Thank for your help

---

<div class="post-metadata">

**Author:** ![tiagowta3-com-br](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tiagowta3-com-br/32/337_2.png) [@tiagowta3-com-br](https://forum.mautic.org/u/tiagowta3-com-br)\
**Post date:** [June 7, 2018, 7:01pm UTC](https://forum.mautic.org/t/got-error-500-only-when-not-connected-as-admin/10423/2 "2018-06-07T19:01:24Z")

</div>

yes I have same problem, when i am not connected as admin, broken (error 500). Look: [http://conteudos.neooftalmo.com.br/catarata/obrigado-guia-completo-sobre-cirurgia-de-catarata](http://conteudos.neooftalmo.com.br/catarata/obrigado-guia-completo-sobre-cirurgia-de-catarata)

Uh oh! I think I broke it. If I do it again, please report me to the system administrator!  
500 Internal Server Erro

---

<div class="post-metadata">

**Author:** ![fianbiasa](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/fianbiasa/32/1249_2.png) [@fianbiasa](https://forum.mautic.org/u/fianbiasa)\
**Post date:** [April 20, 2020, 9:24pm UTC](https://forum.mautic.org/t/got-error-500-only-when-not-connected-as-admin/10423/3 "2020-04-20T21:24:55Z")

</div>

Yes, i have some problem too…

check this video for description : [https://youtu.be/bo7SLDJeJl4](https://youtu.be/bo7SLDJeJl4)

@silavapi please help

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [April 21, 2020, 10:47am UTC](https://forum.mautic.org/t/got-error-500-only-when-not-connected-as-admin/10423/4 "2020-04-21T10:47:17Z")

</div>

Hi @fianbiasa and others. It’s generally not a great idea to bump a 2+ years old thread with a new problem, but since we’re already here, let’s see how folk can help you troubleshoot.

You won’t be very successful in getting people to help unless you share:

- Mautic version
- PHP version
- Full error logs

If you share those, folk might be able to help you troubleshoot.

Based on your video, I would also recommend checking if your landing page is set to published or not - that might explain why if you’re not logged in you can’t access it. But the error messages, mautic version etc are the most important part.

---

<div class="post-metadata">

**Author:** ![fianbiasa](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/fianbiasa/32/1249_2.png) [@fianbiasa](https://forum.mautic.org/u/fianbiasa)\
**Post date:** [April 21, 2020, 2:23pm UTC](https://forum.mautic.org/t/got-error-500-only-when-not-connected-as-admin/10423/5 "2020-04-21T14:23:43Z")

</div>

Hi @rcheesley im sorry, im just worried double post. 😢

- Mautic Version : 2.16.0-dev (old)
- PHP version : 7.2 (old)
- no error logs

This **problem happend after Update to new version**

- Mautic Version : 2.16.2
- PHP Version : 7.3.16
- Error Logs is :

> [2020-04-21 14:21:00] mautic.CRITICAL: Uncaught PHP Exception ErrorException: “stream\_socket\_client(): unable to connect to tcp://localhost:5672 (Connection refused)” at /home/dewaeka/webapps/mautic/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Wire/IO/StreamIO.php line 141 {“exception”:“[object] (ErrorException(code: 0): stream\_socket\_client(): unable to connect to tcp://localhost:5672 (Connection refused) at /home/dewaeka/webapps/mautic/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Wire/IO/StreamIO.php:141)”}
