# I have some issues to update from 4.1.0

**URL:** <https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477>\
**Category:** Mautic 5 Install/Upgrade Support\
**Created:** [January 12, 2024, 5:49pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477 "2024-01-12T17:49:33Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![funkman733](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/funkman733/32/9158_2.png) [@funkman733](https://forum.mautic.org/u/funkman733)\
**Post date:** [January 12, 2024, 5:49pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477/1 "2024-01-12T17:49:33Z")

</div>

**Your software**  
My Mautic version is: 4.1.0  
My PHP version is: 7.4.33  
My Database type and version is: 10.6.16-MariaDB-cll-lve-log

**Your problem**  
My problem is: that I have some issues updating from the 4.1.0 version to other new versions

These errors are showing in the log: not

Steps I have tried to fix the problem: I tried to update using Mautic Notifications to update to 4.4.10 version and also using the command line. After the process, I have the “403 forbidden” message error, and I need to restore the backup of the Mautic 4.1.0 folder.  
The site is [https://marketing.inonda.tv](https://marketing.inonda.tv)

Can someone help me to update?

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [January 12, 2024, 6:04pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477/2 "2024-01-12T18:04:00Z")

</div>

Hi there,

Please do not use the notifications bell to update follow the docs here:

[https://docs.mautic.org/en/5.x/getting\_started/how\_to\_update\_mautic.html#updating-at-the-command-line-non-composer-based-installations](https://docs.mautic.org/en/5.x/getting_started/how_to_update_mautic.html#updating-at-the-command-line-non-composer-based-installations)

Please ensure you’re not causing issues with your file and folder ownerships by updating with a different user to the one that Mautic / Apache uses - if so, you might need to check these docs:

[https://docs.mautic.org/en/5.x/troubleshooting/file\_ownership\_permissions.html](https://docs.mautic.org/en/5.x/troubleshooting/file_ownership_permissions.html)

---

<div class="post-metadata">

**Author:** ![funkman733](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/funkman733/32/9158_2.png) [@funkman733](https://forum.mautic.org/u/funkman733)\
**Post date:** [January 12, 2024, 6:34pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477/3 "2024-01-12T18:34:47Z")

</div>

Thank you but I have also tried to update using the command line, but I have also the 403 issue…

I have tried to follow the file ownership permission guide, but at the command line “groups apache\_user - where apache\_user” I have this message “groups: apache\_user: no such user”

There are other processes that can I follow?  
From Github I have downloaded the zip of the 5.0.1 version folder update

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [January 12, 2024, 6:40pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477/4 "2024-01-12T18:40:31Z")

</div>

Hi there,

> [@funkman733](#):
>
> “groups: apache\_user: no such user”

The important part of the documentation there would be:

> where apache\_user is **the user you identified from the first step above**

That step being:

> ps aux | grep apache2

I’d bet it’s not called apache\_user but something like www-data or similar.

---

<div class="post-metadata">

**Author:** ![funkman733](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/funkman733/32/9158_2.png) [@funkman733](https://forum.mautic.org/u/funkman733)\
**Post date:** [January 12, 2024, 6:44pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477/5 "2024-01-12T18:44:52Z")

</div>

ok, at

> ps aux | grep apache2

I have

> XXXgljgl 1438104 0.0 0.0 112812 980 pts/0 S+ 19:28 0:00 grep --color=auto apache2

---

<div class="post-metadata">

**Author:** ![funkman733](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/funkman733/32/9158_2.png) [@funkman733](https://forum.mautic.org/u/funkman733)\
**Post date:** [January 17, 2024, 3:15pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477/6 "2024-01-17T15:15:06Z")

</div>

Can someone help me update Mautic to the latest version from 4.1.0 version?

---

<div class="post-metadata">

**Author:** ![funkman733](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/funkman733/32/9158_2.png) [@funkman733](https://forum.mautic.org/u/funkman733)\
**Post date:** [February 21, 2024, 5:46pm UTC](https://forum.mautic.org/t/i-have-some-issues-to-update-from-4-1-0/30477/7 "2024-02-21T17:46:31Z")

</div>

Hi,  
I have tried the following solution to update from 4.1.0 to 4.4.11, after the .htaccess edit I didn’t the 403 forbidden error message, but I have another error message that I cannot display the login form…

> <https://github.com/mautic/mautic/issues/10913?fbclid=IwAR0pwv01xLREn5grcDZXnpGaBDQIi_Z860gR0MS2lC7owo8_naX1oHDvzmU#issuecomment-1084513105>
>
> \### Mautic Version
> 
> 4.2.x series
> 
> \### PHP version
> 
> 7.4.27
> 
> \### What brow…sers are you seeing the problem on?
> 
> Firefox, Chrome
> 
> \### What happened?
> 
> After performing an upgrade, the site reports an error 403, forbidden.
> 
> We upgrade via command line and clear cache and clean permissions as part of the process.
> 
> This maybe server specific, but this line in the HTACCESS
> 
> https://github.com/mautic/mautic/blob/4.2.0/.htaccess
> 
> \`\`\`
> \# Apache 2.4+
> \<IfModule authz\_core\_module\>
> # Deny access via HTTP requests to all PHP files.
> \<FilesMatch "\\.php$"\>
> Require all denied
> \</FilesMatch\>
> \`\`\`
> 
> Causes the issue, by commenting out
> 
> \`\`\`
> \<FilesMatch "\\.php$"\>
> Require all denied
> \</FilesMatch\>
> \`\`\`
> 
> The site loads again.
> 
> Prior to this verison 4.1.2 Worked with this in the htaccess file.
> 
> \### How can we reproduce this issue?
> 
> Server
> Ubunto 18.04.4 LTS
> Server API | FPM/FastCGI
> MariaDB
> 1:10.2.43+maria~bionic
> Apache
> 2.4.52-1+ubuntu18.04+1
> NGiNX
> 1.19.9-1+ubuntu18.04+1
> 
> Not sure if this is important, but we have mautic in a subfolder off the domain
> eg: domain.com/mautic/
> 
> \### Relevant log output
> 
> \`\`\`shell
> n/a
> \`\`\`
> 
> 
> \### Code of Conduct
> 
> \- \[X\] I confirm that I have read and agree to follow this project's Code of Conduct
