# Installation issue

**URL:** <https://forum.mautic.org/t/installation-issue/3382>\
**Category:** Product Support\
**Created:** [February 2, 2016, 5:35pm UTC](https://forum.mautic.org/t/installation-issue/3382 "2016-02-02T17:35:35Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Paolo](https://avatars.discourse-cdn.com/v4/letter/p/6f9a4e/32.png) [@Paolo](https://forum.mautic.org/u/Paolo)\
**Post date:** [February 2, 2016, 5:35pm UTC](https://forum.mautic.org/t/installation-issue/3382/1 "2016-02-02T17:35:35Z")

</div>

I’ve tried googling around but apparently I am the only one with this issue.  
  
  
  
I installed mautic according to the manual and all seems fine, the web side of it works as it should out of the tin. Not so much the php cron jobs. To investigate I sshed into my host (on [justhost.com](http://justhost.com)) to try to debug the issue.  
  
  
  
I am running php 5.4 and if I run php console from the app folder it returns an error ![:(]( ":(")  
  
My error\_log says:  
  
  
  
PHP Parse error: syntax error, unexpected T\_STRING, expecting T\_CONSTANT\_ENCAPSED\_STRING or ‘(’ in marketing/app/console on line 18  
  
which should be: use SymfonyBundleFrameworkBundleConsoleApplication;  
  
  
  
I believe I installed everything and in the manual there’s no reference to Symfony separate installation. Am I missing something?  
  
  
  
Thanks

---

<div class="post-metadata">

**Author:** ![Paolo](https://avatars.discourse-cdn.com/v4/letter/p/6f9a4e/32.png) [@Paolo](https://forum.mautic.org/u/Paolo)\
**Post date:** [February 2, 2016, 5:35pm UTC](https://forum.mautic.org/t/installation-issue/3382/2 "2016-02-02T17:35:35Z")

</div>

I’ve tried googling around but apparently I am the only one with this issue.

I installed mautic according to the manual and all seems fine, the web side of it works as it should out of the tin. Not so much the php cron jobs. To investigate I sshed into my host (on [justhost.com](http://justhost.com)) to try to debug the issue.

I am running php 5.4 and if I run php console from the app folder it returns an error ☹  
My error\_log says:

PHP Parse error: syntax error, unexpected T\_STRING, expecting T\_CONSTANT\_ENCAPSED\_STRING or ‘(’ in marketing/app/console on line 18  
which should be: use SymfonyBundleFrameworkBundleConsoleApplication;

I believe I installed everything and in the manual there’s no reference to Symfony separate installation. Am I missing something?

Thanks

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 3, 2016, 11:57am UTC](https://forum.mautic.org/t/installation-issue/3382/3 "2016-02-03T11:57:24Z")

</div>

Since it’s failing in the PHP namespace declaration:

[https://github.com/mautic/mautic/blob/staging/app/console#L18](https://github.com/mautic/mautic/blob/staging/app/console#L18)

My guess is that your PHP is a bit older than 5.4.

---

<div class="post-metadata">

**Author:** ![Paolo](https://avatars.discourse-cdn.com/v4/letter/p/6f9a4e/32.png) [@Paolo](https://forum.mautic.org/u/Paolo)\
**Post date:** [February 4, 2016, 10:03am UTC](https://forum.mautic.org/t/installation-issue/3382/4 "2016-02-04T10:03:57Z")

</div>

Thanks for the answer escopecz, you are already pointing me in the right direction. I wasn’t sure if it was an installation issue. It seems more an “environment” one 🙂

I am/was quite confident I am running php 5.4

cPanel 11.52.2  
Apache 2.2.31  
PHP 5.4.24  
MySQL 5.5.42  
Perl 5.10.1

Strangely enough I created a test page  
[http://marketing.paolopelloni.it/test.php](http://marketing.paolopelloni.it/test.php)  
and this returns PHP 5.6!

Having said that I forced PHP5.4 via php.ini in the app folder, just to get an extra error:

`Failed loading /usr/php/54/usr/lib64/php/modules/ZendGuardLoader.so: /usr/php/54/usr/lib64/php/modules/ZendGuardLoader.so: undefined symbol: zend_new_interned_string
Status: 500 Internal Server Error
Content-type: text/html`

I tried also disabling fast cgi but with no luck ☹

Which I believe it has to do with an extra line in the php.ini. Commented and the error goes away but status 500 is still there, and so the error on line 18.  
Is there any extra module I should install?

---

<div class="post-metadata">

**Author:** ![escopecz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/escopecz/32/370_2.png) [@escopecz](https://forum.mautic.org/u/escopecz)\
**Post date:** [February 4, 2016, 10:26am UTC](https://forum.mautic.org/t/installation-issue/3382/5 "2016-02-04T10:26:00Z")

</div>

It seems like a server setting issue. Consult it probably with your hosting provider. I’m not a skilled sysadmin.

---

<div class="post-metadata">

**Author:** ![Paolo](https://avatars.discourse-cdn.com/v4/letter/p/6f9a4e/32.png) [@Paolo](https://forum.mautic.org/u/Paolo)\
**Post date:** [February 7, 2016, 8:02pm UTC](https://forum.mautic.org/t/installation-issue/3382/6 "2016-02-07T20:02:45Z")

</div>

If this can be of any help to anyone else. php app/console does not work … but the trick from escopecz of commands.php does.

See: [https://gist.github.com/escopecz/9a1a0b10861941a457f4](https://gist.github.com/escopecz/9a1a0b10861941a457f4)

I have opened a ticked with [justhost.com](http://justhost.com) to understand why the cli php returns an error and I will update here again for the benefit of others.

---

<div class="post-metadata">

**Author:** ![theniel](https://avatars.discourse-cdn.com/v4/letter/t/0ea827/32.png) [@theniel](https://forum.mautic.org/u/theniel)\
**Post date:** [July 23, 2017, 7:26pm UTC](https://forum.mautic.org/t/installation-issue/3382/7 "2017-07-23T19:26:54Z")

</div>

In my case I had to use right php version on CLI
