# Installed mautic 4.4.10 with softaculous - getting 403 error

**URL:** <https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425>\
**Category:** Mautic 4 Install/Upgrade Support\
**Created:** [September 25, 2023, 3:37pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425 "2023-09-25T15:37:31Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![mikehersee](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikehersee/32/8291_2.png) [@mikehersee](https://forum.mautic.org/u/mikehersee)\
**Post date:** [September 25, 2023, 3:37pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/1 "2023-09-25T15:37:32Z")

</div>

**Your software**  
_My PHP version is_ :8.0  
_My MariaDB version is_ 10.6.15

**Updating/Installing Errors**  
_I am_: Installing  
_installing via_ Softaculous on Rochen hosting (who host the joomla official website)

_These errors are showing in the installer_ : it appeared to have installed properly, according to softaculous

_These errors are showing in the Mautic log_ : the log files directory in mautic is empty.

**Your problem**  
_My problem is_ :  
I installed mautic using softaculous on a wp site, in the recommended subdirectory of mautic. When I click on the link to go to the login page - [www.pivotalshift.co.uk/mautic/s/login](http://www.pivotalshift.co.uk/mautic/s/login) - I get 403 forbidden error.

_Steps I have tried to fix the problem_ : If I rename the .htaccess file in the mautic directory I then get after a slight delay, “there has been a critical error on this website. Learn more about troubleshooting wordpress”. Which is not what I expected as I thought I would get some mautic error.

I’ve looked at the file and folder permissions, and all the folders are 755 and the files have 644 permissions, in the mautic directory at least. The mautic directory has folder permission of 755.

Any suggestions gratefully received. I know it is shared hosting, but I have set the execution time max to 240 seconds, and I’ve not had problems with Rochen previously.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [September 25, 2023, 3:49pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/2 "2023-09-25T15:49:10Z")

</div>

Hey there, you might like to take a look at this Github issue:

> <https://github.com/mautic/mautic/issues/10913#issuecomment-1055681986>
>
> \### Mautic Version
> 
> 4.2.x series
> 
> \### PHP version
> 
> 7.4.27
> 
> \### What brow…sers are you seeing the problem on?
> 
> Firefox, Chrome
> 
> \### What happened?
> 
> After performing an upgrade, the site reports an error 403, forbidden.
> 
> We upgrade via command line and clear cache and clean permissions as part of the process.
> 
> This maybe server specific, but this line in the HTACCESS
> 
> https://github.com/mautic/mautic/blob/4.2.0/.htaccess
> 
> \`\`\`
> \# Apache 2.4+
> \<IfModule authz\_core\_module\>
> # Deny access via HTTP requests to all PHP files.
> \<FilesMatch "\\.php$"\>
> Require all denied
> \</FilesMatch\>
> \`\`\`
> 
> Causes the issue, by commenting out
> 
> \`\`\`
> \<FilesMatch "\\.php$"\>
> Require all denied
> \</FilesMatch\>
> \`\`\`
> 
> The site loads again.
> 
> Prior to this verison 4.1.2 Worked with this in the htaccess file.
> 
> \### How can we reproduce this issue?
> 
> Server
> Ubunto 18.04.4 LTS
> Server API | FPM/FastCGI
> MariaDB
> 1:10.2.43+maria~bionic
> Apache
> 2.4.52-1+ubuntu18.04+1
> NGiNX
> 1.19.9-1+ubuntu18.04+1
> 
> Not sure if this is important, but we have mautic in a subfolder off the domain
> eg: domain.com/mautic/
> 
> \### Relevant log output
> 
> \`\`\`shell
> n/a
> \`\`\`
> 
> 
> \### Code of Conduct
> 
> \- \[X\] I confirm that I have read and agree to follow this project's Code of Conduct

It’s preferred to use Mautic in a subdomain rather than a sub folder, but there are some workarounds mentioned.

You may need to ask Rochen for some help on their specific setup if you’re struggling to get this working.

---

<div class="post-metadata">

**Author:** ![mikehersee](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikehersee/32/8291_2.png) [@mikehersee](https://forum.mautic.org/u/mikehersee)\
**Post date:** [September 25, 2023, 4:56pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/3 "2023-09-25T16:56:11Z")

</div>

Ok, thanks for that. Having read about it as you suggested, I’ve decided that rather than mess with the .htaccess file I’ve decided to uninstall and create a subdomain as that will be the better-supported way going forward.

---

<div class="post-metadata">

**Author:** ![mikehersee](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mikehersee/32/8291_2.png) [@mikehersee](https://forum.mautic.org/u/mikehersee)\
**Post date:** [September 25, 2023, 5:32pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/4 "2023-09-25T17:32:06Z")

</div>

Oh. I’ve created my subdomain - [mail.pivotalshift.co.uk](http://mail.pivotalshift.co.uk) - and installed mautic 4.4.10 using softaculous in the root of it (ie, no mautic subdirectory), but still get the ‘403 forbidden’ message 😖

I gather the subdomain might take a while to propagate round the internet - I tried to log in to mautic only about 20 minutes after creating the subdomain. Could that be the reason?

Mike

---

<div class="post-metadata">

**Author:** ![mzagmajster](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mzagmajster/32/687_2.png) [@mzagmajster](https://forum.mautic.org/u/mzagmajster)\
**Post date:** [September 26, 2023, 4:07pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/5 "2023-09-26T16:07:03Z")

</div>

Softaculous has some rules in place that prevent accessing some files and executing some of the functions in order to be able to use mautic with it, you have to adjust the rules.

I think I can adjust that for you if you are interested, drop me a PM.

Regards, M.

---

<div class="post-metadata">

**Author:** ![marcus42](https://avatars.discourse-cdn.com/v4/letter/m/ac91a4/32.png) [@marcus42](https://forum.mautic.org/u/marcus42)\
**Post date:** [September 27, 2023, 6:22pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/6 "2023-09-27T18:22:59Z")

</div>

403 is a forbidden access.

Things to check, in that order:

1. create a file only containing the words “hello world” at the root of your www and try accessing it directly (and you should read “Hello world”).

- If it fails, it could be directory permissions and/or server configuration.
- if it succeed, it is probably a server configuration (read htaccess misconfiguration) - but not a permission issue.

1. check htaccess for any “deny from” and comment all of it and test…

\*\* I suspect that those lines in your htaccess are breaking it:

> <https://github.com/mautic/mautic/blob/62cffc538299aa6ddb75ecd8352aeee248417e2b/.htaccess#L100-L124>

\*\* EDIT \*\*  
Make sure to leave the composer bit active (don’t comment it - actually those files shouldn’t even be there to start with)

---

<div class="post-metadata">

**Author:** ![mzagmajster](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mzagmajster/32/687_2.png) [@mzagmajster](https://forum.mautic.org/u/mzagmajster)\
**Post date:** [September 29, 2023, 10:16am UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/7 "2023-09-29T10:16:47Z")

</div>

Yes, its forbidden and softaculous might trigger 403 if the rules are too strict

---

<div class="post-metadata">

**Author:** ![lancehaverkamp](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lancehaverkamp/32/9627_2.png) [@lancehaverkamp](https://forum.mautic.org/u/lancehaverkamp)\
**Post date:** [October 3, 2023, 6:27pm UTC](https://forum.mautic.org/t/installed-mautic-4-4-10-with-softaculous-getting-403-error/29425/8 "2023-10-03T18:27:50Z")

</div>

You will find that upgrading Mautic also breaks the .htaccess file. My hosting company is kind & efficient at fixing that. Perhaps it’s only an issue for those of us installing both WordPress & Mautic via Softaculous–I don’t know. Do be aware that Mautic is headed down a path (Composer dependence) that will eventually kick Mautic off of shared hosing entirely. Because, Composer has administrative power that can’t be safely trusted on shared hosting. That’s unfortunate, because for the **vast majority** of us, shared hosting is completely sufficient with a small mailing list.

I’ve been trying to get a fully-managed container service such as [PikaPods.com](http://PikaPods.com) to offer Mautic hosting, but there is not enough demand yet. That may change if/when Mautic becomes uninstallable on shared hosting.

Lance
