# Landing Page URL Error

**URL:** <https://forum.mautic.org/t/landing-page-url-error/1869>\
**Category:** Product Support\
**Created:** [May 22, 2015, 3:59pm UTC](https://forum.mautic.org/t/landing-page-url-error/1869 "2015-05-22T15:59:44Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![petertl](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/petertl/32/511_2.png) [@petertl](https://forum.mautic.org/u/petertl)\
**Post date:** [May 22, 2015, 3:59pm UTC](https://forum.mautic.org/t/landing-page-url-error/1869/1 "2015-05-22T15:59:44Z")

</div>

Hi,  
  
  
  
I installed Mautic into a folder just into the WWW document root. I think, the application (e.g. the campaigns) should be accessible via

Code:

http://.../mautic/s/campaigns/view/5

  
but that does not work. I have to make the URL look like  

Code:

http://.../mautic/index.php/s/campaigns/view/5

  
to be able to use the application.  
  
That would not be a real issue but it becomes one when I get to the landing page functionality. When I create a landing page and insert it into an email, the generated link looks like  

Code:

http://.../mautic/landing-page-part?ct=...tracking...code...

  
This URL generates a 404, because the application expects the _.../index.php/..._ part which is there when I work with the frontend but is missing in the generated landing page URL.  
  
My very limited technical skills tell me that something is wrong with the URL rewrite - maybe it is not. ![:-)]( ":-)")  
  
Any ideas?  
  
Peter

---

<div class="post-metadata">

**Author:** ![petertl](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/petertl/32/511_2.png) [@petertl](https://forum.mautic.org/u/petertl)\
**Post date:** [May 22, 2015, 3:59pm UTC](https://forum.mautic.org/t/landing-page-url-error/1869/2 "2015-05-22T15:59:44Z")

</div>

Hi,

I installed Mautic into a folder just into the WWW document root. I think, the application (e.g. the campaigns) should be accessible via

```auto
http://.../mautic/s/campaigns/view/5
```

but that does not work. I have to make the URL look like

```auto
http://.../mautic/index.php/s/campaigns/view/5
```

to be able to use the application.

That would not be a real issue but it becomes one when I get to the landing page functionality. When I create a landing page and insert it into an email, the generated link looks like

```auto
http://.../mautic/landing-page-part?ct=...tracking...code...
```

This URL generates a 404, because the application expects the …/index.php/… part which is there when I work with the frontend but is missing in the generated landing page URL.

My very limited technical skills tell me that something is wrong with the URL rewrite - maybe it is not. 🙂

Any ideas?

Peter

---

<div class="post-metadata">

**Author:** ![petertl](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/petertl/32/511_2.png) [@petertl](https://forum.mautic.org/u/petertl)\
**Post date:** [May 23, 2015, 9:17am UTC](https://forum.mautic.org/t/landing-page-url-error/1869/3 "2015-05-23T09:17:03Z")

</div>

Hey guys,

I created a hosted Mautic account and there is indeed a difference between this application and the one I installed on my server. The Mautic hosted application dashboard URL is

```auto
https://....mautic.com/s/dashboard
```

where mine is

```auto
http://.../mautic/index.php/s/dashboard
```

I am pretty sure now that something goes wrong with the URL rewrite, the /index.php should not be there. And I guess when it is not in the URL, both landing page and and tracking will work fine.

Any idea what is configured wrong in my web server?

Peter

---

<div class="post-metadata">

**Author:** ![chad.windnagle](https://avatars.discourse-cdn.com/v4/letter/c/7feea3/32.png) [@chad.windnagle](https://forum.mautic.org/u/chad.windnagle)\
**Post date:** [May 25, 2015, 5:25pm UTC](https://forum.mautic.org/t/landing-page-url-error/1869/4 "2015-05-25T17:25:06Z")

</div>

Hi Peter

This is definitely related to a configuration mod\_rewrite issue. Couple questions:

- Can you confirm your web engine? Is it apache?
- Confirm if mod\_rewrite is enabled?
- Confirm the .htaccess file sent with mautic is on the server?

Its possible Apache may need to be configured to allow overrides in your web root:  
[http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride](http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride)

---

<div class="post-metadata">

**Author:** ![petertl](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/petertl/32/511_2.png) [@petertl](https://forum.mautic.org/u/petertl)\
**Post date:** [May 26, 2015, 4:20pm UTC](https://forum.mautic.org/t/landing-page-url-error/1869/5 "2015-05-26T16:20:55Z")

</div>

Hi Chad, please find my answers inline:

> [@](#):
>
> - Can you confirm your web engine? Is it apache?

I am running Apache version 2.4.7 on a Linux server.

> [@](#):
>
> - Confirm if mod\_rewrite is enabled?

In the Loaded Modules section of phpinfo(), mod\_rewrite is listed.

> [@](#):
>
> - Confirm the .htaccess file sent with mautic is on the server?

Yes, the .htaccess file is on the server.

[quote]Its possible Apache may need to be configured to allow overrides in your web root:  
[http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride[/quote]](http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride%5B/quote%5D)  
I inserted the following into apache2.conf and restarted the Apache service:

`<Directory /var/www/http/mautic>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>`

Unfortunately after inserting and restarting, the Mautic application (via http://…/mautic) produces a redirection to http://…/mautic/s/dashboard and results in a 404 (“The requested URL /mautic/s/dashboard was not found on this server.”).

This is the point where it gets intransparent for me. Is the apache2.conf the correct place to put the code or does it have to be the .htaccess file for the /mautic directory?

Peter

---

<div class="post-metadata">

**Author:** ![petertl](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/petertl/32/511_2.png) [@petertl](https://forum.mautic.org/u/petertl)\
**Post date:** [May 28, 2015, 6:47pm UTC](https://forum.mautic.org/t/landing-page-url-error/1869/6 "2015-05-28T18:47:46Z")

</div>

I just found the solution - and it is rather strange/stupid. I checked the (delivered) .htaccess file and the first line was

```auto
e the front controller as index file. It serves as a fallback solution when
```

although it should have been

```auto
#Use the front controller as index file. It serves as a fallback solution when
```

Somehow the first three characters went missing. Strange thing, however: solved.

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 2, 2020, 10:59pm UTC](https://forum.mautic.org/t/landing-page-url-error/1869/7 "2020-02-02T22:59:46Z")

</div>


