# MariaDB server error broadcasts:send sending to very large segment

**URL:** https://forum.mautic.org/t/mariadb-server-error-broadcasts-send-sending-to-very-large-segment/20026
**Category:** Product Support
**Created:** [June 30, 2021, 12:34pm UTC](https://forum.mautic.org/t/mariadb-server-error-broadcasts-send-sending-to-very-large-segment/20026 "2021-06-30T12:34:30Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![bmontell](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bmontell/32/4130_2.png) [@bmontell](https://forum.mautic.org/u/bmontell)
#### Post date: [June 30, 2021, 12:34pm UTC](https://forum.mautic.org/t/mariadb-server-error-broadcasts-send-sending-to-very-large-segment/20026/1 "2021-06-30T12:34:30Z")

</div>

**Your software**  
My Mautic version is: v3.3.3  
My PHP version is: 7.4.20  
My Database type and version is: mysql Ver 15.1 Distrib 10.5.11-MariaDB

**Your problem**  
My problem is: when we schedule an email delivery to a very large segment we get an error

These errors are showing in the log: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ’  
:defaultNumber) as frequency\_number, IFNULL(fr.frequency\_time,:frequencyTime)…’ at line 1

Steps I have tried to fix the problem: We try to change the value of the frequency of the email configuration to 2 a day as well as look in the forum for an answer to a similar case without success

---

<div class="post-metadata">

### Author: ![bmontell](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bmontell/32/4130_2.png) [@bmontell](https://forum.mautic.org/u/bmontell)
#### Post date: [June 30, 2021, 2:35pm UTC](https://forum.mautic.org/t/mariadb-server-error-broadcasts-send-sending-to-very-large-segment/20026/2 "2021-06-30T14:35:27Z")

</div>

I just solved the problem by including the limit in the scheduled task

mautic:emails:send --limit=50000  
mautic:broadcasts:send --limit=50000
