# Mautic 2.15.3 Installation not working on VPS (PHP 5.6)

**URL:** <https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394>\
**Category:** Product Support\
**Tags:** community\
**Created:** [January 22, 2020, 5:08pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394 "2020-01-22T17:08:54Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![rehansaleem](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/rehansaleem/32/398_2.png) [@rehansaleem](https://forum.mautic.org/u/rehansaleem)\
**Post date:** [January 22, 2020, 5:08pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/1 "2020-01-22T17:08:55Z")

</div>

**Your software**  
My Mautic version is: 2.15.3  
My PHP version is: 5.6

**Your problem**  
My problem is: I am trying to install mautic 2.15.3 on VPS server, on second step of installation process after entering the admin details it is showing following error.

However same environment is working for mautic 2.15.0 version.

Thanks.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/a/aeea9a0b82dc95b7d782daa9a65276f50130bf76.png)

These errors are showing in the log:  
[2020-01-22 17:01:39] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/var/www/html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=’.:/usr/share/pear:/usr/share/php’) - in file /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209    
[2020-01-22 17:01:39] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/var/www/html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=’.:/usr/share/pear:/usr/share/php’) - in file /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209    
[2020-01-22 17:01:39] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalErrorException: “Compile Error: require(): Failed opening required ‘/var/www/html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=’.:/usr/share/pear:/usr/share/php’)” at /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php line 209 {“exception”:"[object] (Symfony\Component\Debug\Exception\FatalErrorException(code: 0): Compile Error: require(): Failed opening required ‘/var/www/html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=’.:/usr/share/pear:/usr/share/php’) at /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php:209)"}

---

<div class="post-metadata">

**Author:** ![rehansaleem](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/rehansaleem/32/398_2.png) [@rehansaleem](https://forum.mautic.org/u/rehansaleem)\
**Post date:** [January 22, 2020, 5:28pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/2 "2020-01-22T17:28:42Z")

</div>

Hi guys, the issue was fixed by setting this for the vps.

php app/console cache:warmup --env=prod

---

<div class="post-metadata">

**Author:** ![rehansaleem](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/rehansaleem/32/398_2.png) [@rehansaleem](https://forum.mautic.org/u/rehansaleem)\
**Post date:** [January 22, 2020, 9:33pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/3 "2020-01-22T21:33:35Z")

</div>

Seems like crons are not working and giving following error, after running above command.

```
require(/var/www/html/app/cache/prod/doctrine/orm/Proxies/ __CG__ MauticLeadBundleEntityLead.php): failed to open
+stream: No such file or directory in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
PHP Fatal error: require(): Failed opening required '/var/www/html/app/cache/prod/doctrine/orm/Proxies/ __CG__ MauticLeadBundleEntityLead.php'
+(include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209
```

---

<div class="post-metadata">

**Author:** ![dirk\_s](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dirk_s/32/748_2.png) [@dirk\_s](https://forum.mautic.org/u/dirk_s)\
**Post date:** [January 22, 2020, 10:37pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/4 "2020-01-22T22:37:39Z")

</div>

It very much looks like PHP timed our before finishing creating your cache. Can you increase PHP timeout limit? I experienced systems where it took 2.5 min to warmup the cache.

---

<div class="post-metadata">

**Author:** ![dirk\_s](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dirk_s/32/748_2.png) [@dirk\_s](https://forum.mautic.org/u/dirk_s)\
**Post date:** [January 22, 2020, 10:38pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/5 "2020-01-22T22:38:44Z")

</div>

Also I recommend upgrading PHP to Version 7.2, at least some 7.x (but not yet 7.3) 🤓

---

<div class="post-metadata">

**Author:** ![rehansaleem](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/rehansaleem/32/398_2.png) [@rehansaleem](https://forum.mautic.org/u/rehansaleem)\
**Post date:** [January 23, 2020, 4:29pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/6 "2020-01-23T16:29:41Z")

</div>

Thanks dirk, If i increase the PHP timeout limit, will it also fix the screenshot error as well? i tried this on same VPS with php 7.0 and it was giving same error.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [January 23, 2020, 9:55pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/7 "2020-01-23T21:55:13Z")

</div>

Mautic files/directory (app/cache) must be writable by the web server user.

---

<div class="post-metadata">

**Author:** ![rehansaleem](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/rehansaleem/32/398_2.png) [@rehansaleem](https://forum.mautic.org/u/rehansaleem)\
**Post date:** [January 23, 2020, 10:24pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/8 "2020-01-23T22:24:59Z")

</div>

apache owns all the files and directory of mautic and i have also set the 755 on folders and 644 on files, but still getting the error.

I am curious why everything runs perfectly fine when i install 2.15.0.

Any thoughts on that as well.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [January 24, 2020, 2:24am UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/9 "2020-01-24T02:24:57Z")

</div>

Did you run that PHP command (php app/console cache:warmup ) as root user? If you did, the web server user can’t write there as only root has permission to do so.

`find -user /var/www/html/app/cache`

---

<div class="post-metadata">

**Author:** ![rehansaleem](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/rehansaleem/32/398_2.png) [@rehansaleem](https://forum.mautic.org/u/rehansaleem)\
**Post date:** [January 25, 2020, 5:19pm UTC](https://forum.mautic.org/t/mautic-2-15-3-installation-not-working-on-vps-php-5-6/12394/10 "2020-01-25T17:19:10Z")

</div>

Yes, i ran above command as root user, i have switched user to apache using following command

`su -s /bin/bash apache`

Then warmup the cache and crons are running perfectly fine.  
Thanks for your help @MxyzptlkFishStix.
