# Mautic 2.6 problem

**URL:** <https://forum.mautic.org/t/mautic-2-6-problem/7477>\
**Category:** Product Support\
**Created:** [February 11, 2017, 3:03pm UTC](https://forum.mautic.org/t/mautic-2-6-problem/7477 "2017-02-11T15:03:57Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![marketer](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marketer/32/13380_2.png) [@marketer](https://forum.mautic.org/u/marketer)\
**Post date:** [February 11, 2017, 3:03pm UTC](https://forum.mautic.org/t/mautic-2-6-problem/7477/1 "2017-02-11T15:03:57Z")

</div>

I upgraded and discovered a path issue with the avatar image and so did a clean installation.  
  
  
  
The URL to the avatar.png file is still being created incorrectly:  
  
  
  
 ![](https://www.gravatar.com/avatar/d3f2cbee69954df6a9ef63cb6c58c2da?s=250&d=https%3A%2F%2Fwww.mydomain.com%2Fmarketing%2Fmarketing%2Fmedia%2Fimages%2Favatar.png)  
  
  
  
And the File Browser in the Builder section of emails just produces a spinning wheel and I am unable to upload or find images.  
  
  
  
Is this a permission problem or a bug…

---

<div class="post-metadata">

**Author:** ![marketer](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marketer/32/13380_2.png) [@marketer](https://forum.mautic.org/u/marketer)\
**Post date:** [February 11, 2017, 3:03pm UTC](https://forum.mautic.org/t/mautic-2-6-problem/7477/2 "2017-02-11T15:03:57Z")

</div>

I upgraded and discovered a path issue with the avatar image and so did a clean installation.

The URL to the avatar.png file is still being created incorrectly:

![](https://www.gravatar.com/avatar/d3f2cbee69954df6a9ef63cb6c58c2da?s=250&d=https%3A%2F%2Fwww.mydomain.com%2Fmarketing%2Fmarketing%2Fmedia%2Fimages%2Favatar.png)

And the File Browser in the Builder section of emails just produces a spinning wheel and I am unable to upload or find images.

Is this a permission problem or a bug…

---

<div class="post-metadata">

**Author:** ![marketer](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marketer/32/13380_2.png) [@marketer](https://forum.mautic.org/u/marketer)\
**Post date:** [February 11, 2017, 3:38pm UTC](https://forum.mautic.org/t/mautic-2-6-problem/7477/3 "2017-02-11T15:38:50Z")

</div>

A little more data is this:

It is the extra marketing in the page that is being generated as I edited the HTML in the page in live view and the avatar.png appeared:

… %2Fmarketing%2Fmarketing%2F …

Where is this coming from?

---

<div class="post-metadata">

**Author:** ![marketer](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marketer/32/13380_2.png) [@marketer](https://forum.mautic.org/u/marketer)\
**Post date:** [February 11, 2017, 4:23pm UTC](https://forum.mautic.org/t/mautic-2-6-problem/7477/4 "2017-02-11T16:23:29Z")

</div>

So I have fixed most of above … I had placed in the General Settings / Site URL as [http://www.mydomain.com/marketing](http://www.mydomain.com/marketing)  
instead of the root domain… I thought it meant the path to the installed files… it should just be [http://www.mydomain.com](http://www.mydomain.com)

---

<div class="post-metadata">

**Author:** ![marketer](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marketer/32/13380_2.png) [@marketer](https://forum.mautic.org/u/marketer)\
**Post date:** [February 11, 2017, 4:30pm UTC](https://forum.mautic.org/t/mautic-2-6-problem/7477/5 "2017-02-11T16:30:44Z")

</div>

File manager still not working though… although the images do appear in the Email Builder for a selected template the file manager does not layout any files and adding files to upload just results in a failure…

Errors like: mod\_fcgid: stderr: PHP Fatal error: Call to a member function setLogger() on null in /var/www/vhosts/domain.com/httpdocs/marketing/app/bundles/CoreBundle/EventListener/ErrorHandlingListener.php on line 42, referer: [https://www.mydomain.com/marketing/app/bundles/CoreBundle/Assets/js/libraries/ckeditor/filemanager/index.html?type=Images](https://www.mydomain.com/marketing/app/bundles/CoreBundle/Assets/js/libraries/ckeditor/filemanager/index.html?type=Images)

Any ideas?

---

<div class="post-metadata">

**Author:** ![marketer](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/marketer/32/13380_2.png) [@marketer](https://forum.mautic.org/u/marketer)\
**Post date:** [February 13, 2017, 10:33am UTC](https://forum.mautic.org/t/mautic-2-6-problem/7477/6 "2017-02-13T10:33:57Z")

</div>

All working and noted in the Mautic Repo - issues - GitHub
