# Mautic 3. Can not login for first time

**URL:** <https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073>\
**Category:** Mautic 3 - Install/Upgrade Support\
**Created:** [July 3, 2020, 2:22pm UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073 "2020-07-03T14:22:41Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![ocamposf](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ocamposf/32/1627_2.png) [@ocamposf](https://forum.mautic.org/u/ocamposf)\
**Post date:** [July 3, 2020, 2:22pm UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073/1 "2020-07-03T14:22:41Z")

</div>

**Your software**  
\*My PHP version is :7.3.19-1  
\*MariaDB version is: 10.3.22-MariaDB  
Apache/2.4.38  
New installation no errors.

I just install a mautic 3, in a new instance, there were no errors on installation. But just after install and first configuration (admin user, db connection…) , I got the first login page, but I can not login. The error is: Unable to resolve binding type, invalid or unsupported http request

I have reviewed permissions but seems all it’s ok.

I executed these scripts with no errors:

```auto
find . -type f -not -perm 644 -exec chmod 644 {} +
find . -type d -not -perm 644 -exec chmod 755 {} +
chmod -R g+w app/cache/ app/logs/ app/config/
chmod -R g+w media/files/ media/images/ translations/
rm -rf app/cache/*
sudo chown -R www-data:www-data .

```

---

<div class="post-metadata">

**Author:** ![dennisameling](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dennisameling/32/958_2.png) [@dennisameling](https://forum.mautic.org/u/dennisameling)\
**Post date:** [July 6, 2020, 8:58am UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073/2 "2020-07-06T08:58:15Z")

</div>

Can you let us know what server OS you’re using (CentOS/Ubuntu/etc.)?

When checking on Google for your error I came across similar errors when SAML is used ([https://stackoverflow.com/questions/35062847/saml-unable-to-resolve-binding-type-invalid-or-unsupported-http-request](https://stackoverflow.com/questions/35062847/saml-unable-to-resolve-binding-type-invalid-or-unsupported-http-request)). Have you by any change configured SAML?

Just linking this issue + PR here for visibility [https://github.com/mautic/mautic/issues/7836](https://github.com/mautic/mautic/issues/7836) and [https://github.com/mautic/mautic/pull/7512](https://github.com/mautic/mautic/pull/7512)

---

<div class="post-metadata">

**Author:** ![ocamposf](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ocamposf/32/1627_2.png) [@ocamposf](https://forum.mautic.org/u/ocamposf)\
**Post date:** [July 6, 2020, 5:29pm UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073/3 "2020-07-06T17:29:38Z")

</div>

Hi,

Its a Debian GNU/Linux 10 (buster). A server in Google cloud platform.

I also see this error related to SAML, but I don’t configure SAML as I was not able to login jet, just pass the first wizard.

---

<div class="post-metadata">

**Author:** ![M571](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/m571/32/2866_2.png) [@M571](https://forum.mautic.org/u/M571)\
**Post date:** [July 9, 2020, 10:20am UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073/4 "2020-07-09T10:20:16Z")

</div>

Hello, I just had the same problem, try this:

sudo a2enmod rewrite  
edit: sorry and restart apache2 with:  
sudo systemctl reload apache2

---

<div class="post-metadata">

**Author:** ![ocamposf](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ocamposf/32/1627_2.png) [@ocamposf](https://forum.mautic.org/u/ocamposf)\
**Post date:** [July 15, 2020, 2:29pm UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073/5 "2020-07-15T14:29:58Z")

</div>

Thanks for your help, its working also for me.  
Many Thanks.

---

<div class="post-metadata">

**Author:** ![masterale](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/masterale/32/433_2.png) [@masterale](https://forum.mautic.org/u/masterale)\
**Post date:** [September 2, 2020, 4:17pm UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073/6 "2020-09-02T16:17:30Z")

</div>

Hello !  
I have same problem, ubuntu 18.04 server fresh install, apache2, php7.2, MariaDB correct version, mautic 3.1.  
With this command i solved the problem.

- sudo a2enmod rewrite
- sudo systemctl reload apache2

Thanks.

---

<div class="post-metadata">

**Author:** ![tanaysai](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tanaysai/32/4163_2.png) [@tanaysai](https://forum.mautic.org/u/tanaysai)\
**Post date:** [December 26, 2020, 9:56pm UTC](https://forum.mautic.org/t/mautic-3-can-not-login-for-first-time/15073/7 "2020-12-26T21:56:43Z")

</div>

Stumbled upon this issue today.  
This seems to be happening if you are using Apache and mod\_rewrite is not enabled.

As suggested above, you can run the above command shared by @masterale to enable mod rewrite.

If you are using docker, add this to your dockerfile

```
RUN a2enmod rewrite

```

Although I wonder if login can’t happen without this, shouldn’t this be checked in checkRequirements() in CheckStep.php in InstallBundle?
