Mautic Community Forums

Mautic 3 on Centos 7 404 after installer completes

It seems like there are some permission/rewrite issues going on @netideas ?

Have a look in app/config/local.php for the site URL, it should not contain /index.php/. Also double check the htaccess against the link above.

This might be helpful for checking permissions: https://docs.mautic.org/en/troubleshooting/file-ownership-and-permissions

Sorry if i reply to this post, but i think is the same problem.

Hi,
i have the same problem on clean installation on Ubuntu 18.04 server made 2 days ago, with nginx and Mysql.
Problem is egual.
When connect to mautic3 website, receive 404 error and return url is : https://192.168.1.95/s/login
So i try to modify this url so : https://192.168.1.95/index.php/s/login and i receive login form.
After user and password and after click on Login button, i take another 404 error
with this return url : https://192.168.1.95/s/login_check.
What’s appen ?
I have downloaded .htaccess from github, but problem wasnt resolved.
Any idea ?

p.s. i have another mautic2 installation and work fine, no problem.

What is the site URL in your local.php file?

In /var/www/mautic/app/config/local.php the site_url parm is : https://192.168.1.95
Ty for help.

In local.php there is ‘site_url’ => ‘http://192.168.20.65’,

Does the site have to be https ?

I still need to compare .htaccess files although I’m using the one that came with Mautic with no modifications. Will also relax file permissions just in case

Thanks

I’ve got the same exact issue on Ubuntu 20.04 running Apache2. Anyone got this figured out?

Same issue here on ubuntu 18

In order to help us troubleshoot further, can everyone please provide us with the following information:

  • What webserver are you using (Apache/Nginx)? If you can, please let us know the webserver version number as well.
    • If Apache, have you set up Mautic as a vhost or under the webserver’s root directory (e.g. http://localhost/mautic)?
  • Are you running Mautic behind a reverse proxy?
  • Are you running Mautic on HTTP or HTTPS?

Thanks in advance!!

Apache package httpd-2.4.6-93.el7.centos.x86_64

Mautic is in webserver root running as http

I just set up a clean CentOS 7 VM with Apache 2.4.6 and PHP 7.3, and can indeed reproduce the issue after the installer completes:

I checked the Apache configuration and by default, AllowOverride is set to None in httpd.conf, which is causing the 404s. This setting was set to None by default starting with Apache 2.3.9.

Setting the AllowOverride setting to All fixed the issue for me :rocket:
Don’t forget to run sudo systemctl restart httpd after changing the config file!

<Directory "/var/www/html">
    # ... Other config here ...

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    # ... Other config here ...
</Directory>

Please let us know if this helps!

2 Likes

Hi,
had the same error on Debian9, and I found I too had “AllowOverride None” in the apache directive, probably a copy&paste from a different site configuration.

By setting “AllowOverride All” I solved the 404 as well.

1 Like

Thanks for your time and effort to investigate this.
That solved the issue.
Very much appreciated.

1 Like

Problem solved. Thanks mate. :+1:

1 Like

Information requested :

  • What webserver are you using (Apache/Nginx)? If you can, please let us know the webserver version number as well.
    nginx version: nginx/1.14.0 (Ubuntu 18.04 server)

    • If Apache, have you set up Mautic as a vhost or under the webserver’s root directory (e.g. http://localhost/mautic)?
      using nginx
  • Are you running Mautic behind a reverse proxy?
    NO. And i have already a mautic 2 running server from 2 month

  • Are you running Mautic on HTTP or HTTPS?
    Https If want can show you nginx webserver config

Thank you a lot, for help.

@masterale Can you please share you Nginx config? Mautic works best with Apache out of the box, but if you share your config here we can have a look :slight_smile:

Sure, here content of file.
One point : i keep error also before insert code part for redirect http to htts.

server {
listen 80 default_server;
listen [::]:80 default_server;
server_name _;
return 301 https://$host$request_uri;
}

server {
listen 443 ssl;
listen [::]:443 ssl;
include snippets/self-signed.conf;
include snippets/ssl-params.conf;

 server_name mautic3-it;

 root /var/www/mautic;
 index index.php;

 location / {
   try_files $uri $uri/ =404;
 }

 location ~ .php$ {
   include snippets/fastcgi-php.conf;
   fastcgi_pass unix:/run/php/php7.2-fpm.sock;
 }

 location ~* ^/index.php {
   fastcgi_split_path_info ^(.+.php)(/.+)$;
   fastcgi_pass unix:/run/php/php7.2-fpm.sock;
   fastcgi_index index.php;
   fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
   include fastcgi_params;
   fastcgi_buffer_size 128k;
   fastcgi_buffers 256 16k;
   fastcgi_busy_buffers_size 256k;
   fastcgi_temp_file_write_size 256k;
 }

}

Your software
My Mautic version is: 3.0.1
My PHP version is: PHP 7.2.24-0ubuntu0.18.04.6
Server OS: Ubuntu 18.04.4 LTS
Mysql: Ver 14.14 Distrib 5.7.30, for Linux
nginx: nginx/1.14.0 (Ubuntu)

Your problem
My problem is: Seems URL command cannot correctly locate the installer
The command URL changes from domain.com/mautic/ to
domain.com/mautic/index.php/installer with an error 404

These errors are showing in the log: There is no log

Steps I have tried to fix the problem:
1/ i have reviewed other similar error 404 problems and they have not led to solving this particular problem

2/ I assume it is something quite basic in the ngnix config at finding the installer files in the vendor subdir

3/ NOTE: I have a multi-site nginx server with multiple web servers under the main domain.
example: //main domain.com/mautic
//main domain.com/site2
etc…

4/ Suggestion: What may help me (and others with similar configs using nginx) is to post a functional example nginx.conf and perhaps an example site “sites-available/server” file so that this step becomes a mute problem for this and future releases.

5/ nginx.conf file: Perhaps someone may be able to point out the errors in my ways :slight_smile:

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}
http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    include /etc/nginx/mime.types;
    default_type application/octet-stream;
    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;
    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;
    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

}

6/ nginx sites-enabled/mautic file
server {
listen 80;
root /var/www/html;
index index.php index.html index.htm index.nginx-debian.html;
server_name mautic;
location = /favicon.ico { log_not_found off; access_log off; }
location = /robots.txt { log_not_found off; access_log off; allow all; }
location ~* .(css|gif|ico|jpeg|jpg|js|png)$ {
expires max;
log_not_found off;
}

    location / {
            try_files $uri /index.php$is_args$args;
    }
    location /mautic/ {
            try_files $uri $uri/ /mautic/index.php?q=$uri&$args;
    }


    location ~ \.php$ {
            include snippets/fastcgi-php.conf;
            fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include fastcgi_params;
            fastcgi_split_path_info ^(.+.php)(/.+)$;
     }

}

Many Thanks for any input and suggestions on this…

Rgs

@steveoppenheim moved this into an existing topic on 404 errors, please take a look at the thread above!

The thread above unfortunately did’nt really assist for some reason.

I’ve taken the following steps:

1/ installed fresh ubtuntu 18.04, fresh APACHE2, mysql with std configs and installed mautic .zip and "IT WORKS’

2/ installed fresh ubuntu 18.04, fresh nginx, mysql with above and similar server blocks and ALWAYS I get error 404;

It would be great if someone could do this from mautic or from the community with more knowlege about the install structure of mautic and come up with a standard nginx server block structure for 3.0.1

I confirm after doing the fresh install steps 2x for apache and 2x for nginx that someone ‘smarter than I’ needs to come up with a nginx server block structure that allows a fresh install of mautic 3.0.1

Seems to work out of the box for apache2 but Not for Nginx.