# Mautic, Amazon SES, and Bluehost configuration problem Connection refused #111 error

**URL:** <https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273>\
**Category:** Product Support\
**Created:** [January 23, 2017, 8:11pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273 "2017-01-23T20:11:15Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Evan37](https://avatars.discourse-cdn.com/v4/letter/e/d9b06d/32.png) [@Evan37](https://forum.mautic.org/u/Evan37)\
**Post date:** [January 23, 2017, 8:11pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/1 "2017-01-23T20:11:15Z")

</div>

I’ve been banging my head against the wall for a few days trying to figure this out.  
  
I set up an Amazon SES account and validated my domain and email address, including DKIM.  
  
Test email works fine.  
  
I contacted Amazon and they removed the sandbox so I can email anyone.  
  
  
  
I set up the email address through Outlook and can send emails that way.  
  
  
  
I’m using Bluehost for my hosting/domain and I have a dedicated IP and have been assured several times that ports are not being blocked (and the fact that I can send through Outlook seems to confirm this but I’m not positive this is the case).  
  
  
  
My issue is when I configure Mautic I can’t get a successful test connection.  
  
My settings (I’ve tried Plain and Login for SMTP authentication mode) and for ports I’ve tried 25, 465, 587, and 2587 :  
  
 ![mautic.png](https://www.dropbox.com/s/z1vquu038yopu8x/mautic.png)  
  
LInk if above image doesn’t work: [https://www.dropbox.com/s/z1vquu038yopu8x/mautic.png?dl=0](https://www.dropbox.com/s/z1vquu038yopu8x/mautic.png?dl=0)  
  
  
  
How do I figure out what to do from here?  
  
Appreciate any help you guys can offer.

---

<div class="post-metadata">

**Author:** ![Evan37](https://avatars.discourse-cdn.com/v4/letter/e/d9b06d/32.png) [@Evan37](https://forum.mautic.org/u/Evan37)\
**Post date:** [January 23, 2017, 8:11pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/2 "2017-01-23T20:11:15Z")

</div>

I’ve been banging my head against the wall for a few days trying to figure this out.  
I set up an Amazon SES account and validated my domain and email address, including DKIM.  
Test email works fine.  
I contacted Amazon and they removed the sandbox so I can email anyone.

I set up the email address through Outlook and can send emails that way.

I’m using Bluehost for my hosting/domain and I have a dedicated IP and have been assured several times that ports are not being blocked (and the fact that I can send through Outlook seems to confirm this but I’m not positive this is the case).

My issue is when I configure Mautic I can’t get a successful test connection.  
My settings (I’ve tried Plain and Login for SMTP authentication mode) and for ports I’ve tried 25, 465, 587, and 2587 :  
 ![](https://www.dropbox.com/s/z1vquu038yopu8x/mautic.png)  
LInk if above image doesn’t work: [https://www.dropbox.com/s/z1vquu038yopu8x/mautic.png?dl=0](https://www.dropbox.com/s/z1vquu038yopu8x/mautic.png?dl=0)

How do I figure out what to do from here?  
Appreciate any help you guys can offer.

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [January 23, 2017, 10:22pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/3 "2017-01-23T22:22:58Z")

</div>

ports are block @Evan37

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [January 23, 2017, 10:37pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/4 "2017-01-23T22:37:51Z")

</div>

send me an email `jninhilario@gmail.com`

---

<div class="post-metadata">

**Author:** ![sourdoughbread](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/sourdoughbread/32/2060_2.png) [@sourdoughbread](https://forum.mautic.org/u/sourdoughbread)\
**Post date:** [January 24, 2017, 12:31am UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/5 "2017-01-24T00:31:33Z")

</div>

you need to call bluehost and tell them to open port 2587 for both incoming and outgoing. I was in the exact same situation as you before.

---

<div class="post-metadata">

**Author:** ![Evan37](https://avatars.discourse-cdn.com/v4/letter/e/d9b06d/32.png) [@Evan37](https://forum.mautic.org/u/Evan37)\
**Post date:** [January 24, 2017, 2:13pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/6 "2017-01-24T14:13:31Z")

</div>

@ninjoan , you helped me on Slack a couple of days ago, if the ports are blocked would the email still work when I set up outgoing email with Outlook?  
The email sends fine everywhere except Mautic. Is that still a port issue?

---

<div class="post-metadata">

**Author:** ![Evan37](https://avatars.discourse-cdn.com/v4/letter/e/d9b06d/32.png) [@Evan37](https://forum.mautic.org/u/Evan37)\
**Post date:** [January 24, 2017, 2:15pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/7 "2017-01-24T14:15:02Z")

</div>

@sourdoughbread I saw your similar post on here. Bluehost assured me 2587 was open. Before you called them was your email sending through any other clients (gmail, outlook,. etc)?

I’m wondering why I can send through Outlook if the ports are blocked but it doesn’t work through Mautic.

How do I know for sure that the port is open?  
Thanks

---

<div class="post-metadata">

**Author:** ![Evan37](https://avatars.discourse-cdn.com/v4/letter/e/d9b06d/32.png) [@Evan37](https://forum.mautic.org/u/Evan37)\
**Post date:** [January 26, 2017, 4:10pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/8 "2017-01-26T16:10:47Z")

</div>

Finally got this resolved, @sourdoughbread was exactly right. After about 3 different people told me port 2587 was open, a 4th told me it wasn’t. I’m using a dedicated IP account so they opened it up and Mautic started working instantly.

Good to know for anyone else experiencing this problem.

---

<div class="post-metadata">

**Author:** ![sourdoughbread](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/sourdoughbread/32/2060_2.png) [@sourdoughbread](https://forum.mautic.org/u/sourdoughbread)\
**Post date:** [January 26, 2017, 5:14pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/9 "2017-01-26T17:14:57Z")

</div>

@Evan37 Nice. Glad it is resolved.

And by the way, you do not need a dedicated IP with any shared hosting provider. You just need them to open the port 2587 for incoming and outgoing.

---

<div class="post-metadata">

**Author:** ![charlescorn](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/charlescorn/32/155_2.png) [@charlescorn](https://forum.mautic.org/u/charlescorn)\
**Post date:** [January 26, 2017, 9:04pm UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/10 "2017-01-26T21:04:56Z")

</div>

Bluehost support is shocking at the moment. I had the same problem as you. Had to wait a 2 hours to get a response, then they did the ‘we don’t block any ports’ routine, until I pointed out that in Bluehost’s own support documents it states that they do block ports. After almost an hour and a half of pointing this out and explaining my situation in terms that a 3 year old might understand, they told me I needed to buy a dedicated IP.

So I switched my host to Siteground.

---

<div class="post-metadata">

**Author:** ![sourdoughbread](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/sourdoughbread/32/2060_2.png) [@sourdoughbread](https://forum.mautic.org/u/sourdoughbread)\
**Post date:** [January 28, 2017, 12:11am UTC](https://forum.mautic.org/t/mautic-amazon-ses-and-bluehost-configuration-problem-connection-refused-111-error/7273/11 "2017-01-28T00:11:37Z")

</div>

Glad your issue with ports being blocked was resolved. Personally, I would recommend [A2 Hosting](http://www.a2hosting.com?aid=jkpinto) .

I’m using A2 myself personally. The support and speed is insane! No issues setting up Mautic (you will have to tell them to open port 2587 thought).
