# Mautic API with Thrive

**URL:** <https://forum.mautic.org/t/mautic-api-with-thrive/4838>\
**Category:** Product Support\
**Created:** [August 10, 2016, 7:13pm UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838 "2016-08-10T19:13:16Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![steph2bordeaux](https://avatars.discourse-cdn.com/v4/letter/s/ce73a5/32.png) [@steph2bordeaux](https://forum.mautic.org/u/steph2bordeaux)\
**Post date:** [August 10, 2016, 7:13pm UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838/1 "2016-08-10T19:13:16Z")

</div>

Hi everyone,  
  
  
  
First of all, I’m french, so sorry if I make some mistakes.  
  
  
  
I bought Thrive Leads today and I tried to make the connection between Mautic and the plugin Thrive but it doesn’t work.  
  
  
  
I create an API Oath1 in Mautic, that’s ok. I made a connection in Thrive (Oath 1 too) and when I tried to validate, I have a message “The connection didn’t work.” The Error message is empty.  
  
  
  
Do you have some idea to help me ?

---

<div class="post-metadata">

**Author:** ![steph2bordeaux](https://avatars.discourse-cdn.com/v4/letter/s/ce73a5/32.png) [@steph2bordeaux](https://forum.mautic.org/u/steph2bordeaux)\
**Post date:** [August 10, 2016, 7:13pm UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838/2 "2016-08-10T19:13:16Z")

</div>

Hi everyone,

First of all, I’m french, so sorry if I make some mistakes.

I bought Thrive Leads today and I tried to make the connection between Mautic and the plugin Thrive but it doesn’t work.

I create an API Oath1 in Mautic, that’s ok. I made a connection in Thrive (Oath 1 too) and when I tried to validate, I have a message “The connection didn’t work.” The Error message is empty.

Do you have some idea to help me ?

---

<div class="post-metadata">

**Author:** ![Adam](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Adam](https://forum.mautic.org/u/Adam)\
**Post date:** [August 10, 2016, 7:14pm UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838/3 "2016-08-10T19:14:48Z")

</div>

Here is how I did it, and it worked flawless. If that does not work for you perhaps you should detail your environment because that is most likely where the problem is.

[https://www.youtube.com/watch?v=Ir4CkL9n6\_o](https://www.youtube.com/watch?v=Ir4CkL9n6_o)

---

<div class="post-metadata">

**Author:** ![steph2bordeaux](https://avatars.discourse-cdn.com/v4/letter/s/ce73a5/32.png) [@steph2bordeaux](https://forum.mautic.org/u/steph2bordeaux)\
**Post date:** [August 10, 2016, 7:43pm UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838/4 "2016-08-10T19:43:28Z")

</div>

I did exactly as you do in the video. In fact, I used the video to help me.

I’m on Wordpress. Mautic & Wordpress are on the same 1&1’s hosting.

I don’t know what you need, so I paste here part of my System Info :

PHP Version 5.6.24  
System Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux  
Build Date Jul 25 2016 07:13:53  
Configure Command ‘./configure’ ‘–build=x86\_64-linux-gnu’ ‘–prefix=/usr’ ‘–includedir=${prefix}/include’ ‘–mandir=${prefix}/share/man’ ‘–infodir=${prefix}/share/info’ ‘–sysconfdir=/etc’ ‘–localstatedir=/var’ ‘–disable-silent-rules’ ‘–libdir=${prefix}/lib/x86\_64-linux-gnu’ ‘–libexecdir=${prefix}/lib/x86\_64-linux-gnu’ ‘–disable-maintainer-mode’ ‘–disable-dependency-tracking’ ‘–program-suffix=5.6’ ‘–libdir=/usr/lib/php5.6’ ‘–with-config-file-path=/usr/lib/php5.6’ ‘–with-pear=/usr/lib/php5.6’ ‘–bindir=/usr/bin’ ‘–includedir=/usr/include’ ‘–with-zlib’ ‘–enable-debug=no’ ‘–enable-safe-mode=no’ ‘–enable-discard-path=no’ ‘–with-gd’ ‘–with-png-dir’ ‘–enable-track-vars’ ‘–with-db’ ‘–with-gdbm’ ‘–enable-force-cgi-redirect’ ‘–with-ttf’ ‘–enable-ftp’ ‘–with-mcrypt’ ‘–enable-memory-limit’ ‘–enable-calendar’ ‘–enable-wddx’ ‘–enable-bcmath’ ‘–enable-gd-imgstrttf’ ‘–enable-shmop’ ‘–with-openssl’ ‘–with-dom’ ‘–with-dom-xslt’ ‘–with-dom-exslt’ ‘–with-imap’ ‘–with-curl’ ‘–with-iconv’ ‘–with-freetype-dir’ ‘–with-bz2’ ‘–with-gettext’ ‘–enable-exif’ ‘–enable-mbstring=all’ ‘–with-kerberos’ ‘–with-sqlite’ ‘–with-imap-ssl’ ‘–with-libxml-dir’ ‘–with-xsl’ ‘–with-xslt-sablot’ ‘–with-jpeg-dir’ ‘–with-tidy’ ‘–enable-soap’ ‘–enable-xslt’ ‘–enable-sqlite-utf8’ ‘–enable-zip’ ‘–enable-intl’ ‘–with-mysqli=mysqlnd’ ‘–with-pdo-mysql=mysqlnd’ ‘–with-mysql=mysqlnd’ ‘–enable-opcache’ ‘build\_alias=x86\_64-linux-gnu’ ‘CFLAGS=-g ‘-O2’ ‘-fPIE’ ‘-fstack-protector-strong’ ‘-Wformat’ ‘-Werror=format-security’’ ‘LDFLAGS=-fPIE ‘-pie’ ‘-Wl,-z, relro’ ‘-Wl,-z, now’’ ‘CPPFLAGS=-D\_FORTIFY\_SOURCE=2’ ‘CXXFLAGS=-g ‘-O2’ ‘-fPIE’ ‘-fstack-protector-strong’ ‘-Wformat’ ‘-Werror=format-security’’  
Server API CGI/FastCGI  
Virtual Directory Support disabled  
Configuration File (php.ini) Path /usr/lib/php5.6  
Loaded Configuration File …/mautic/php.ini  
Scan this dir for additional .ini files (none)  
Additional .ini files parsed (none)  
PHP API 20131106  
PHP Extension 20131226  
Zend Extension 220131226  
Zend Extension Build API220131226, NTS  
PHP Extension Build API20131226, NTS  
Debug Build no  
Thread Safety disabled  
Zend Signal Handling disabled  
Zend Memory Manager enabled  
Zend Multibyte Support provided by mbstring  
IPv6 Support enabled  
DTrace Support disabled  
Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip  
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, tls, tlsv1.0, tlsv1.1, tlsv1.2  
Registered Stream Filters zlib._, bzip2._, convert.iconv._, mcrypt._, mdecrypt._, string.rot13, string.toupper, string.tolower, string.strip\_tags, convert._, consumed, dechunk

---

<div class="post-metadata">

**Author:** ![alexb](https://avatars.discourse-cdn.com/v4/letter/a/ecc23a/32.png) [@alexb](https://forum.mautic.org/u/alexb)\
**Post date:** [August 11, 2016, 4:32am UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838/5 "2016-08-11T04:32:02Z")

</div>

Also, if you include a slash ("/") at the end of your Mautic URL that you paste into Thrive during setup, that will fail as well.  
So, make sure there’s NO slash at the end of the URL (to your Mautic installation) that you paste into Thrive.

---

<div class="post-metadata">

**Author:** ![steph2bordeaux](https://avatars.discourse-cdn.com/v4/letter/s/ce73a5/32.png) [@steph2bordeaux](https://forum.mautic.org/u/steph2bordeaux)\
**Post date:** [August 11, 2016, 9:52am UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838/6 "2016-08-11T09:52:26Z")

</div>

Ok, just to let you know, I find this morning there was a problem with the plugin Evergreen. After disabling it, it works perfectly well. Thank you all for your help.

Have a nice day !

---

<div class="post-metadata">

**Author:** ![senol](https://avatars.discourse-cdn.com/v4/letter/s/bcef8e/32.png) [@senol](https://forum.mautic.org/u/senol)\
**Post date:** [January 18, 2017, 11:55am UTC](https://forum.mautic.org/t/mautic-api-with-thrive/4838/7 "2017-01-18T11:55:02Z")

</div>

The following happened:  
With help of my website hosting provider we added the following code to .htaccess

php\_flag display\_errors on

This provided the 500-error code which I then gave back to them.  
In my case it gave a Fatal error with “‘cURL error 35: SSL connect error’ in ”

My hosting provider could tell there was a conflict in curl-versions between both servers. They updated their curl versions.

This has helped! because I now have a working OATH1 api connection in ThriveLeads with Mautic.
