# Mautic campaigns as well as campaign filter is not working

**URL:** https://forum.mautic.org/t/mautic-campaigns-as-well-as-campaign-filter-is-not-working/26612
**Category:** Product Support
**Tags:** mautic-4
**Created:** [January 5, 2023, 3:02pm UTC](https://forum.mautic.org/t/mautic-campaigns-as-well-as-campaign-filter-is-not-working/26612 "2023-01-05T15:02:18Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![ankushanand](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ankushanand/32/8565_2.png) [@ankushanand](https://forum.mautic.org/u/ankushanand)
#### Post date: [January 5, 2023, 3:02pm UTC](https://forum.mautic.org/t/mautic-campaigns-as-well-as-campaign-filter-is-not-working/26612/1 "2023-01-05T15:02:18Z")

</div>

**Your software**  
My Mautic version is: 4.4.5  
My PHP version is: 7.4.30  
My Database type and version is: 10.6.9-MariaDB

**Your problem**  
My problem is:  
Issue 1: I created a segment to add Unsubscribed and bounced contacts automatically using filter as shown in image.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/c/cf7b8ed3088a7e68828ab5eeacc8e035f5c79bbd.png)

but my segment is not updating with those contacts at all.

Issue 2: Campaigns with contact source as segments are not working.  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/e/e769eacee0524b62042d82e33f6f1b6640203c06.png)

I did check and it works fine when there is a decision step in between but here, we don’t have any decision, I want the campaign to start as soon as someone enters the campaign which is not happening.

most of the time, I am uploading contacts from my other marketing platforms to mautic, so, I don’t yet have a decision from contact side

These errors are showing in the log:  
[2023-01-05 13:28:15] mautic.ERROR: PHP Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) - in file /opt/bitnami/apache/htdocs/app/bundles/LeadBundle/Helper/CustomFieldValueHelper.php - at line 28 {“hostname”:“ip-172-26-4-11”,“pid”:658040}  
[2023-01-05 13:28:15] mautic.ERROR: Symfony\Component\Debug\Exception\OutOfMemoryException: Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) - in file /opt/bitnami/apache/htdocs/app/bundles/LeadBundle/Helper/CustomFieldValueHelper.php - at line 28 {“hostname”:“ip-172-26-4-11”,“pid”:658040}  
[2023-01-05 13:28:53] mautic.ERROR: PHP Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) - in file /opt/bitnami/apache/htdocs/app/bundles/LeadBundle/Helper/CustomFieldValueHelper.php - at line 28 {“hostname”:“ip-172-26-4-11”,“pid”:658047}  
[2023-01-05 13:28:53] mautic.ERROR: Symfony\Component\Debug\Exception\OutOfMemoryException: Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) - in file /opt/bitnami/apache/htdocs/app/bundles/LeadBundle/Helper/CustomFieldValueHelper.php - at line 28 {“hostname”:“ip-172-26-4-11”,“pid”:658047}  
[2023-01-05 13:29:34] mautic.ERROR: PHP Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) - in file /opt/bitnami/apache/htdocs/app/bundles/LeadBundle/Helper/CustomFieldValueHelper.php - at line 28 {“hostname”:“ip-172-26-4-11”,“pid”:658042}  
[2023-01-05 13:29:34] mautic.ERROR: Symfony\Component\Debug\Exception\OutOfMemoryException: Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) - in file /opt/bitnami/apache/htdocs/app/bundles/LeadBundle/Helper/CustomFieldValueHelper.php - at line 28 {“hostname”:“ip-172-26-4-11”,“pid”:658042}  
[2023-01-05 14:17:10] mautic.ERROR: PHP Error: Allowed memory size of 792723456 bytes exhausted (tried to allocate 96473088 bytes) - in file /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php - at line 268 {“hostname”:“ip-172-26-4-11”,“pid”:886517}  
[2023-01-05 14:17:10] mautic.NOTICE: PHP Notice - Undefined variable: inline - in file /opt/bitnami/apache/htdocs/offline.php - at line 77 {“hostname”:“ip-172-26-4-11”,“pid”:886517}  
[2023-01-05 14:17:10] mautic.ERROR: Symfony\Component\Debug\Exception\OutOfMemoryException: Error: Allowed memory size of 792723456 bytes exhausted (tried to allocate 96473088 bytes) - in file /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php - at line 268 {“hostname”:“ip-172-26-4-11”,“pid”:886517}  
[2023-01-05 08:47:10] mautic.WARNING: PHP Warning - session\_start(): Failed to decode session object. Session has been destroyed - in file /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php - at line 156 {“file”:“”,“line”:0} {“hostname”:“ip-172-26-4-11”,“pid”:886518}  
[2023-01-05 08:47:10] mautic.CRITICAL: Uncaught PHP Exception RuntimeException: “Failed to start the session.” at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php line 157 {“exception”:“[object] (RuntimeException(code: 0): Failed to start the session. at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php:157)”} {“hostname”:“ip-172-26-4-11”,“pid”:886518}  
[2023-01-05 08:47:10] mautic.WARNING: PHP Warning - session\_start(): Failed to decode session object. Session has been destroyed - in file /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php - at line 156 {“file”:“”,“line”:0} {“hostname”:“ip-172-26-4-11”,“pid”:886520}  
[2023-01-05 08:47:10] mautic.CRITICAL: Uncaught PHP Exception RuntimeException: “Failed to start the session.” at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php line 157 {“exception”:“[object] (RuntimeException(code: 0): Failed to start the session. at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php:157)”} {“hostname”:“ip-172-26-4-11”,“pid”:886520}  
[2023-01-05 08:47:10] mautic.WARNING: PHP Warning - session\_start(): Failed to decode session object. Session has been destroyed - in file /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php - at line 156 {“file”:“”,“line”:0} {“hostname”:“ip-172-26-4-11”,“pid”:886521}  
[2023-01-05 08:47:10] mautic.CRITICAL: Uncaught PHP Exception RuntimeException: “Failed to start the session.” at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php line 157 {“exception”:“[object] (RuntimeException(code: 0): Failed to start the session. at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php:157)”} {“hostname”:“ip-172-26-4-11”,“pid”:886521}  
[2023-01-05 08:47:10] mautic.WARNING: PHP Warning - session\_start(): Failed to decode session object. Session has been destroyed - in file /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php - at line 156 {“file”:“”,“line”:0} {“hostname”:“ip-172-26-4-11”,“pid”:886522}  
[2023-01-05 08:47:10] mautic.CRITICAL: Uncaught PHP Exception RuntimeException: “Failed to start the session.” at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php line 157 {“exception”:“[object] (RuntimeException(code: 0): Failed to start the session. at /opt/bitnami/apache/htdocs/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php:157)”} {“hostname”:“ip-172-26-4-11”,“pid”:886522}  
[2023-01-05 13:11:04] mautic.NOTICE: PHP Notice - Trying to access array offset on value of type bool - in file /opt/bitnami/apache/htdocs/app/bundles/PageBundle/Entity/HitRepository.php - at line 267 {“options”:{“leadId”:“8492”,“0”:“%[www.domain.com/%“,“second\_to\_last”:“17547”},“sq”:”[object]](http://www.domain.com/%25%22,%22second_to_last%22:%2217547%22%7D,%22sq%22:%22%5Bobject%5D) (Doctrine\DBAL\Query\QueryBuilder: SELECT h.date\_hit latest\_hit FROM page\_hits h WHERE (h.lead\_id = 8492) AND (h.id \<\> 17547))”,“result”:false} {“hostname”:“ip-172-26-4-11”,“pid”:887830}  
[2023-01-05 13:11:08] mautic.NOTICE: PHP Notice - Trying to access array offset on value of type bool - in file /opt/bitnami/apache/htdocs/app/bundles/PageBundle/Entity/HitRepository.php - at line 267 {“options”:{“leadId”:“8650”,“0”:“%[www.domain.com/%“,“second\_to\_last”:“17548”},“sq”:”[object]](http://www.domain.com/%25%22,%22second_to_last%22:%2217548%22%7D,%22sq%22:%22%5Bobject%5D) (Doctrine\DBAL\Query\QueryBuilder: SELECT h.date\_hit latest\_hit FROM page\_hits h WHERE (h.lead\_id = 8650) AND (h.id \<\> 17548))”,“result”:false} {“hostname”:“ip-172-26-4-11”,“pid”:887833}

Steps I have tried to fix the problem:

I have tried alternative ways like using forms contact source, which works right, but I had to fill form thousands of times which also I did automate using python.  
That is not important,

I had to add contacts to a specific segment based on the actions they took like if they get more points, they will be added to a segment; in that case, I am helpless.

Any help will be appreciated.

---

<div class="post-metadata">

### Author: ![robm](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/robm/32/260_2.png) [@robm](https://forum.mautic.org/u/robm)
#### Post date: [January 5, 2023, 3:37pm UTC](https://forum.mautic.org/t/mautic-campaigns-as-well-as-campaign-filter-is-not-working/26612/2 "2023-01-05T15:37:33Z")

</div>

U seem to know tech so I am sure you have your cron jobs set correctly?

Segments not populating and campaigns not running usually means cron job issues.

---

<div class="post-metadata">

### Author: ![ankushanand](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ankushanand/32/8565_2.png) [@ankushanand](https://forum.mautic.org/u/ankushanand)
#### Post date: [January 5, 2023, 5:27pm UTC](https://forum.mautic.org/t/mautic-campaigns-as-well-as-campaign-filter-is-not-working/26612/3 "2023-01-05T17:27:10Z")

</div>

Thanks for your reply and input.

I will definitely check cron jobs as soon as possible and update in this post.  
If you see any other issue, plz let me know. I actually have set this mautic on AWS Lightsail which I am still trying to figure out 🙂.

@joeyk had really article on cron jobs, I will check this out, adding link here just in case some-else face same issue.

> **[Ultimate guide to Mautic cronjobs – Joey Keller](https://joeykeller.com/ultimate-guide-to-mautic-cronjobs/)**

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/1X/43c63600fe51440378769136903f1fa2a9a34102.png) [@system](https://forum.mautic.org/u/system)
#### Post date: [January 7, 2023, 5:27am UTC](https://forum.mautic.org/t/mautic-campaigns-as-well-as-campaign-filter-is-not-working/26612/4 "2023-01-07T05:27:14Z")

</div>

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.
