# Mautic latest 2.15.3 update failed causing error 500

**URL:** <https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960>\
**Category:** Product Support\
**Created:** [December 10, 2019, 10:28am UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960 "2019-12-10T10:28:19Z")\
**Posts on this page:** 19\
**Page:** 1

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 10, 2019, 10:28am UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/1 "2019-12-10T10:28:19Z")

</div>

**Your software**  
My Mautic version is: 2.15.1  
My PHP version is: 7x

**Your problem**  
My problem is:  
mautic dashboard update to latest version failed at step 3 or 4 causing a 500 error  
[https://mautic.designdiverso.com/](https://mautic.designdiverso.com/)

 ![Screenshot 2019-12-10 at 11.59.15](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/c/c7bf61c446bf7bf18b49d7d551bb0e34657e6191.jpeg)

These errors are showing in the log:

Steps I have tried to fix the problem: none so far

Just wondering is there a way I can fix this not being myself a programmer?

---

<div class="post-metadata">

**Author:** ![dirk\_s](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dirk_s/32/748_2.png) [@dirk\_s](https://forum.mautic.org/u/dirk_s)\
**Post date:** [December 16, 2019, 9:46pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/2 "2019-12-16T21:46:58Z")

</div>

Looks very much like a failed database migration. Did you run the upgrade through shell or through the webinterface? In one case we supported, it was one single database issue, that could have been fixed with one single SQL statement 😉

Could you please look into your logs?

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 16, 2019, 10:12pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/3 "2019-12-16T22:12:00Z")

</div>

Hi thank you for your comment, as I mentioned in my post Ive updated using the dashboard feature.

Now we managed to somehow patch it up by removing the /app/cache content.

We are back up, however for some unknown reason I can’t access the components \> forms section anymore, and on top of that I can’t seem to be able to send emails at all using the emails feature.

Here is the log [https://slack-files.com/TFWQ1U3EX-FRR22662G-6174c66cae](https://slack-files.com/TFWQ1U3EX-FRR22662G-6174c66cae)

Any thoughts on how to fix this very welcome!

---

<div class="post-metadata">

**Author:** ![Yosu\_Cadilla](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/yosu_cadilla/32/6206_2.png) [@Yosu\_Cadilla](https://forum.mautic.org/u/Yosu_Cadilla)\
**Post date:** [December 17, 2019, 12:11pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/4 "2019-12-17T12:11:06Z")

</div>

Hello @tancredi start by following this tutorial, hopefully it will fix the issue, come back if it doesn’t:

> **[How to Successfully Update your Own Mautic Self-Hosted](https://mauteam.org/mautic/mautic-admins/mautic-update-how-to-dont-click-that-button/)**
>
> Flawless Mautic upgrades every time, a simple step by step guide… Check the health of your Mautic installation, you might have an incomplete Mautic update!

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 20, 2019, 1:19pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/5 "2019-12-20T13:19:45Z")

</div>

thank you for sharing your article, the issue is we are not sure how to proceed.

Shall we upload previous version as 2.15.3 seems rather buggy, (we noticed we are not the only ones facing these issues) [https://github.com/mautic/mautic/issues?utf8=✓&q=is:issue+2.15.3](https://github.com/mautic/mautic/issues?utf8=%E2%9C%93&q=is:issue+2.15.3)

Shall we go back to 2.15.1? or try again uploading the latest 2.15.3 via ftp?

how can I do that as I’m not myself a programmer, can I just download the version from your article and then upload it to server via ftp?

---

<div class="post-metadata">

**Author:** ![roye](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/roye/32/510_2.png) [@roye](https://forum.mautic.org/u/roye)\
**Post date:** [December 20, 2019, 3:12pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/6 "2019-12-20T15:12:30Z")

</div>

Can you check if you have the following file, and show us the permissions on it.

/home/admin/web/mautic.designdiverso.com/public\_html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticPluginBundleEntityPlugin.php

---

<div class="post-metadata">

**Author:** ![josevi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/josevi/32/636_2.png) [@josevi](https://forum.mautic.org/u/josevi)\
**Post date:** [December 20, 2019, 5:57pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/7 "2019-12-20T17:57:16Z")

</div>

Hi

I had the same problem and finally I solved it  
I restored a copy of the mautic folder and the database again  
to version 2.15.0

edit the user.ini file of the mautic root  
and added these lines  
max\_execution\_time = 120

the problem is that there is not enough time to clear the cache  
I updated again and everything was correct

I hope it serves

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 20, 2019, 7:18pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/8 "2019-12-20T19:18:38Z")

</div>

> [@roye](#):
>
> /home/admin/web/mautic.designdiverso.com/public\_html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticPluginBundleEntityPlugin.php

yes I can see that file no idea how to show you the permissions on it though

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 20, 2019, 7:20pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/9 "2019-12-20T19:20:44Z")

</div>

so do you guys recommend to roll back to 2.15.0?

Can you please be so kind and let me know how to do it exactly via ftp?

How can I roll back to previous version without erasing all our forms and data?

Unfortunately don’t have a backup from prior the incident as is been already a week.

---

<div class="post-metadata">

**Author:** ![roye](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/roye/32/510_2.png) [@roye](https://forum.mautic.org/u/roye)\
**Post date:** [December 20, 2019, 8:49pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/10 "2019-12-20T20:49:01Z")

</div>

Clear the cache  
There are several ways to do that. The easiest is to go to the /app/cache folder and delete its content. If you want to do it via CLI command, navigate to the Mautic root folder and run rm -rf app/cache/\*. The new cache files will generate itself after the next Mautic refresh in the browser.

It might happen that the files won’t generate itself. It can be caused by the wrong folder permission and Mautic doesn’t have permission to write the new cache files. Contact your sysadmin and ask them to fix it for you.

Tip: Don’t execute Mautic commands as the root user yourself and do not run Mautic commands in the root crontab. This way all the files which will be created by the command will have the root as the author and Mautic won’t be able to rewrite those files.

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 20, 2019, 11:19pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/11 "2019-12-20T23:19:08Z")

</div>

Ive already tried step 1 delete cache though it doesn’t fix it.

ok assuming I can’t get hold of my sysadmin atm, how can I fix these permissions? Which ones shall I fix?

Here is the permission on that folder  
/home/admin/web/mautic.designdiverso.com/public\_html/app/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticPluginBundleEntityPlugin.php

 ![Screenshot 2019-12-20 at 21.21.59](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/a/a6dd7817a51f4a3764ba416283829ff546f396a1.png)

from my ftp client

---

<div class="post-metadata">

**Author:** ![roye](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/roye/32/510_2.png) [@roye](https://forum.mautic.org/u/roye)\
**Post date:** [December 21, 2019, 1:59am UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/12 "2019-12-21T01:59:24Z")

</div>

The permissions are fine.

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 21, 2019, 11:14am UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/13 "2019-12-21T11:14:08Z")

</div>

so what else shall I fix in order to get rid of those bugs?

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 21, 2019, 4:04pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/14 "2019-12-21T16:04:07Z")

</div>

can you please provide some other thoughts on how to actually fix these bugs?

I’m stuck here, backup prior incident on server is expired as it lasts only one week.

I need to fix these bugs without wiping off our current setup (forms and other data)

Here is our site where you can see the missing forms [designdiverso.com](http://designdiverso.com)

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 21, 2019, 4:08pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/15 "2019-12-21T16:08:36Z")

</div>

Ive been trying to look for that file, can’t find it though, do you know where is it located?

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 22, 2019, 12:30pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/16 "2019-12-22T12:30:37Z")

</div>

I don’t understand why these two bugs have been closed if they are still there:

1 - [https://github.com/mautic/mautic/issues/8199](https://github.com/mautic/mautic/issues/8199)  
2 - [https://github.com/mautic/mautic/issues/8136](https://github.com/mautic/mautic/issues/8136)

We’ve also tried rebooting the server it didnt work we still got same error when trying to access forms

 ![2019-12-22_14-45-18](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/5/50a30eea7a6f1608641de006f6c490ecc457672d.jpeg)

---

<div class="post-metadata">

**Author:** ![josevi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/josevi/32/636_2.png) [@josevi](https://forum.mautic.org/u/josevi)\
**Post date:** [December 23, 2019, 5:16pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/17 "2019-12-23T17:16:19Z")

</div>

Hi  
Check that the permissions of the mautic root folder are 755  
and that the cache is 755

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [December 24, 2019, 3:01pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/18 "2019-12-24T15:01:01Z")

</div>

we’ve managed to downgrade to 2.15.1 wasn’t that easy fight but in the end we prevailed.

I personally believe that open source sometimes can be tricky, for instance when a new buggy update is introduced there should a notification, somewhere within dashboard, mentioning (upgrade at your own risk) or something like that.

This way would really be fair…

---

<div class="post-metadata">

**Author:** ![dirk\_s](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dirk_s/32/748_2.png) [@dirk\_s](https://forum.mautic.org/u/dirk_s)\
**Post date:** [January 6, 2020, 3:33pm UTC](https://forum.mautic.org/t/mautic-latest-2-15-3-update-failed-causing-error-500/11960/19 "2020-01-06T15:33:54Z")

</div>

Actually I had this happening as well. The situation is, that some database migrations worked - while one SQL statement is missing.

In my case, upgrading Mautic on shell didn’t work properly due to the bad hosting environment.  
There was one database migration missing:

ALTER TABLE forms ADD form\_attr VARCHAR(255) DEFAULT NULL

You might want to check, if that column exists.
