# Mautic stops fetching GeoLite2 data

**URL:** <https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626>\
**Category:** Product Support\
**Created:** [November 12, 2019, 3:03pm UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626 "2019-11-12T15:03:22Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![bulgin](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bulgin/32/1001_2.png) [@bulgin](https://forum.mautic.org/u/bulgin)\
**Post date:** [November 12, 2019, 3:03pm UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/1 "2019-11-12T15:03:23Z")

</div>

**Your software**  
My Mautic version is: 2.15.3  
My PHP version is: 7.2.24

**Your problem**  
My problem is:  
Mautic has stopped fetching GeoLite2 data. Whenever I request an update on the configuration settings page, the wheel just keeps turning and turning.

POSSIBLE CULPRIT: This install of Mautic was a new install in a new directory and the old install was completely deleted. However, I see in the logs that mautic is somehow referencing the old install and the clue was the “joomla” reference. Somehow, the new install is still referencing a single old directory path. However, those directories are now gone and where gone when I installed the new install.

Additionally, I can’t find information anywhere on the location on my server where these files are stored so I could attempt some troubleshooting. It would be nice to have a readily available tech note somewhere on where these files are stored, how a user might manually download and troubleshoot.  
Thank you.

These errors are showing in the log: most recent after request for GeoLite2:

DON’T KNOW WHY JOOMLA IS LISTED IN THE ERROR LOGS BELOW - THERE ARE OTHER JOOMLA DIRECTORIES BUT NOT WHERE MAUTIC IS INSTALLED:

[2019-11-12 09:57:07] mautic.ERROR: PHP Error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 29353872 bytes) - in file /home/xxxx/public\_html/XXXXXX.com/vendor/joomla/http/src/Transport/Curl.php - at line 222    
[2019-11-12 09:57:07] mautic.ERROR: Symfony\Component\Debug\Exception\OutOfMemoryException: Error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 29353872 bytes) - in file /home/xxxx/public\_html/xxxxxx.com/vendor/joomla/http/src/Transport/Curl.php - at line 222    
[2019-11-12 09:57:07] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\OutOfMemoryException: “Error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 29353872 bytes)” at /home/xxxx/public\_html/xxxxx.com/vendor/joomla/http/src/Transport/Curl.php line 222 {“exception”:"[object] (Symfony\Component\Debug\Exception\OutOfMemoryException(code: 0): Error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 29353872 bytes) at /home/xxxxx/public\_html/xxxx.com/vendor/joomla/http/src/Transport/Curl.php:222)"}

Steps I have tried to fix the problem: attempt to locate geolite data and troubleshoot and examine logs.

---

<div class="post-metadata">

**Author:** ![MxyzptlkFishStix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mxyzptlkfishstix/32/1132_2.png) [@MxyzptlkFishStix](https://forum.mautic.org/u/MxyzptlkFishStix)\
**Post date:** [November 12, 2019, 5:46pm UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/2 "2019-11-12T17:46:22Z")

</div>

Increase PHP’s memory limit. You’re running out of memory.

Example: `memory_limit = ???M`

---

<div class="post-metadata">

**Author:** ![bulgin](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bulgin/32/1001_2.png) [@bulgin](https://forum.mautic.org/u/bulgin)\
**Post date:** [December 21, 2019, 1:44am UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/3 "2019-12-21T01:44:26Z")

</div>

That worked. thanks for tip.

---

<div class="post-metadata">

**Author:** ![deejames](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/deejames/32/677_2.png) [@deejames](https://forum.mautic.org/u/deejames)\
**Post date:** [February 9, 2020, 11:53am UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/4 "2020-02-09T11:53:15Z")

</div>

I setup account at Maxmind for the geoip database geolite2-city; got License key and account/user ID

This is where Mautic says I should get the file:  
[http://geolite.maxmind.com/download/geoip/database/geolite2-city.mmdb.gz](http://geolite.maxmind.com/download/geoip/database/geolite2-city.mmdb.gz)

Below are the databases Maxmind lists to download. So Which of these database do I download?

|GeoLite2-ASN|GeoLite2 ASN|GeoIP2 Binary (APIs)|2020-02-04|GZIP (MD5)|  
|GeoLite2-ASN-CSV|GeoLite2 ASN: CSV Format|GeoIP2 CSV (docs)|2020-02-04|ZIP (MD5)|  
|GeoLite2-City|GeoLite2 City|GeoIP2 Binary (APIs)|2020-02-04|GZIP (MD5)|  
|GeoLite2-City-CSV|GeoLite2 City: CSV Format|GeoIP2 CSV (docs)|2020-02-04|ZIP (MD5)|  
|GeoLite2-Country|GeoLite2 Country|GeoIP2 Binary (APIs)|2020-02-04|GZIP (MD5)|  
|GeoLite2-Country-CSV|GeoLite2 Country: CSV Format|GeoIP2 CSV (docs)|2020-02-04|ZIP (MD5)|

---

<div class="post-metadata">

**Author:** ![Yosu\_Cadilla](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/yosu_cadilla/32/6206_2.png) [@Yosu\_Cadilla](https://forum.mautic.org/u/Yosu_Cadilla)\
**Post date:** [February 9, 2020, 3:15pm UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/5 "2020-02-09T15:15:26Z")

</div>

I have recently created a step by step guide to help Mautic users with the Madmind GeoIP and Geolite2 automated database updates.

> **[\[Solved\] Maxmind GeoLite2 & GeoIP Database Auto-Update | 2020](https://mauteam.org/mautic/mautic-admins/solved-maxmind-geolite2-database-not-updating/)**
>
> Maxmind has changed the method to update GeoLite2 & GeoIP databases, it now requires you to provide your credentials. See how to solve this on any Linux server.

Hope it helps…

---

<div class="post-metadata">

**Author:** ![tancredi](https://avatars.discourse-cdn.com/v4/letter/t/b3f665/32.png) [@tancredi](https://forum.mautic.org/u/tancredi)\
**Post date:** [February 18, 2022, 8:37am UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/6 "2022-02-18T08:37:26Z")

</div>

Is this solution still working in 2022?

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 21, 2022, 12:40pm UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/7 "2022-02-21T12:40:14Z")

</div>

Please read the official documentation:

> **[Maxmind license](https://docs.mautic.org/en/setup/maxmind-license)**
>
> . From the 2.16 release, Mautic has supported using a license key to access the MaxMind IP lookup service.. . . . From the 3.2 release the format for the license key needs to be AccountID:Licensekey. You can locate the Account ID directly preceding...

---

<div class="post-metadata">

**Author:** ![silavapi](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/silavapi/32/7424_2.png) [@silavapi](https://forum.mautic.org/u/silavapi)\
**Post date:** [February 21, 2022, 12:40pm UTC](https://forum.mautic.org/t/mautic-stops-fetching-geolite2-data/11626/8 "2022-02-21T12:40:16Z")

</div>


