# Migrate to another server

**URL:** https://forum.mautic.org/t/migrate-to-another-server/21044
**Category:** Mautic 4 Install/Upgrade Support
**Created:** [September 27, 2021, 7:45pm UTC](https://forum.mautic.org/t/migrate-to-another-server/21044 "2021-09-27T19:45:58Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![succes33](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/succes33/32/2867_2.png) [@succes33](https://forum.mautic.org/u/succes33)
#### Post date: [September 27, 2021, 7:45pm UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/1 "2021-09-27T19:45:58Z")

</div>

**Your software**  
_My PHP version is_ : 7.4  
\*My MySQL: 8.0.26  
**Updating/Installing Errors**  
\*I am Installing  
_Upgrading/installing via_ : Web

display\_errors = Off  
max\_execution\_time = 120  
max\_input\_time = 300  
max\_input\_vars = 10000  
memory\_limit = 512M  
post\_max\_size = 8M  
session.gc\_maxlifetime = 1440  
session.save\_path = “/var/cpanel/php/sessions/ea-php74”  
upload\_max\_filesize = 2M  
zlib.output\_compression = Off

_These errors are showing in the Mautic log_ :

**Your problem**  
_My problem is_ :

Hi I have a problem: I have an installation with version 4.0 I have saved the files and a copy of the database. On another server with another domain I have uploaded the files, created a database and imported the one from the other account. I modified the local.php file with the name and pass of the new database.  
In short, everything seems to be fine. All the necessary steps to move an installation to another server with another domain.

Login without problem. But after a few minutes I log out and log in again and the browser shows error 524 time out.

And I don’t know what to do to solve it.

---

<div class="post-metadata">

### Author: ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)
#### Post date: [September 27, 2021, 10:46pm UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/2 "2021-09-27T22:46:32Z")

</div>

Look at the local.php file to update all the URLS. Cache,Logs ect. Then clear the cache and verify file permissions are correct.

---

<div class="post-metadata">

### Author: ![succes33](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/succes33/32/2867_2.png) [@succes33](https://forum.mautic.org/u/succes33)
#### Post date: [September 28, 2021, 7:52am UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/3 "2021-09-28T07:52:17Z")

</div>

Hello, thank you very much for the reply.

Yes all that I have done, the local.php file is modified, cache cleared, etc.  
The question is that after doing all that, you can access you can navigate through the contacts menu, desktop, etc… But when you go to enter the section on the right where the settings and everything else is blocked. And from that first lock, and always appears error 524 time out.

---

<div class="post-metadata">

### Author: ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)
#### Post date: [September 28, 2021, 1:07pm UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/4 "2021-09-28T13:07:16Z")

</div>

Hi, btw did you use Redis?

---

<div class="post-metadata">

### Author: ![succes33](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/succes33/32/2867_2.png) [@succes33](https://forum.mautic.org/u/succes33)
#### Post date: [September 28, 2021, 3:34pm UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/5 "2021-09-28T15:34:43Z")

</div>

Hi, thank you very much for the reply and the interest.

I am not using redis.  
What I see is that if I install from startup with the version 4.0.0.0 package everything installs correctly.

But if I upgrade from a previous version, or simply in version 4 I reinstall it in another domain, following all the necessary steps (local.php, import DB, add folder with the files, clean cache, etc.) It does not work.  
It only works fine if you install version 4 clean from the beginning. If not, what happens is what I explained in the problem above.

---

<div class="post-metadata">

### Author: ![joeyk](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/joeyk/32/11164_2.png) [@joeyk](https://forum.mautic.org/u/joeyk)
#### Post date: [September 29, 2021, 11:14am UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/6 "2021-09-29T11:14:34Z")

</div>

One more question: DB version is the same?

---

<div class="post-metadata">

### Author: ![succes33](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/succes33/32/2867_2.png) [@succes33](https://forum.mautic.org/u/succes33)
#### Post date: [September 29, 2021, 1:09pm UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/7 "2021-09-29T13:09:47Z")

</div>

Yes, it is.

**Your software**  
_My PHP version is_ : 7.4  
\*My MySQL: 8.0.26  
[/quote]

---

<div class="post-metadata">

### Author: ![succes33](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/succes33/32/2867_2.png) [@succes33](https://forum.mautic.org/u/succes33)
#### Post date: [October 4, 2021, 11:45pm UTC](https://forum.mautic.org/t/migrate-to-another-server/21044/8 "2021-10-04T23:45:08Z")

</div>

I have done many tests, and what I see is that if I install the application on a new hosting it works.

But if I perform a migration from another installation, or update the new installation stops working. And I have the problem that I have commented in the previous messages.

This is what is in var/log/mautic\_prod-2021-10-04.php

[2021-10-04 22:05:34] mautic.WARNING: PHP Warning - require(/home/veroglx7em/public\_html/var/cache/prod/ContainerSPiMbI1/getSwiftmailer\_EmailSender\_ListenerService.php): failed to open stream: No such file or directory - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerSPiMbI1/appAppKernelProdContainer.php - at line 2225 {“file”:“getSwiftmailer\_EmailSender\_ListenerService.php”,“lazyLoad”:true}   
[2021-10-04 22:05:34] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerSPiMbI1/getSwiftmailer\_EmailSender\_ListenerService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerSPiMbI1/appAppKernelProdContainer.php - at line 2225    
[2021-10-04 22:05:34] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerSPiMbI1/getSwiftmailer\_EmailSender\_ListenerService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerSPiMbI1/appAppKernelProdContainer.php - at line 2225    
[2021-10-04 22:48:56] mautic.WARNING: PHP Warning - require(/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getMautic\_Form\_Type\_FormconfigService.php): failed to open stream: No such file or directory - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227 {“file”:“getMautic\_Form\_Type\_FormconfigService.php”,“lazyLoad”:true}   
[2021-10-04 22:48:56] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getMautic\_Form\_Type\_FormconfigService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getMautic\_Form\_Type\_FormconfigService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.WARNING: PHP Warning - require(/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php): failed to open stream: No such file or directory - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227 {“file”:“getRouting\_LoaderService.php”,“lazyLoad”:true}   
[2021-10-04 22:48:56] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.WARNING: PHP Warning - require(/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php): failed to open stream: No such file or directory - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227 {“file”:“getRouting\_LoaderService.php”,“lazyLoad”:true}   
[2021-10-04 22:48:56] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.WARNING: PHP Warning - require(/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php): failed to open stream: No such file or directory - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227 {“file”:“getRouting\_LoaderService.php”,“lazyLoad”:true}   
[2021-10-04 22:48:56] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.WARNING: PHP Warning - require(/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php): failed to open stream: No such file or directory - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227 {“file”:“getRouting\_LoaderService.php”,“lazyLoad”:true}   
[2021-10-04 22:48:56] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227    
[2021-10-04 22:48:56] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/getRouting\_LoaderService.php’ (include\_path=’.:/opt/cpanel/ea-php74/root/usr/share/pear’) - in file /home/veroglx7em/public\_html/var/cache/prod/ContainerN57Y2bR/appAppKernelProdContainer.php - at line 2227
