# Multiple errors with two fresh installations of 3.1.1

**URL:** <https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420>\
**Category:** Product Support\
**Created:** [October 4, 2020, 2:46am UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420 "2020-10-04T02:46:02Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![zach](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/zach/32/3526_2.png) [@zach](https://forum.mautic.org/u/zach)\
**Post date:** [October 4, 2020, 2:46am UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/1 "2020-10-04T02:46:02Z")

</div>

**Your software**  
My Mautic version is: 3.1.1  
My PHP version is: 7.2

**Your problem**  
My problem is:

I have two instances of Mautic running on my VPS. One was installed via Softaculous on Cpanel, the other was installed manually.

- Neither instance shows a directory for /apps/cache or /apps/logs when I am going through directories via FTP

- I get a persistent error when I try go to/update/schema on both installations.

- Both sites return this error when I try to connect to Zapier:

- I only see two plugins available: OneSignal and Twilio

These errors are showing in the log:  
[2020-10-04 01:28:53] mautic.NOTICE: Doctrine\DBAL\DBALException: Unknown database type json requested, Doctrine\DBAL\Platforms\MySqlPlatform may not support it. (uncaught exception) at /home/sofosadmin/go.sofosinvestments.com/vendor/doctrine/dbal/lib/Doctrine/DBAL/Platforms/AbstractPlatform.php line 436 while running console command `doctrine:migrations:migrate`    
[2020-10-04 01:28:53] mautic.WARNING: Command `doctrine:migrations:migrate` exited with status code 1    
[2020-10-04 01:28:53] mautic.ERROR: [UPGRADE ERROR] Exit code 1; Mautic Migrations \ Migrating up to 20200815153711 from 0 Migration 20181111095447 failed during Pre-Checks. Error Unknown database type json requested, Doctrine\DBAL\Platforms\MySqlPlatform may not support it. \ In AbstractPlatform.php line 436: \ Unknown database type json requested, Doctrine\DBAL\Platforms\MySqlPlatform may not support it. \ doctrine:migrations:migrate [–write-sql [WRITE-SQL]] [–dry-run] [–query-time] [–allow-no-migration] [–all-or-nothing [ALL-OR-NOTHING]] [–configuration [CONFIGURATION]] [–db-configuration [DB-CONFIGURATION]] [–db DB] [–em EM] [–shard SHARD] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-e|–env ENV] [–no-debug] [–] \    
[2020-10-04 02:37:31] mautic.NOTICE: Doctrine\DBAL\DBALException: Unknown database type json requested, Doctrine\DBAL\Platforms\MySqlPlatform may not support it. (uncaught exception) at /home/sofosadmin/go.sofosinvestments.com/vendor/doctrine/dbal/lib/Doctrine/DBAL/Platforms/AbstractPlatform.php line 436 while running console command `doctrine:migrations:migrate`    
[2020-10-04 02:37:31] mautic.WARNING: Command `doctrine:migrations:migrate` exited with status code 1    
[2020-10-04 02:37:31] mautic.ERROR: [UPGRADE ERROR] Exit code 1; Mautic Migrations \ Migrating u

Steps I have tried to fix the problem:

I have scoured the forums, I cleared the cache via command line, I tried to migrate the DB (which led to me doing the manual installation), etc.

Is there a more stable version of 3 I can use until 3.1.1 is fixed or does anyone have a clue what could be causing my problems?

Thanks in advance!

---

<div class="post-metadata">

**Author:** ![frankofno](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/frankofno/32/3455_2.png) [@frankofno](https://forum.mautic.org/u/frankofno)\
**Post date:** [October 4, 2020, 11:24am UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/2 "2020-10-04T11:24:36Z")

</div>

with version 3 the cache folder moved from mautic/app/cache -\> mautic/var/cache

looks like your database needs to be upgraded.

---

<div class="post-metadata">

**Author:** ![zach](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/zach/32/3526_2.png) [@zach](https://forum.mautic.org/u/zach)\
**Post date:** [October 4, 2020, 2:12pm UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/3 "2020-10-04T14:12:21Z")

</div>

Hi Frank,

I did find those directories and I cleared them, but it didn’t fix the issue with Zapier.

I tried to update the Softaculous installation through the command line (the logs I included are from the Softaculous install).

The manual installation does not have that error. But it does give me the same error for Zapier. Is it possible I am missing a cronjob?

---

<div class="post-metadata">

**Author:** ![frankofno](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/frankofno/32/3455_2.png) [@frankofno](https://forum.mautic.org/u/frankofno)\
**Post date:** [October 4, 2020, 4:54pm UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/4 "2020-10-04T16:54:02Z")

</div>

have you tried this?

> <https://stackoverflow.com/questions/41345893/command-doctrinemigrationsmigrate-error>

---

<div class="post-metadata">

**Author:** ![EJL](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ejl/32/12155_2.png) [@EJL](https://forum.mautic.org/u/EJL)\
**Post date:** [October 4, 2020, 6:06pm UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/5 "2020-10-04T18:06:45Z")

</div>

For whatever reason, Mautic installs performed by Softaculous seem prone to issues. Even similar to what you described.

What version of MySQL or MariaDB are you using? I was using MariaDB 10.1 and had similar issues until I upgraded to 10.3

---

<div class="post-metadata">

**Author:** ![zach](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/zach/32/3526_2.png) [@zach](https://forum.mautic.org/u/zach)\
**Post date:** [October 4, 2020, 7:05pm UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/6 "2020-10-04T19:05:17Z")

</div>

I did not, but I am bookmarking it, thank you. I ended up doing a third install and had my install PHP 7.3 on that instance. I am running these installs on a subdomain and using PHP 7.4 for a Wordpess install.

I no longer have any error logs showing (in the logs under the menu for Configuration/System) but I still can’t get Zapier to connect.

I have tried turning off the API settings and then connecting with Zapier and I get a different error message related to having those options disabled. I have a ticket in with Zapier in case it is on there end.

---

<div class="post-metadata">

**Author:** ![zach](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/zach/32/3526_2.png) [@zach](https://forum.mautic.org/u/zach)\
**Post date:** [October 4, 2020, 7:07pm UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/7 "2020-10-04T19:07:29Z")

</div>

Hi EJL,

I am running MySQL 5.7. I don’t get an option to install with Maria when running Softaculous.

I reinstalled with Softaculous and used PHP 7.3 instead of 7.2. It seems to have resolved the database error.

---

<div class="post-metadata">

**Author:** ![dennisameling](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/dennisameling/32/958_2.png) [@dennisameling](https://forum.mautic.org/u/dennisameling)\
**Post date:** [November 24, 2020, 11:48am UTC](https://forum.mautic.org/t/multiple-errors-with-two-fresh-installations-of-3-1-1/16420/8 "2020-11-24T11:48:10Z")

</div>

We’ve fixed this bug with MySQL 5.7 (`Unknown database type json requested`) in Mautic 3.2, to be released on **November 30**. The fix will only apply to **new** installations and to installations that don’t have `db_server_version` in their `app/config/local.php` yet (this is the case if you haven’t changed the default configuration in Mautic’s UI before). Otherwise you have to change the version in `app/config/local.php` yourself, as mentioned in [Mautic 3.1.2 installed - Plugins are not available](https://forum.mautic.org/t/mautic-3-1-2-installed-plugins-are-not-available/17003/3).

Apologies for the inconvenience and thanks for reporting this!
