# New Install - 500 Error on 3rd step - mailer\_sparkpost\_region

**URL:** <https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114>\
**Category:** Mautic 4 Install/Upgrade Support\
**Created:** [August 21, 2022, 3:21am UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114 "2022-08-21T03:21:00Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![patbhakta](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/patbhakta/32/6592_2.png) [@patbhakta](https://forum.mautic.org/u/patbhakta)\
**Post date:** [August 21, 2022, 3:21am UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114/1 "2022-08-21T03:21:00Z")

</div>

**Your software** Mautic 4.4.latest  
_My PHP version is_ : 7.4  
_My MySQL/MariaDB version is_ : MySQL/MariaDB version 10.3.34

**Updating/Installing Errors**  
_I am_ : Installing  
_Installing via_ : Command Line

_These errors are showing in the installer_ :

_These errors are showing in the Mautic log_ :  
[2022-08-21 00:56:01] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException: “Neither the property “mailer\_sparkpost\_region” nor one of the methods “getMailerSparkpostRegion()”, “mailerSparkpostRegion()”, “isMailerSparkpostRegion()”, “hasMailerSparkpostRegion()”, “\_\_get()” exist and have public access in class “Mautic\InstallBundle\Configurator\Step\EmailStep”.” at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php line 446 {“exception”:“[object] (Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException(code: 0): Neither the property "mailer\_sparkpost\_region" nor one of the methods "getMailerSparkpostRegion()", "mailerSparkpostRegion()", "isMailerSparkpostRegion()", "hasMailerSparkpostRegion()", "\_\_get()" exist and have public access in class "Mautic\InstallBundle\Configurator\Step\EmailStep". at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php:446)”} {“hostname”:“DATACENTER-02”,“pid”:34372}  
[2022-08-21 00:56:24] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException: “Neither the property “mailer\_sparkpost\_region” nor one of the methods “getMailerSparkpostRegion()”, “mailerSparkpostRegion()”, “isMailerSparkpostRegion()”, “hasMailerSparkpostRegion()”, “\_\_get()” exist and have public access in class “Mautic\InstallBundle\Configurator\Step\EmailStep”.” at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php line 446 {“exception”:“[object] (Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException(code: 0): Neither the property "mailer\_sparkpost\_region" nor one of the methods "getMailerSparkpostRegion()", "mailerSparkpostRegion()", "isMailerSparkpostRegion()", "hasMailerSparkpostRegion()", "\_\_get()" exist and have public access in class "Mautic\InstallBundle\Configurator\Step\EmailStep". at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php:446)”} {“hostname”:“DATACENTER-02”,“pid”:34366}  
[2022-08-21 02:04:08] mautic.NOTICE: LogicException: DoctrineMetadataCacheWarmer must load metadata first, check priority of your warmers. (uncaught exception) at /var/www/html/lemming/vendor/doctrine/doctrine-bundle/CacheWarmer/DoctrineMetadataCacheWarmer.php line 47 while running console command `cache:warmup` {“hostname”:“DATACENTER-02”,“pid”:3516}  
[2022-08-21 02:04:08] mautic.WARNING: Command `cache:warmup` exited with status code 1 {“hostname”:“DATACENTER-02”,“pid”:3516}  
[2022-08-21 02:07:56] mautic.WARNING: PHP Warning - require(/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php): failed to open stream: No such file or directory - in file /var/www/html/lemming/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 197 {“className”:“Mautic\UserBundle\Entity\Role”,“classMetadata”:“[object] (Doctrine\ORM\Mapping\ClassMetadata: Doctrine\ORM\Mapping\ClassMetadataInfo@1654)”,“proxyClassName”:“Proxies\ **CG** \Mautic\UserBundle\Entity\Role”,“fileName”:“/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php”} {“hostname”:“DATACENTER-02”,“pid”:3510}  
[2022-08-21 02:07:56] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=‘.:/usr/share/php’) - in file /var/www/html/lemming/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 197 {“hostname”:“DATACENTER-02”,“pid”:3510}  
[2022-08-21 02:07:56] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=‘.:/usr/share/php’) - in file /var/www/html/lemming/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 197 {“hostname”:“DATACENTER-02”,“pid”:3510}  
[2022-08-21 02:08:05] mautic.WARNING: PHP Warning - require(/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php): failed to open stream: No such file or directory - in file /var/www/html/lemming/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 197 {“className”:“Mautic\UserBundle\Entity\Role”,“classMetadata”:“[object] (Doctrine\ORM\Mapping\ClassMetadata: Doctrine\ORM\Mapping\ClassMetadataInfo@1653)”,“proxyClassName”:“Proxies\ **CG** \Mautic\UserBundle\Entity\Role”,“fileName”:“/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php”} {“hostname”:“DATACENTER-02”,“pid”:34703}  
[2022-08-21 02:08:05] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=‘.:/usr/share/php’) - in file /var/www/html/lemming/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 197 {“hostname”:“DATACENTER-02”,“pid”:34703}  
[2022-08-21 02:08:05] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required ‘/var/www/html/lemming/var/cache/prod/doctrine/orm/Proxies/\_\_CG\_\_MauticUserBundleEntityRole.php’ (include\_path=‘.:/usr/share/php’) - in file /var/www/html/lemming/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 197 {“hostname”:“DATACENTER-02”,“pid”:34703}  
[2022-08-21 02:15:55] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException: “Neither the property “mailer\_sparkpost\_region” nor one of the methods “getMailerSparkpostRegion()”, “mailerSparkpostRegion()”, “isMailerSparkpostRegion()”, “hasMailerSparkpostRegion()”, “\_\_get()” exist and have public access in class “Mautic\InstallBundle\Configurator\Step\EmailStep”.” at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php line 446 {“exception”:“[object] (Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException(code: 0): Neither the property "mailer\_sparkpost\_region" nor one of the methods "getMailerSparkpostRegion()", "mailerSparkpostRegion()", "isMailerSparkpostRegion()", "hasMailerSparkpostRegion()", "\_\_get()" exist and have public access in class "Mautic\InstallBundle\Configurator\Step\EmailStep". at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php:446)”} {“hostname”:“DATACENTER-02”,“pid”:34703}  
[2022-08-21 02:34:03] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException: “Neither the property “mailer\_sparkpost\_region” nor one of the methods “getMailerSparkpostRegion()”, “mailerSparkpostRegion()”, “isMailerSparkpostRegion()”, “hasMailerSparkpostRegion()”, “\_\_get()” exist and have public access in class “Mautic\InstallBundle\Configurator\Step\EmailStep”.” at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php line 446 {“exception”:“[object] (Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException(code: 0): Neither the property "mailer\_sparkpost\_region" nor one of the methods "getMailerSparkpostRegion()", "mailerSparkpostRegion()", "isMailerSparkpostRegion()", "hasMailerSparkpostRegion()", "\_\_get()" exist and have public access in class "Mautic\InstallBundle\Configurator\Step\EmailStep". at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php:446)”} {“hostname”:“DATACENTER-02”,“pid”:34704}  
[2022-08-21 02:39:28] mautic.ERROR: SCHEMA ERROR: An index with name ‘fax\_search’ was already defined on table ‘leads’. {“hostname”:“DATACENTER-02”,“pid”:3710}  
[2022-08-21 02:39:31] mautic.ERROR: SCHEMA ERROR: An exception occurred while executing ‘SELECT f.alias, f.is\_unique\_identifer as is\_unique, f.type, f.object FROM lead\_fields f WHERE f.object = ‘lead’ ORDER BY f.field\_order ASC’: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘lemming\_db.lead\_fields’ doesn’t exist {“hostname”:“DATACENTER-02”,“pid”:3710}  
[2022-08-21 02:40:47] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException: “Neither the property “mailer\_sparkpost\_region” nor one of the methods “getMailerSparkpostRegion()”, “mailerSparkpostRegion()”, “isMailerSparkpostRegion()”, “hasMailerSparkpostRegion()”, “\_\_get()” exist and have public access in class “Mautic\InstallBundle\Configurator\Step\EmailStep”.” at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php line 446 {“exception”:“[object] (Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException(code: 0): Neither the property "mailer\_sparkpost\_region" nor one of the methods "getMailerSparkpostRegion()", "mailerSparkpostRegion()", "isMailerSparkpostRegion()", "hasMailerSparkpostRegion()", "\_\_get()" exist and have public access in class "Mautic\InstallBundle\Configurator\Step\EmailStep". at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php:446)”} {“hostname”:“DATACENTER-02”,“pid”:34702}  
[2022-08-21 02:46:19] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException: “Neither the property “mailer\_sparkpost\_region” nor one of the methods “getMailerSparkpostRegion()”, “mailerSparkpostRegion()”, “isMailerSparkpostRegion()”, “hasMailerSparkpostRegion()”, “\_\_get()” exist and have public access in class “Mautic\InstallBundle\Configurator\Step\EmailStep”.” at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php line 446 {“exception”:“[object] (Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException(code: 0): Neither the property "mailer\_sparkpost\_region" nor one of the methods "getMailerSparkpostRegion()", "mailerSparkpostRegion()", "isMailerSparkpostRegion()", "hasMailerSparkpostRegion()", "\_\_get()" exist and have public access in class "Mautic\InstallBundle\Configurator\Step\EmailStep". at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php:446)”} {“hostname”:“DATACENTER-02”,“pid”:3510}  
[2022-08-21 02:47:01] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException: “Neither the property “mailer\_sparkpost\_region” nor one of the methods “getMailerSparkpostRegion()”, “mailerSparkpostRegion()”, “isMailerSparkpostRegion()”, “hasMailerSparkpostRegion()”, “\_\_get()” exist and have public access in class “Mautic\InstallBundle\Configurator\Step\EmailStep”.” at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php line 446 {“exception”:“[object] (Symfony\Component\PropertyAccess\Exception\NoSuchPropertyException(code: 0): Neither the property "mailer\_sparkpost\_region" nor one of the methods "getMailerSparkpostRegion()", "mailerSparkpostRegion()", "isMailerSparkpostRegion()", "hasMailerSparkpostRegion()", "\_\_get()" exist and have public access in class "Mautic\InstallBundle\Configurator\Step\EmailStep". at /var/www/html/lemming/vendor/symfony/property-access/PropertyAccessor.php:446)”} {“hostname”:“DATACENTER-02”,“pid”:3594}

**Your problem**  
_My problem is_ :  
I can not get passed the 2nd step due to this mailer\_sparkpost\_region error

_Steps I have tried to fix the problem_ :  
clear cache  
reset permissions for www-data  
php bin/console cache:warmup comes up clear  
php bin/console mautic:assets:generate is ok  
php bin/console mautic.install:data is ok but did generate some other errors  
I set the version of db n local.php  
restart mysql, apache2

I don’t use mailer sparkpost and google turns up nothing on the subject…this is a fresh install

---

<div class="post-metadata">

**Author:** ![techbill](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/techbill/32/8325_2.png) [@techbill](https://forum.mautic.org/u/techbill)\
**Post date:** [August 22, 2022, 1:37pm UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114/2 "2022-08-22T13:37:38Z")

</div>

Look like permission error to me.

I would suggest check your folders’ permission.

---

<div class="post-metadata">

**Author:** ![mhd.jalilvand](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mhd.jalilvand/32/6327_2.png) [@mhd.jalilvand](https://forum.mautic.org/u/mhd.jalilvand)\
**Post date:** [September 1, 2022, 6:24pm UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114/3 "2022-09-01T18:24:15Z")

</div>

I have same issue and solve this problem by adding a missing property

```auto
Mautic\InstallBundle\Configurator\Step\EmailStep:
class EmailStep implements StepInterface
{
...
public $mailer_sparkpost_region;
...

```

---

<div class="post-metadata">

**Author:** ![TheUltimate221144](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/theultimate221144/32/8143_2.png) [@TheUltimate221144](https://forum.mautic.org/u/TheUltimate221144)\
**Post date:** [September 18, 2022, 9:21pm UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114/4 "2022-09-18T21:21:50Z")

</div>

Where exactly was this change made?  
@mhd.jalilvand

I am currently having this issue and would appreciate a fix.

---

<div class="post-metadata">

**Author:** ![mzagmajster](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mzagmajster/32/687_2.png) [@mzagmajster](https://forum.mautic.org/u/mzagmajster)\
**Post date:** [September 18, 2022, 10:25pm UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114/5 "2022-09-18T22:25:25Z")

</div>

did not check it myself, but try:

```auto
mautic/app/bundles/InstallBundle/Configurator/Step/EmailStep.php

```

---

<div class="post-metadata">

**Author:** ![TheUltimate221144](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/theultimate221144/32/8143_2.png) [@TheUltimate221144](https://forum.mautic.org/u/TheUltimate221144)\
**Post date:** [September 18, 2022, 11:17pm UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114/6 "2022-09-18T23:17:17Z")

</div>

Ah excellent. This fixed it for me.  
❤

Thanks

---

<div class="post-metadata">

**Author:** ![mhd.jalilvand](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mhd.jalilvand/32/6327_2.png) [@mhd.jalilvand](https://forum.mautic.org/u/mhd.jalilvand)\
**Post date:** [October 26, 2022, 10:37am UTC](https://forum.mautic.org/t/new-install-500-error-on-3rd-step-mailer-sparkpost-region/25114/7 "2022-10-26T10:37:23Z")

</div>

> [@mzagmajster](#):
>
> `mautic/app/bundles/InstallBundle/Configurator/Step/EmailStep.php`

As @mzagmajster said, the file is:

```auto
app/bundles/InstallBundle/Configurator/Step/EmailStep.php

```

and also there is PR which solves this problem:  
[Prevents throwing NoSuchPropertyException #11429](https://github.com/mautic/mautic/pull/11429)
