# Other SMTP Issues

**URL:** <https://forum.mautic.org/t/other-smtp-issues/5014>\
**Category:** Product Support\
**Created:** [August 23, 2016, 9:35am UTC](https://forum.mautic.org/t/other-smtp-issues/5014 "2016-08-23T09:35:15Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![globalavs](https://avatars.discourse-cdn.com/v4/letter/g/58956e/32.png) [@globalavs](https://forum.mautic.org/u/globalavs)\
**Post date:** [August 23, 2016, 9:35am UTC](https://forum.mautic.org/t/other-smtp-issues/5014/1 "2016-08-23T09:35:15Z")

</div>

I’ve tried time and again to get this working with external mail providers. This is the second host that i’ve installed Mautic on.  
  
  
  
This happens with both amazon SES and sendgrid. I figured SES was a little too complex for my needs so tried sendgrid.  
  
  
  
“Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] Log data: ++ Starting Swift\_SmtpTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] (code: 0)  
  
++ Starting Swift\_SmtpTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] (code: 0)”  
  
  
  
i’ve checked with the host that all ports are open, tried every configuration of the settings possible and i still get the same error.  
  
ive installed wordpress on another subdomain and installed the sendgrid plugin, that worked first time.  
  
  
  
I don’t have SSH access.  
  
  
  
Any help much appreciated as i’ve almost given up with it.  
  
  
  
[settings](http://imgur.com/lzLXSwt)

---

<div class="post-metadata">

**Author:** ![globalavs](https://avatars.discourse-cdn.com/v4/letter/g/58956e/32.png) [@globalavs](https://forum.mautic.org/u/globalavs)\
**Post date:** [August 23, 2016, 9:35am UTC](https://forum.mautic.org/t/other-smtp-issues/5014/2 "2016-08-23T09:35:15Z")

</div>

I’ve tried time and again to get this working with external mail providers. This is the second host that i’ve installed Mautic on.

This happens with both amazon SES and sendgrid. I figured SES was a little too complex for my needs so tried sendgrid.

“Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] Log data: ++ Starting Swift\_SmtpTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] (code: 0)  
++ Starting Swift\_SmtpTransport !! Connection could not be established with host [smtp.sendgrid.net](http://smtp.sendgrid.net) [Connection timed out #110] (code: 0)”

i’ve checked with the host that all ports are open, tried every configuration of the settings possible and i still get the same error.  
ive installed wordpress on another subdomain and installed the sendgrid plugin, that worked first time.

I don’t have SSH access.

Any help much appreciated as i’ve almost given up with it.

[settings](http://imgur.com/lzLXSwt)

---

<div class="post-metadata">

**Author:** ![caleb.hurd](https://avatars.discourse-cdn.com/v4/letter/c/35a633/32.png) [@caleb.hurd](https://forum.mautic.org/u/caleb.hurd)\
**Post date:** [August 23, 2016, 1:22pm UTC](https://forum.mautic.org/t/other-smtp-issues/5014/3 "2016-08-23T13:22:12Z")

</div>

Have you tried something other than TLS for SendGrid?

Also, have you tried messing around with other ports?

[https://sendgrid.com/docs/Classroom/Basics/Email\_Infrastructure/recommended\_smtp\_settings.html](https://sendgrid.com/docs/Classroom/Basics/Email_Infrastructure/recommended_smtp_settings.html)

```
Use port 25, 2525, or 587 for unencrypted / TLS connections
Use port 465 for SSL connections

```

Here’s a previous ticket that looks like hit the same exact issue: [https://www.mautic.org/community/index.php/1051-sendgrid-connection-error/0](https://www.mautic.org/community/index.php/1051-sendgrid-connection-error/0)

---

<div class="post-metadata">

**Author:** ![globalavs](https://avatars.discourse-cdn.com/v4/letter/g/58956e/32.png) [@globalavs](https://forum.mautic.org/u/globalavs)\
**Post date:** [August 23, 2016, 1:41pm UTC](https://forum.mautic.org/t/other-smtp-issues/5014/4 "2016-08-23T13:41:28Z")

</div>

Like I said, i’ve tried all of the settings. Ive followed all of the online advice, and the fact that sendgrid works fine with a wordpress plugin with the exact same credentials leads me to think the server is ok?

---

<div class="post-metadata">

**Author:** ![caleb.hurd](https://avatars.discourse-cdn.com/v4/letter/c/35a633/32.png) [@caleb.hurd](https://forum.mautic.org/u/caleb.hurd)\
**Post date:** [August 23, 2016, 2:10pm UTC](https://forum.mautic.org/t/other-smtp-issues/5014/5 "2016-08-23T14:10:54Z")

</div>

Would you like for me to private message you an SES username and password so you can test that sending method? If it works I can you walk you through the SES setup… it’s pretty simple (assuming you can make a DNS entry).

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [August 24, 2016, 1:39pm UTC](https://forum.mautic.org/t/other-smtp-issues/5014/6 "2016-08-24T13:39:32Z")

</div>

@globalavs email me at [jninhilario@gmail.com](mailto:jninhilario@gmail.com) i have something that maybe can help you

---

<div class="post-metadata">

**Author:** ![globalavs](https://avatars.discourse-cdn.com/v4/letter/g/58956e/32.png) [@globalavs](https://forum.mautic.org/u/globalavs)\
**Post date:** [August 25, 2016, 5:57am UTC](https://forum.mautic.org/t/other-smtp-issues/5014/7 "2016-08-25T05:57:20Z")

</div>

caleb.hurd that would be useful yes just to test.

MxyzptlkFishStix, i have a wordpress installation on a subdomain on the same server which sends fine using the sendgrid plugin and the same credentials. so im assuming all outgoing ports, permissions, firewalls etc are open as that wouldnt send either would it?

---

<div class="post-metadata">

**Author:** ![globalavs](https://avatars.discourse-cdn.com/v4/letter/g/58956e/32.png) [@globalavs](https://forum.mautic.org/u/globalavs)\
**Post date:** [August 25, 2016, 11:32am UTC](https://forum.mautic.org/t/other-smtp-issues/5014/8 "2016-08-25T11:32:05Z")

</div>

i wasnt using the smtp plugin, i tried and that failed too.  
got in touch my host and they have said the following

Forwarding the mail to SendGrid mail server using a authentication will require exim to setup according to the SendGrid authentication.  
As this is a shared server, it will be applied for all the users…

You need a VPS for this purpose to set a EXIM to send all the mails though mail server.

is that correct, it is beyond my understanding now…

---

<div class="post-metadata">

**Author:** ![ninjoan](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/ninjoan/32/1005_2.png) [@ninjoan](https://forum.mautic.org/u/ninjoan)\
**Post date:** [August 25, 2016, 12:24pm UTC](https://forum.mautic.org/t/other-smtp-issues/5014/9 "2016-08-25T12:24:43Z")

</div>

@globalavs im using Sendgrid in shared hosted without problem…

---

<div class="post-metadata">

**Author:** ![globalavs](https://avatars.discourse-cdn.com/v4/letter/g/58956e/32.png) [@globalavs](https://forum.mautic.org/u/globalavs)\
**Post date:** [August 25, 2016, 5:43pm UTC](https://forum.mautic.org/t/other-smtp-issues/5014/10 "2016-08-25T17:43:40Z")

</div>

thanks for your help, I think i’ll go with option 5 and give up on Mautic altogether and find another way to do what i need to.

Thanks for the help though, i’ve got a little further, and expanded my knowledge at the same time.  
i’m presuming this is why Amazon SES fails as well.

ive got an ec2 instance vps (windows), could i use that?

---

<div class="post-metadata">

**Author:** ![crystal.harris](https://avatars.discourse-cdn.com/v4/letter/c/b38774/32.png) [@crystal.harris](https://forum.mautic.org/u/crystal.harris)\
**Post date:** [August 27, 2016, 10:00am UTC](https://forum.mautic.org/t/other-smtp-issues/5014/11 "2016-08-27T10:00:45Z")

</div>

Getting the same errors.

I’ve switched hosts for my client because his original host told me the same; he’s now on a host that has all outbound SMTP ports open by default, and I am STILL unable to connect via SMTP to any mail service.

Credentials are all good, I’m able to connect via SMTP through any other service; the fact that there are many other people having the same timeout errors regardless of host or SMTP service leads me to believe that this is a problem somewhere in the guts of Mautic, but apparently for only new installs (?). I’m wondering if it was maybe introduced in the 2.0 series? Just speculating, because I’ve gotten it working in the past with no problem. Perhaps it works on upgrade if it was set up before… but on a new install, something goes wonky? Is that possible?

---

<div class="post-metadata">

**Author:** ![crystal.harris](https://avatars.discourse-cdn.com/v4/letter/c/b38774/32.png) [@crystal.harris](https://forum.mautic.org/u/crystal.harris)\
**Post date:** [August 27, 2016, 11:52am UTC](https://forum.mautic.org/t/other-smtp-issues/5014/12 "2016-08-27T11:52:35Z")

</div>

@MxyzptlkFishStix

Host is SiteGround.

Thanks, I’ll try to create an account somehow if I can.
