# PDO extension not working for Mautic

**URL:** <https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351>\
**Category:** Product Support\
**Created:** [October 26, 2016, 3:56am UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351 "2016-10-26T03:56:57Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tony\_Gavin](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tony_gavin/32/2440_2.png) [@Tony\_Gavin](https://forum.mautic.org/u/Tony_Gavin)\
**Post date:** [October 26, 2016, 3:56am UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/1 "2016-10-26T03:56:57Z")

</div>

I have mautic 2.2 up and running and it was working fine. Suddenly I got this error message when attempting to log in:  
  
  
  
Fatal error: Class ‘PDO’ not found in /home/MYDOMAIN/public\_html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php on line 172  
  
  
  
Searching around for this error, Mautic suggested installing the PDO PHP extension, but it already was:  
  
  
  
php -i | grep -i pdo  
  
  
  
PDO  
  
  
  
PDO support =\> enabled  
  
  
  
PDO drivers =\> sqlite, mysql  
  
  
  
I ran the Easy Apache script to disable it and re-enable it, but that didn’t restore the site’s functionality.  
  
  
  
Any ideas?

---

<div class="post-metadata">

**Author:** ![Tony\_Gavin](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tony_gavin/32/2440_2.png) [@Tony\_Gavin](https://forum.mautic.org/u/Tony_Gavin)\
**Post date:** [October 26, 2016, 3:56am UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/2 "2016-10-26T03:56:57Z")

</div>

I have mautic 2.2 up and running and it was working fine. Suddenly I got this error message when attempting to log in:

Fatal error: Class ‘PDO’ not found in /home/MYDOMAIN/public\_html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php on line 172

Searching around for this error, Mautic suggested installing the PDO PHP extension, but it already was:

php -i | grep -i pdo

PDO

PDO support =\> enabled

PDO drivers =\> sqlite, mysql

I ran the Easy Apache script to disable it and re-enable it, but that didn’t restore the site’s functionality.

Any ideas?

---

<div class="post-metadata">

**Author:** ![swip](https://avatars.discourse-cdn.com/v4/letter/s/f475e1/32.png) [@swip](https://forum.mautic.org/u/swip)\
**Post date:** [October 26, 2016, 4:23pm UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/3 "2016-10-26T16:23:51Z")

</div>

If your CLI is running a different version of PHP (most common cause of this type of issue) than what you see on phpinfo(), make sure both versions have the extension installed.

---

<div class="post-metadata">

**Author:** ![Tony\_Gavin](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/tony_gavin/32/2440_2.png) [@Tony\_Gavin](https://forum.mautic.org/u/Tony_Gavin)\
**Post date:** [October 26, 2016, 11:00pm UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/4 "2016-10-26T23:00:34Z")

</div>

Thanks swip.

It turns out that the issue was configuration related. Earlier in the day we’d had Liquid Web support change the date / time of an unrelated website. The technician used a deprecated technique to achieve that change and it affected websites outside of the container in question - that was apparently what caused Mautic to fail. As soon as we addressed it the site went back up again. Odd.

---

<div class="post-metadata">

**Author:** ![latrotech](https://avatars.discourse-cdn.com/v4/letter/l/6f9a4e/32.png) [@latrotech](https://forum.mautic.org/u/latrotech)\
**Post date:** [October 30, 2017, 7:10am UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/5 "2017-10-30T07:10:11Z")

</div>

Hi All,  
I am getting this exact error:

/home/MYDOMAIN/public\_html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php on line 172

I have rebuilt Apache even though I believe all mods where installed, Im stumped. Any help would be appreciated.

Thanks in advance

---

<div class="post-metadata">

**Author:** ![latrotech](https://avatars.discourse-cdn.com/v4/letter/l/6f9a4e/32.png) [@latrotech](https://forum.mautic.org/u/latrotech)\
**Post date:** [October 31, 2017, 11:09pm UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/6 "2017-10-31T23:09:52Z")

</div>

ok so I found my solution, its an obvious one once you read but I thought I would post it to help anyone else that may have the issue. Make sure that you include:

extension = pdo.so  
extension = pdo\_sqlite.so  
extension = pdo\_mysql.so

in you php.ini file

---

<div class="post-metadata">

**Author:** ![bizcrony](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bizcrony/32/409_2.png) [@bizcrony](https://forum.mautic.org/u/bizcrony)\
**Post date:** [November 1, 2017, 8:46am UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/7 "2017-11-01T08:46:07Z")

</div>

@Tony Gavin resolved ?

---

<div class="post-metadata">

**Author:** ![bizcrony](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/bizcrony/32/409_2.png) [@bizcrony](https://forum.mautic.org/u/bizcrony)\
**Post date:** [November 1, 2017, 8:47am UTC](https://forum.mautic.org/t/pdo-extension-not-working-for-mautic/6351/8 "2017-11-01T08:47:42Z")

</div>

> [@26830:@bizcrony](#):
>
> @Tony Gavin resolved ?
