# Php when visiting subdomain/installer gives 404 error

**URL:** <https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521>\
**Category:** Mautic 3 - Install/Upgrade Support\
**Created:** [November 4, 2021, 2:17pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521 "2021-11-04T14:17:15Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![unscrambled](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/unscrambled/32/6152_2.png) [@unscrambled](https://forum.mautic.org/u/unscrambled)\
**Post date:** [November 4, 2021, 2:17pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/1 "2021-11-04T14:17:15Z")

</div>

**Your software**  
_My PHP version is_ : 7.4.2  
_My MariaDB version is_ (delete as applicable): 10.3.31

**Updating/Installing Errors**  
_I am_ : Installing  
_Upgrading/installing via_ / Command Line

_These errors are showing in the installer_ :

(subdomain).mydomain.com/index.php/installer gives 404 error

_These errors are showing in the Mautic log_ :

No Errors showing/no log files

_These errors are showing in the upgrade\_log.txt file (located in the root of your Mautic instance when an upgrade has been attempted - ensure you remove or redact any sensitive data such as domain names in the file path)_ :

No errors showing/no log files  
**Your problem**  
_My problem is_ : When I visit [mautic.mydomain.com](http://mautic.mydomain.com) I get a resolve()); on the screen, but nothing else, and the installer is showing a 404. Verified www-data has all permissions. New to linux/DigitalOcean, but files are all there, and my SuiteCRM is running on the same server. Any ideas where to start?

_Steps I have tried to fix the problem_ :

---

<div class="post-metadata">

**Author:** ![mirash01](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mirash01/32/7762_2.png) [@mirash01](https://forum.mautic.org/u/mirash01)\
**Post date:** [September 19, 2022, 2:48pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/2 "2022-09-19T14:48:02Z")

</div>

do you have any solution for that problem… i have same problem… its missing installation folder…

---

<div class="post-metadata">

**Author:** ![modifiedcontent](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/modifiedcontent/32/511_2.png) [@modifiedcontent](https://forum.mautic.org/u/modifiedcontent)\
**Post date:** [September 19, 2022, 3:17pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/3 "2022-09-19T15:17:48Z")

</div>

I probably misunderstood your question, but if you have Mautic on a subdomain like `mywebsite.com/mautic`, you manually have to add/change this in your .htaccess file:

```auto
    <If "%{REQUEST_URI} =~ 
m#^/mautic/(index|index_dev|upgrade/upgrade)\.php#">
        Require all granted
    </If>

```

If you put your Mautic installation on another subdomain name than `/mautic/`, like `/crm/` or something creative, use that of course.

In general 404 errors after installation could be caused by file permission errors, for example if you went through the installation process via command line as root, instead of as user.

---

<div class="post-metadata">

**Author:** ![mirash01](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/mirash01/32/7762_2.png) [@mirash01](https://forum.mautic.org/u/mirash01)\
**Post date:** [September 19, 2022, 6:06pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/4 "2022-09-19T18:06:42Z")

</div>

hello

I been installing that in different ways and never had installation folder in Mautic directory… dont know why i have checked permissions and was all good. When i open browser and go to Mautic installation automaticly from let say [domian.com/index.php](http://domian.com/index.php) is redirected to [domian.com/installation/index.php](http://domian.com/installation/index.php) but I had installation folder there and browser was empty 404 error.

Could that be issue cos i used Hestia panel as starting point??  
sorry for my english

---

<div class="post-metadata">

**Author:** ![sawlhung](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/sawlhung/32/6368_2.png) [@sawlhung](https://forum.mautic.org/u/sawlhung)\
**Post date:** [December 22, 2022, 12:31pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/5 "2022-12-22T12:31:09Z")

</div>

Make sure not to use -dis on .htaccess file

---

<div class="post-metadata">

**Author:** ![lijo.mathew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lijo.mathew/32/13293_2.png) [@lijo.mathew](https://forum.mautic.org/u/lijo.mathew)\
**Post date:** [December 10, 2024, 12:15pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/6 "2024-12-10T12:15:49Z")

</div>

is this valid for the latest version as well?

I installed 5.2 and the setup went smooth. However, i am getting 404 at /installer

---

<div class="post-metadata">

**Author:** ![marcus42](https://avatars.discourse-cdn.com/v4/letter/m/ac91a4/32.png) [@marcus42](https://forum.mautic.org/u/marcus42)\
**Post date:** [December 10, 2024, 12:59pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/7 "2024-12-10T12:59:50Z")

</div>

That problem was most likely related with the web server configuration (and not Mautic).

Regarding the 404, you first need to understand it.

i.e.  
In this thread, the 404 was most likely a 403 with a missing 403 error page (thus generating a 404 on the 403).

You would be better starting your own thread instead of necro this very old post.

---

<div class="post-metadata">

**Author:** ![lijo.mathew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lijo.mathew/32/13293_2.png) [@lijo.mathew](https://forum.mautic.org/u/lijo.mathew)\
**Post date:** [December 14, 2024, 9:33am UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/8 "2024-12-14T09:33:49Z")

</div>

> [@marcus42](#):
>
> n this thread, the 404 was most likely a 403 with a missing 403 error page (t

 ![image](https://us1.discourse-cdn.com/flex020/uploads/mautic/original/2X/1/1c11dfbfc61c7ff7503b36c63710819d0d6a64a3.png)

---

<div class="post-metadata">

**Author:** ![lijo.mathew](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.mautic.org/lijo.mathew/32/13293_2.png) [@lijo.mathew](https://forum.mautic.org/u/lijo.mathew)\
**Post date:** [December 14, 2024, 3:24pm UTC](https://forum.mautic.org/t/php-when-visiting-subdomain-installer-gives-404-error/21521/9 "2024-12-14T15:24:11Z")

</div>

I had to re-install the whole VM and redo the setup, it is working now
